WBCE Home | WBCE Hilfe | WBCE Addon Repository | Impressum | Datenschutz

WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 22.11.2018 20:56:43

peitman
Member

fckeditor.2.6.11.3

Hallo zusammen,
beim FCK Editor fehlt auf einmal die Leiste mit allen Bearbeitungsicons!
WBCE Version: 1.3.1
PHP Version: 7.2.10

Die Seite lief bis gestern fehlerfrei. Dann wurde das Zielverzeichnis für die Domain umgestellt, da von der alten Seite auf die neue Seite geschaltet wurde. Ich habe den fckeditor.2.6.11.3 bereits mehrfach deinstalliert und wieder instaliert. Auch ander, wie den CKEditor-Standard-Edition.4.6.2.2_1 oder der CKEditor.4.11.1.Developer.Edition führten zu keinem Erfolg.

Des Weiteren erfolgt folgende Meldung im oberen Bereich des Backends:
message will be suppressed on further calls in /srv/www/root/bar00/home/bar00/www/include/phplib/template.inc on line 407

Hat jemand einen Lösungsansatz?

Danke schon einmal.

Offline

#2 22.11.2018 21:09:35

florian
Projektmanagement und Support WBCE CMS

Re: fckeditor.2.6.11.3

Den FCKeditor solltest Du nun wirklich ausrangieren.
Wenn der CKE auch nicht tut, ist meistens ein Slash ( / ) am Ende von WB_URL in der config.php Schuld.
Ein Update auf WBCE 1.3.2 könnte auch nicht schaden.

Offline

#3 22.11.2018 21:16:05

peitman
Member

Re: fckeditor.2.6.11.3

Vielen Dank für die schnelle Hilfe.
Es war der / in der config.php
Die Meldung erscheint allerdings immer noch oben am Rand im Backend.
Ein Update auf 1.3.2 werde ich am Wochenende durchführen.

Grüße D. Peiter

Offline

#4 22.11.2018 21:25:14

florian
Projektmanagement und Support WBCE CMS

Re: fckeditor.2.6.11.3

Erscheint die Meldung auch beim aktuellen CKE?
Aufgrund der Darstellung im Template ist die Meldung auch nur unvollständig lesbar. Bitte ruf mal die Quelltextansicht auf (i.d.R. mit Strg-U). Da müsste dann erkennbar sein, ob es eine Warning oder eine Notice ist und was konkret angekrittelt wird.
Die einfachste Methode ist, bei den Grundeinstellungen die PHP-Fehlerberichte zu deaktivieren.
Aber für die Verwendung von WBCE und PHP 7.2 ist wirklich ein Update auf die aktuelle Version erforderlich.

Offline

#5 22.11.2018 21:28:12

peitman
Member

Re: fckeditor.2.6.11.3

Gibt es was besonderes zu beachten beim Update?

Offline

#6 22.11.2018 21:33:52

florian
Projektmanagement und Support WBCE CMS

Re: fckeditor.2.6.11.3

Siehe Releasenotes:
https://forum.wbce.org/viewtopic.php?id=2289
Für PHP 7.2 ist außerdem ein Patch der include.php von ShowMenu2 erforderlich:
https://forum.wbce.org/viewtopic.php?id=2418

Offline

#7 22.11.2018 21:51:07

peitman
Member

Re: fckeditor.2.6.11.3

Danke thumb_up

Offline

#8 22.11.2018 23:58:14

bernd
Developer

Re: fckeditor.2.6.11.3

Just "for the records":
die (unvollständige) Fehlermeldung ist mit ziemlicher Sicherheit eine "deprecated" Meldung, die sich mit dem Update auf die 1.3.2 erledigen dürfte.


2 x ROT13 hält besser ...

Online

#9 23.11.2018 00:19:20

colinax
Developer

Re: fckeditor.2.6.11.3

Wie bernd es bereits schrieb, template.inc ist in WBCE 1.3.2 für php 7.2 optimiert.

Edit: Aussage korrigiert

Last edited by colinax (23.11.2018 14:26:56)

Offline

Board footer

Powered by FluxBB

up