WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 07.01.2020 23:49:18

herbi
Member

Toggle-Menu geht nur auf erste Seitenebene

Servus,

eine Frage zu einem Toogle-Menu, ähnlich bzw. wie im Template "webezeheh".

Aus einem Responsee-Template, das hier...

Template-Link...

...probehalber eingesetzt wird, stammt dieses Menu:

[== HTML ==]
<div class="top-nav s-12 l-10">
          
          <ul class="right chevron">
            <li class="submenu">
              <a aria-haspopup="true">Home<span class="count-number"> 5</span></a>
              <ul>
                <li><a href="index.html">Home Page 1</a></li>
                <li><a href="index-2.html">Home Page 2</a></li>
                <li><a href="index-3.html">Home Page 3</a></li>
                <li><a href="index-4.html">Home Page 4</a></li>
                <li><a href="animated-elements.html">Animated Elements</a></li>                
              </ul>
            </li>
            <li class="submenu">
              <a aria-haspopup="true">Blog<span class="count-number"> 2</span></a>
              <ul>
                <li><a href="blog.html">Blog Home Page</a></li>
                <li><a href="sample-post.html">Sample Post</a></li>
              </ul>
            </li>
            <li class="submenu">
              <a aria-haspopup="true">Pages<span class="count-number"> 2</span></a>
              <ul>
                <li><a href="sample-page.html">Sample Page</a></li>
                <li><a href="sample-page-with-sidebar.html">Sample Page with Sidebar</a></li>
              </ul>
            </li>
            <li><a href="features.html">Features</a></li>
            <li><a href="elements.html">Elements</a></li>
            <li class="active-item"><a href="typography.html">Typography</a></li>
            <li><a href="gallery.html">Gallery</a></li>
            <li><a href="contact.html">Contact</a></li>
          </ul>
</div>

Die Funktionalität für die Mobile-Ansicht funktioniert aber bei meiner Konfiguration von show_menu2 nicht so richtig.

Ich kann nur die oberste Ebene "Unsere Angebote" anklicken.
Zweite und Dritte gehen dadurch nicht auf.
Was bzw. wie muss ich wo etwas ändern?

Dankeschön für alle Ratschläge.


Jeder meint, seine Wahrheit ist die Richtige.  smile

Offline

#2 08.01.2020 07:34:36

florian
Administrator

Re: Toggle-Menu geht nur auf erste Seitenebene

Standardmäßig darf bei der Responsee-Navigation bei einem Elternelement kein Link hinterlegt sein, da sonst wie in der oben verlinkten die untergeordneten Seiten in der Mobilansicht nicht erreichbar sind.
Abhilfe:
- entweder den Menüaufruf ändern zu

show_menu2(
			$aMenu          = 1,
			$aStart         = SM2_ROOT,
			$aMaxLevel      = SM2_ALL,
			$aOptions       = SM2_ALL|SM2_PRETTY|SM2_BUFFER,
			$aItemOpen      = '<li><a [if (class!=menu-expand) {href="[url]" class="[class]" target="[target]"}]>[menu_title]</a>',
			$aItemClose     = '</li>',
			$aMenuOpen      = '<ul>',
			$aMenuClose     = '</ul>',
			$aTopItemOpen   = false,
			$aTopMenuOpen   = '<ul class="chevron">'
		  );

oder analog zu WBCEZon das Hilfs-Script DoubleTapToGo einbauen, siehe
https://forum.wbce.org/viewtopic.php?id=2652

Offline

#3 08.01.2020 08:12:45

herbi
Member

Re: Toggle-Menu geht nur auf erste Seitenebene

Guten Morgen Florian,

ein herzliches Dankeschön für die super schnelle Lösung.
Nach der Umsetzung gebe ich Bescheid.

thumb_up


Jeder meint, seine Wahrheit ist die Richtige.  smile

Offline

#4 08.01.2020 17:48:46

herbi
Member

Re: Toggle-Menu geht nur auf erste Seitenebene

Hallo Florian,

Danke für die Lösung.
Mit dem Script klappt es einwandfrei.

Und, ein "fettes" Lob an Dich und hier ins Forum.
Immer eine passende Lösung gefunden, schnell und unkompliziert gepostet.
Respekt. thumb_up

Ich weis von was ich rede, ich war im "Alten" auch zwei oder drei Jahre unterwegs.

Danke.


Jeder meint, seine Wahrheit ist die Richtige.  smile

Offline

Liked by:

florian

#5 08.01.2020 23:27:55

herbi
Member

Re: Toggle-Menu geht nur auf erste Seitenebene

Servus,

entgegen des ersten Test, der funktionierte, geht es nun nicht mehr.

[== PHP ==]
$mainnav = show_menu2(
			$aMenu          = 1,
			$aStart         = SM2_ROOT,
			$aMaxLevel      = SM2_ALL,
			$aOptions       = SM2_ALL|SM2_PRETTY|SM2_BUFFER,
			//$aItemOpen      = '<li><a [if (class!=menu-expand) {href="[url]" class="[class]" target="[target]"}]>[menu_title]</a>',
			$aItemOpen      = '<li><a href="[url]" class="[class]" target="[target]">[menu_title]</a>',
			$aItemClose     = '</li>',
			$aMenuOpen      = '<ul>',
			$aMenuClose     = '</ul>',
			$aTopItemOpen   = false,
			$aTopMenuOpen   = '<ul class="right chevron">'
		  );	

und hier das Script...

[== HTML ==]
<script type="text/javascript" src="<?php echo TEMPLATE_DIR; ?>/js/doubletaptogo.min.js"></script>  
<script type="text/javascript">
		$( '.chevron li:has(ul)' ).doubleTapToGo();		
</script>
</body>  
</html>

Woran kann dies liegen?

Hier der Link zum Testen: Template-Link

Sorry für die Fragen.


Jeder meint, seine Wahrheit ist die Richtige.  smile

Offline

#6 08.01.2020 23:56:19

herbi
Member

Re: Toggle-Menu geht nur auf erste Seitenebene

Kommando zurück.
Mit dem Smartphone funktioniert es.
Meine vorherige Beschreibung, wo es nicht erfolgreich war, dass ich da nur die BrowserView veränderte und mit der Mouse anschubste.
smile


Jeder meint, seine Wahrheit ist die Richtige.  smile

Offline

Liked by:

florian

#7 25.05.2020 15:09:04

creatore
Member

Re: Toggle-Menu geht nur auf erste Seitenebene

herbi wrote:

Mit dem Smartphone funktioniert es.
smile

Zumindest bei 'Buschwerk' funktioniert es hochkant (Hamburger) nicht. Bevor die Sublinks auflappen, lädt die übergeordnete Seite.

Korrektur: WIN10 und Chrome, FFox geht doch. Seltsamerweise LNX Mint und FFox nicht. Wie kann das denn sein??

Last edited by creatore (25.05.2020 15:57:00)

Offline

#8 25.05.2020 21:38:36

florian
Administrator

Re: Toggle-Menu geht nur auf erste Seitenebene

Scriptblocker vielleicht?

Offline

Board footer

Powered by FluxBB

up