WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 06.12.2022 16:25:30

Slugger
Member

Version 1.3.43: Deprecated Meldung nach Update auf WBCE 1.5.4 und PHP 8.1

Nach WBCE Update auf 1.5.4 und Umstellung auf PHP 8.1 am 04.12.2022 habe ich nach zwei Tagen wieder beim Kunden vorbeigeschaut und fand diese Meldung im ErrorLog:

2022-12-05T16:35:27+00:00 [Visitor Request] ./pages/kontakt.php
2022-12-05T16:35:27+00:00 [Deprecated] /modules/mpform/paintform.php:[192] from /modules/mpform/paintform.php:[293] new_submission_id "Implicit conversion from float 519688.00000000006 to int loses precision"
2022-12-05T23:18:50+00:00 [Visitor Request] ./pages/kontakt.php
2022-12-05T23:18:50+00:00 [Deprecated] /modules/mpform/paintform.php:[192] from /modules/mpform/paintform.php:[293] new_submission_id "Implicit conversion from float 505557.00000000006 to int loses precision"
2022-12-06T03:43:13+00:00 [Visitor Request]./pages/kontakt.php
2022-12-06T03:43:13+00:00 [Deprecated] /modules/mpform/paintform.php:[192] from /modules/mpform/paintform.php:[293] new_submission_id "Implicit conversion from float 513495.00000000006 to int loses precision"
2022-12-06T11:40:06+00:00 [Visitor Request]./pages/kontakt.php
2022-12-06T11:40:06+00:00 [Deprecated] /modules/mpform/paintform.php:[192] from /modules/mpform/paintform.php:[293] new_submission_id "Implicit conversion from float 125292.99999999999 to int loses precision"

Last edited by Slugger (06.12.2022 18:01:15)


Hoster: ALL-INKL *** Grundsätzliche WBCE Konfig ***
WBCE: 1.5.4 • BE: 2.1.0 • PHP: 8.1.16 * 1. Projekt: FE: Simple responsive • BE: Argos * 2. Projekt: FE: hortal • BE: Argos * 3. Projekt: FE: WBCEZon • BE: Argos * 4. Projekt: FE: WBCETik • BE: Argos
Status Projekt 1-4:  OK

Online

#2 06.12.2022 17:51:10

webbird
Administrator

Re: Version 1.3.43: Deprecated Meldung nach Update auf WBCE 1.5.4 und PHP 8.1

Bitte bei Problemmeldungen immer auch die Version dazu schreiben. In diesem Fall die vom mpForm.


Ich habe eine Amazon-Wishlist. wink Oder spende an das Projekt.
Ich kann, wenn ich will, aber wer will, dass ich muss, kann mich mal

Offline

#3 06.12.2022 17:52:42

webbird
Administrator

Re: Version 1.3.43: Deprecated Meldung nach Update auf WBCE 1.5.4 und PHP 8.1

Zeile 192:

srand((double)microtime()*1000000)

Kannst Du komplett löschen oder mit // auskommentieren.


Ich habe eine Amazon-Wishlist. wink Oder spende an das Projekt.
Ich kann, wenn ich will, aber wer will, dass ich muss, kann mich mal

Offline

#4 06.12.2022 18:00:07

Slugger
Member

Re: Version 1.3.43: Deprecated Meldung nach Update auf WBCE 1.5.4 und PHP 8.1

webbird wrote:

Bitte bei Problemmeldungen immer auch die Version dazu schreiben. In diesem Fall die vom mpForm.

Ist aktualisiert wink


Hoster: ALL-INKL *** Grundsätzliche WBCE Konfig ***
WBCE: 1.5.4 • BE: 2.1.0 • PHP: 8.1.16 * 1. Projekt: FE: Simple responsive • BE: Argos * 2. Projekt: FE: hortal • BE: Argos * 3. Projekt: FE: WBCEZon • BE: Argos * 4. Projekt: FE: WBCETik • BE: Argos
Status Projekt 1-4:  OK

Online

#5 06.12.2022 18:00:44

Slugger
Member

Re: Version 1.3.43: Deprecated Meldung nach Update auf WBCE 1.5.4 und PHP 8.1

webbird wrote:

Zeile 192:

srand((double)microtime()*1000000)

Kannst Du komplett löschen oder mit // auskommentieren.

Vielen Dank, ich berichte  smile


Hoster: ALL-INKL *** Grundsätzliche WBCE Konfig ***
WBCE: 1.5.4 • BE: 2.1.0 • PHP: 8.1.16 * 1. Projekt: FE: Simple responsive • BE: Argos * 2. Projekt: FE: hortal • BE: Argos * 3. Projekt: FE: WBCEZon • BE: Argos * 4. Projekt: FE: WBCETik • BE: Argos
Status Projekt 1-4:  OK

Online

#6 06.12.2022 19:37:38

mrbaseman
Developer

Re: Version 1.3.43: Deprecated Meldung nach Update auf WBCE 1.5.4 und PHP 8.1

die php8.1 Probleme  müssten in der aktuellen Version 1.3.43 gefixed sein, speziell das srand()

Offline

#7 07.12.2022 11:29:37

Slugger
Member

Re: Version 1.3.43: Deprecated Meldung nach Update auf WBCE 1.5.4 und PHP 8.1

mrbaseman wrote:

die php8.1 Probleme  müssten in der aktuellen Version 1.3.43 gefixed sein, speziell das srand()

Hallo Martin,
in beiden aktuellen Version (AOR und Github) ist die Zeile noch Vorhanden.

Ich habe sie jetzt auskommentiert.


Hoster: ALL-INKL *** Grundsätzliche WBCE Konfig ***
WBCE: 1.5.4 • BE: 2.1.0 • PHP: 8.1.16 * 1. Projekt: FE: Simple responsive • BE: Argos * 2. Projekt: FE: hortal • BE: Argos * 3. Projekt: FE: WBCEZon • BE: Argos * 4. Projekt: FE: WBCETik • BE: Argos
Status Projekt 1-4:  OK

Online

#8 07.12.2022 23:43:47

mrbaseman
Developer

Re: Version 1.3.43: Deprecated Meldung nach Update auf WBCE 1.5.4 und PHP 8.1

oh, da ging wohl beim Veröffentlichen was schief - der relevante Commit im November hat seinen Weg leider nicht ins github Repo gefunden...
ich hab daraus jetzt ein neues Release1.3.44 gemacht.

Offline

Liked by:

Slugger

Board footer

up