WBCE Home | WBCE Hilfe | WBCE Addon Repository | Impressum | Datenschutz

WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 04.01.2019 15:06:40

mohnschnecke
Member

[Gelöst] Migration WB 2.12.0 -> WBCE 1.3.3

Guten Tag zusammen,

ich habe versucht eine Migration von Websitebaker 2.12.0 auf WBCE 1.3.3 durchführen. Leider verlief diese nicht ganz reibungslos.
Es wird die PHP-Version 5.6.1 verwendet.

Es wurden folgende Schritte unternommen:

florian wrote:

A direct migration from WB 2.11 would look like this - we have not so much experience with that case, but at least that way worked for WB 2.10.:
I strongly recommend not to try this on a live site, you'd better test it on a working copy first. No warranty that this will work in any case!

  1. Make a backup of the files on your server and the database, store the files of the frontend template in use seperately - you need them lateron

  2. Login to the 2.11 site and uninstall all modules which can be removed without data loss, e.g. admin tools, not used frontend modules

  3. Access the site via FTP and delete everything except the file config.php and the folders media, pages and modules (and their contents)

  4. Upload the WBCE files into the root (so that you have again diectories like /admin, /framework  and so on)

  5. Copy the frontend theme you had in use into the /templates directory

  6. Call yourdomain.com/install/update.php in the browser and run the WBCE update script

  7. Login to your website and update the modules for which updates are available in the WBCE Add-On Repo

  8. Finally, check all pages in the backend and frontend carefully.

As I stated before, newer WB modules won't work with WBCE, at least not out of the box.

Aus einem Thread zum Thema Migration:
https://forum.wbce.org/viewtopic.php?id=2047

So weit so gut. Das Update-Script läuft los und gibt folgende Ausgabe zurück (siehe Anhang).
Auf dem Screenshot des Update-Scripts sieht man bereits, dass dieses nicht erfolgreich durchgelaufen ist, sonst würden am Ende der Tabelle zwei Buttons zu sehen sein.

Ich kann mich anschließend im Backend anmelden, jedoch beim Aufruf des Frontends bekomme ich eine 404-Meldung.

Vielen Dank
Mohnschnecke

Last edited by mohnschnecke (11.01.2019 13:32:32)

Offline

#2 04.01.2019 15:24:23

florian
Projektmanagement und Support WBCE CMS

Re: [Gelöst] Migration WB 2.12.0 -> WBCE 1.3.3

Ich fürchte, die Update-Anleitung enthält einen groben Fehler... das /templates-Verzeichnis bzw. das darin befindliche verwendete Frontend-Template-Verzeichnis und dessen Inhalte sollten wohl besser auch erhalten bleiben. sad
Hast Du ein Backup und kannst mal versuchen, daraus Dein Frontend-Template-Verzeichnis nach /templates zu kopieren und dann nochmal das Updatescript aufrufen?

Last edited by florian (04.01.2019 16:25:42)

Online

#3 04.01.2019 16:10:59

colinax
Developer

Re: [Gelöst] Migration WB 2.12.0 -> WBCE 1.3.3

Die Anleitung enthält keinen Fehler siehe Punkt 5.

Online

#4 04.01.2019 16:19:19

mohnschnecke
Member

Re: [Gelöst] Migration WB 2.12.0 -> WBCE 1.3.3

Hallo zusammen,

danke für die schnellen Antworten.
Die Templates wurden, wie in der Anleitung steht (Punkt 5), ins Fontend-Template-Verzeichnis kopiert. Genauer gesagt, nur das eine welches verwendet wird (Ein custom Template). Muss der komplette Inhalt des /templates/-Verzeichnis kopiert werden? Ich sehe nämlich, dass die alten (nicht mehr vorhandenen) Templates nach wie vor in der Datenbank stehen.

Gruß
Mohnschnecke

Last edited by mohnschnecke (04.01.2019 16:22:33)

Offline

#5 04.01.2019 16:24:47

colinax
Developer

Re: [Gelöst] Migration WB 2.12.0 -> WBCE 1.3.3

Ist das custom Template zu 100% für WB 2.12 entwickelt worden, wenn ja dann ist es zu WBCE inkompatible.

WBCE erkennt nur Templates die nachdem Standard für WB 2.8.x (und kleiner?) entwickelt wurden, korrekt.

Last edited by colinax (04.01.2019 16:25:14)

Online

#6 04.01.2019 16:30:02

colinax
Developer

Re: [Gelöst] Migration WB 2.12.0 -> WBCE 1.3.3

Dann wäre noch interessant welches FTP Programm du verwendest?

Bei Filezilla gibts regelmäßig Probleme dass Files nicht (korrekt) übertragen werden, wenn man Pech hat, ist dass auch noch eine File die Funktionen beinhaltet die in WB und WBCE anspringen, dass dann eben schief geht, da der Inhalt nicht übereinstimmt.

Online

#7 04.01.2019 16:45:38

colinax
Developer

Re: [Gelöst] Migration WB 2.12.0 -> WBCE 1.3.3

mohnschnecke wrote:

Ich sehe nämlich, dass die alten (nicht mehr vorhandenen) Templates nach wie vor in der Datenbank stehen.

Ja, aber auch nur da das Update Script nicht ganz durchgelaufen ist, Step 4 entfernt die alten nicht mehr vorhandenen Einträge.

Online

#8 04.01.2019 16:56:00

mohnschnecke
Member

Re: [Gelöst] Migration WB 2.12.0 -> WBCE 1.3.3

colinax wrote:

Ist das custom Template zu 100% für WB 2.12 entwickelt worden, wenn ja dann ist es zu WBCE inkompatible.

WBCE erkennt nur Templates die nachdem Standard für WB 2.8.x (und kleiner?) entwickelt wurden, korrekt.

Das Template wurde für WB 2.8.3 entwickelt.
Die Websitebaker-Version wurde irgendwann auf 2.10 und schließlich auf 2.12 migriert. Nun steht die Migration auf WBCE an.

Ich verwendete seit Jahren WinSCP.

Ist aus dem Screenshot zu entnehmen, welcher Teil des Updates fehlschlägt? Wurden bereits erfolgreich Migrationen von WB 2.12 auf WBCE 1.3 durchgeführt?

Last edited by mohnschnecke (04.01.2019 16:59:07)

Offline

#9 04.01.2019 17:08:47

colinax
Developer

Re: [Gelöst] Migration WB 2.12.0 -> WBCE 1.3.3

Dann kann es das FTP Programm und das Tempalte nicht sein.

Von WB 2.12 zu WBCE, meines Wissens noch nie, von 2.11 schon, die Anleitung dafür kam ja von mir, Florian hats freundlicherweise übersetzt.

Von der Position im Script her gibts Probleme mit den Modulen, die Meldung "404 Not found" ist keine des Update Scriptes.

Kannst du ein Bild des modules Ordner machen damit wir sehen welche Module vorhanden sind?

Online

#10 04.01.2019 17:20:47

mohnschnecke
Member

Re: [Gelöst] Migration WB 2.12.0 -> WBCE 1.3.3

Modules-Verzeichnis im Anhang

Offline

#11 04.01.2019 17:58:31

colinax
Developer

Re: [Gelöst] Migration WB 2.12.0 -> WBCE 1.3.3

WBlingual, SimpleCommandDispatcher.inc und SimpleRegister.php bitte löschen.

Danach das Update Script über in die Adresszeile klicken und enter drücken neuladen und nochmal durchführen, sollte dieses mal funktinieren.


Verwendet deine Seite im Frontend mehrere Sprachen, wenn ja muss dass danach mit unserem Multilang Modul neu eingestellt werden.

Online

#12 04.01.2019 18:39:11

mohnschnecke
Member

Re: [Gelöst] Migration WB 2.12.0 -> WBCE 1.3.3

Das install-Verzeichnis und somit die update.php waren nicht mehr vorhanden.

Ich habe sie erneut ins WBCE-Verzeichnis kopiert und ausgeführt.
Die 404-Meldung ist schon mal weg...

Screenshot im Anhang.

Macht hier eine erneute "saubere" Migration (diesmal ohne die genannten Module (WBlingual, SimpleCommandDispatcher.inc und SimpleRegister.php) Sinn?
Würde dies zu einem anderen Ergebnis führen?

Gruß
Mohnschnecke

Offline

#13 04.01.2019 20:09:02

colinax
Developer

Re: [Gelöst] Migration WB 2.12.0 -> WBCE 1.3.3

Dann sind wir schon richtig unterwechs haben aber nicht alles erwischt.

Lösche bitte mal das Form Modul und versuche erneut das Update Script auszuführen.

Wenn das dann immer noch nicht klappt benenne den aktuellen modules Ordner um und lade den modules Ordner aus dem WBCE Package erneut hoch.

Wenn du möchtest kannst du mir per PM einen FTP und WBCE Zugang schicken dann kann ich es für dich übernehmen.

Last edited by colinax (04.01.2019 20:09:32)

Online

#14 07.01.2019 19:21:14

colinax
Developer

Re: [Gelöst] Migration WB 2.12.0 -> WBCE 1.3.3

Gibt's hierzu schon ein Update?

Online

#15 11.01.2019 13:18:48

mohnschnecke
Member

Re: [Gelöst] Migration WB 2.12.0 -> WBCE 1.3.3

Hallo colinax,

ich habe das Form-Modul gerade gelöscht und das Update Script erneut ausgeführt.
Diesmal war es erfolgreich (Siehe Screenshot).

Vielen Dank für die Hilfe.

Last edited by mohnschnecke (11.01.2019 13:20:24)

Offline

#16 11.01.2019 16:00:10

colinax
Developer

Re: [Gelöst] Migration WB 2.12.0 -> WBCE 1.3.3

Danke für das Update und gut zuhören dass das Update durch ist.

Passt im Frontend und Backend auch soweit alles oder gibt es noch wo Probleme bzw. ein komisches Verhalten?

Online

Board footer

Powered by FluxBB

up