WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 08.04.2021 10:18:52

mastermind
Member

WBCE Änderungen für PHP 8

Hallo,
habe die Änderungen gemacht, die für PHP 8 notwendig sind. Es sind lediglich 5 Dateien die in der Version 1.4.5 geändert werden müssen, damit eine Standardinstallation unter PHP Version 8 lauffähig ist. Vielleicht kann das mal jemand ebenfalls ausprobieren.

Im Logfile werden allerdings 2 Meldungen angezeigt:
2021-04-08T09:56:34+02:00 [User Deprecated] \include\Sensio\Twig\lib\Twig\Autoloader.php:[12] from \include\Sensio\Twig\TwigConnect.php:[3] "The Twig_Autoloader class is deprecated since version 1.21 and will be removed in 2.0. Use Composer instead."
2021-04-08T09:56:34+02:00 [User Deprecated] \include\Sensio\Twig\lib\Twig\Autoloader.php:[30] from \include\Sensio\Twig\TwigConnect.php:[4] Twig_Autoloader::register "Using Twig_Autoloader is deprecated since version 1.21. Use Composer instead."

Da ich WBCE erst seit einer Woche benutze, sehe ich selbst keine Möglichkeit, diese Fehler zu beseitigen. Sie stören allerdings beim Betrieb nicht. Für den Einsatz auf einem produktiven Server muss das allerdings gelöst werden. Vielleicht kann das jemand machen, denn WBCE unter PHP 8 läuft einiges schneller, besonders auch die Admin Funktionen.

Ansonsten großes Lob für das erstklassige Produkt. Habe einige Produkte in der letzten Zeit getestet, WBCE ist von der einfachen Installation und klaren Bedienung für mich das Beste. Konnte sofort ein Bootstrap Template (Version 5) erstellen und durch Einsatz des CKEditors wurde auch der HTML Code nicht ungewollt abgeändert - das ist auch ein Vorteil gegenüber anderen Produkten.

Anbei ein Link zur ZIP Datei, in der die Änderungen für Version 8 enthalten sind, sowohl Version 7 (Original) als auch die geänderte Version. Ebenso ist das Error-Log als text dabei:

"karuna-mudita.de/WBCE/wbceV8.zip"

Offline

Liked by:

florian, Slugger, jean

#2 08.04.2021 10:56:46

florian
Administrator

Re: WBCE Änderungen für PHP 8

Toll, Danke dafür! Wir schauen uns das so schnell wie möglich an.

Offline

#3 08.04.2021 13:39:33

colinax
Administrator

Re: WBCE Änderungen für PHP 8

Hallo mastermind,

vielen Dank für die Unterstützung.

Die Änderungen in der class.database, class.wb und die Twig Fehler sind bereits im aktuellen Entwicklungsstand enthalten bzw. behoben.

In der OPF\functions.php wurde glaube ich nur die opf_replace_sysvar deinerseits angepasst, ist auch bereits im aktuellen Entwicklungsstand behoben.

Kannst du uns sagen welcher Fehler/Notice usw. zu den Anpassungen der framework\functions.php geführt.

In der sm2\include.php kann ich leider keine Anpassungen feststellen, was hättest du hier angepasst?


Wenn du möchtest kannst du den aktuellen Entwicklungsstand von WBCE auf GitHub runterladen und testen

lg

Last edited by colinax (08.04.2021 13:40:02)


Mein GitHub Profil: https://github.com/Colinax

Offline

#4 08.04.2021 14:08:57

bernd
Developer

Re: WBCE Änderungen für PHP 8

@colinax:
denke die Änderung in der framework/functions.php (Änderung der Reihenfolge der Parameter für delRow) wurde durchgeführt auf Grund der Änderung in der class.database.php
Das Thema das wir gestern bereits hatten.

@mastermind zum Verständnis:
die Änderung der Parameter Reihenfolge in der class.database.php ist eher suboptimal, da dadurch jeder Aufruf von delRow entsprechend angepasst werden muss! Und das betrifft wesentlich mehr als nur die Funktion delete_page in der functions.php. Da sind auch etliche Module von betroffen...
Damit handelt man sich einen Fehler ein, der dann erst nach und nach auftaucht, z.B. beim Löschen eines Modules etc.


... nein in Europa verwenden wir beim Programmieren nicht € statt $ ...

Online

Liked by:

colinax

#5 09.04.2021 15:18:50

mastermind
Member

Re: WBCE Änderungen für PHP 8

Hallo collnax:
ja Du hast Recht, die function opf_insert_sysvar habe ich noch (nicht) angepasst.
Zum Verständnis: das Setup habe ich noch unter PHP 7 gemacht, d.h. beim Setup können noch einige Probleme auftreten, die korrigiert werden müssen.

Änderung in der sm2/include:
function error_logs($error_str)
{
    $log_error = false;
    if (defined('SM2_DEBUG')) {
        if (SM2_DEBUG === true) {
            $log_error = true;
        }
    }
/*    $log_error = (SM2_DEBUG AND SM2_DEBUG === true) ? true : false;*/

weil nicht definierte Konstante sonst eine Fehlermeldung verursacht.


Hallo bernd:
ich hatte folgendes gelesen:
"PHP 8 deprecated required declaring functions/methods that have optional parameters before required ones. "

Deswegen die Änderung in framework/functions. Sollte das weitreichende Auswirkungen haben, muss man da noch die eigentliche Lösung erarbeiten, da hast Du Recht.

Ansonsten vielen Dank für die schnelle Reaktion und Euer Engagement.

Offline

#6 10.04.2021 17:13:57

mastermind
Member

Re: WBCE Änderungen für PHP 8

Hallo Collnax,

"Wenn du möchtest kannst du den aktuellen Entwicklungsstand von WBCE auf GitHub runterladen und testen"

Das habe ich gemacht, läuft für mich problemlos. Habe ganz frisch mit einer Neuinstallation und leerer Datenbank begonnen.

Es läuft alles ohne Probleme und Fehlermeldungen - bis auf die Sitemap, die nicht funktioniert.

Habe den Code geändert und so funktioniert es bei mir mit folgender Umgebung:

Apache/2.4.46 (Win64) OpenSSL/1.1.1j PHP/8.0.3
Server-Version: 10.4.18-MariaDB - mariadb.org binary distribution
Datenbank-Client Version: libmysql - mysqlnd 8.0.3
PHP-Version: 8.0.3

Den geänderten Code (modules/sitemap/view.php) findest Du auf:

"karuna-mudita.de/WBCE/sitemap.zip"

LG

Offline

Liked by:

florian

#7 10.04.2021 17:15:57

florian
Administrator

Re: WBCE Änderungen für PHP 8

Hallo mastermind,

Du kannst übrigens hier im Forum jetzt Links setzen und Anhänge hochladen.

Offline

#8 10.04.2021 18:08:04

colinax
Administrator

Re: WBCE Änderungen für PHP 8

Hallo mastermind,

mit deiner Vermutung, dass es an den Anführungszeichen liegt warst du schon nahe dran, aber bitte keine Backticks bei DB Abfragen löschen, die werden zwingend benötigt.

Hab den Fehler in der view.php behoben, kannst du die view.php im Anhang bei dir testen ob diese das Problem löst?


Welchen Code(Editor) verwendest du für diese Korrekturen?

lg


Mein GitHub Profil: https://github.com/Colinax

Offline

#9 11.04.2021 20:11:26

mastermind
Member

Re: WBCE Änderungen für PHP 8

Hallo collnax,
ja, diese Version funktioniert auch bei mir. Vielen Dank für die schnelle Antwort!

Ich verwende als Editor den NuSphere PhpED in der Professional Version.
Der ist so eingestellt, dass er führende Leerzeichen in Tabs umwandelt, das wird dir den Vergleich Originalversion und Änderungen etwas erschweren. Deswegen lade ich auch die Originalversion in meinen Editor und speichere nochmal, das macht es einfacher.

Noch eine Kleinigkeit: Beim Editieren mit dem CKeditor sollte doch in der Überschrift der Seitenname stehen - oder?
Siehe auch nachfolgenden Screenshot:
Hardcopy

Offline

#10 11.04.2021 20:37:01

bernd
Developer

Re: WBCE Änderungen für PHP 8

Diese Zeile gehört nicht zum CKE sie ist in jedem Abschnitt egal welcher Art vorhanden in ihr sind Infos zum jeweiligen Abschnitt (Block) enthalten.
Das "Name" bezieht sich auf den Namen des Abschnitts den man in der Abschnitts-Verwaltung vergeben kann.
Ist recht praktisch zur besseren Orientierung mit vielen Abschnitten auf einer Seite.


... nein in Europa verwenden wir beim Programmieren nicht € statt $ ...

Online

Board footer

Powered by FluxBB

up