WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 28.03.2024 15:09:02

rheo
Member

[gelöst] Update-Problem

Liebe ExperInnen

Ich habe zwei WBCE-WebSites, die ich wegen der folgenden Mitteilung meines Hosting-Providers updaten möchte :

Wir möchten Sie darüber informieren, dass in der Woche vom 01.04.2024 bis 05.04.2024 eine Aktualisierung unseres Servers auf die MySQL-Version 8.0.35 durchgeführt wird. Damit Ihr Web-Erlebnis auch nach diesem Update reibungslos verlauft, bitten wir Sie, die folgenden Schritte zu befolgen:
-    Aktualisieren Sie Ihr Content Management System (CMS): Stellen Sie sicher, dass Sie die neueste Version Ihres verwendeten CMS nutzen. Falls Sie Unterstützung dabei benötigen, empfehlen wir die Kontaktaufnahme eines entsprechenden Webseiten-Anbieters.
-    Überprüfen und Aktualisieren von Plugins: Falls Sie Plugins oder Erweiterungen in Ihrem System verwenden, überprüfen Sie bitte, ob diese mit der neuen MySQL-Version kompatibel sind. Aktualisieren Sie gegebenenfalls Ihre Plugins auf die neueste Version.
-    Verwenden Sie eine aktuelle PHP-Version: Wir empfehlen Ihnen, eine aktuelle Version von PHP zu verwenden, um die Sicherheit und Leistung Ihrer Webapplikationen zu gewährleisten. Unter dem folgenden Link finden Sie die Versionen, welche verwendet werden sollten: https://www.php.net/supported-versions.php

Bei der ersten einfachen WebSite hat das Update reibungslos geklappt :
Von WBCE 1.4.4 mit PHP 7.4.33 FCGI auf WBCE 1.6.2 mit PHP 8.2.17 FCGI.

Bei der zweiten sehr umfangreichen WebSite gibt es aber Probleme :

Das WBCE-Update von Version 1.4.0 auf 1.6.2 lief (anscheinend) noch einwandfrei.
Beim Umstellen der PHP-Version von 7.4.33 FCGI auf 8.2.17 FCGI war das Frontend aber dann plötzlich komplett leer (auch ohne Fehlermeldung). Auch im Backend waren diverse Fenster leer.

Ich habe daraufhin ein Update aller veralteten Module gemäss ‘Module Update Check’ gemacht. Auch das hat geklappt, bis auf zwei Module, die einen violetten Punkt in der Liste haben (CodeMirror Configurator & znip Childs2Tabs).
Die WebSite blieb im Browser aber weiterhin leer, wohingegen im Backend alles vorhanden zu sein scheint.
Sobald ich die PHP-Version wieder auf 7.4.33 downgrade, ist im Browser alles wieder da und funktioniert wohl einwandfrei.

Jetzt bin ich etwas ratlos, da ich mich mit dem technischen Hintergrund nicht auskenne.
Wo müsste ich ansetzen, um den Fehler zu finden ?
Könnte es daran liegen, dass ich einzelne php-Dateien in den Modulen angepasst habe ? (Diese habe ich noch nicht wieder hochgeladen.)

Vielen Dank im Voraus für eure Hinweise !
rheo

Last edited by florian (28.03.2024 18:37:05)

Offline

#2 28.03.2024 16:40:27

florian
Administrator

Re: [gelöst] Update-Problem

Bitte mal ins Errorlog schauen (Admintools > Errorlog Viewer)


Code allein macht nicht glücklich. Jetzt spenden!

Offline

#3 28.03.2024 16:51:29

rheo
Member

Re: [gelöst] Update-Problem

Im Errorlog hat es ziemlich viele Einträge, die wohl auch immer wieder gelöscht werden.

Ich habe heute Vormittag nach den Problemen die Meldungen herauskopiert.
Darf ich dir einen Auszug per PM schicken ?

Offline

#4 28.03.2024 16:52:22

florian
Administrator

Re: [gelöst] Update-Problem

Ja, kannst Du machen.


Code allein macht nicht glücklich. Jetzt spenden!

Offline

#5 28.03.2024 18:36:33

florian
Administrator

Re: [gelöst] Update-Problem

So, der bzw. das Schuldige ist gefunden, und zwar das Droplet "LastModifiedPages" in der (Ursprungs-)Fassung von Dev4Me - da steht nämlich "MYSQL_ASSOC" drin, und das muss in "MYSQLI_ASSOC" geändert werden.

Wenn das Droplet übers Template auf allen Seiten eingebunden ist, wird im Frontend nirgendwo etwas angezeigt.
Etwas irreführend: Die Fehlermeldung verweist auf die droplets.php

2024-03-28T16:26:24+00:00 [Exception] There was an unknown exception: Undefined constant "MYSQL_ASSOC" in line (20) of /modules/droplets/droplets.php(24) : eval()'d code

Aber dank der neu eingeführten Funktion, die Droplets einzeln deaktivieren zu können, konnte dann das Problem-Droplet recht schnell ausfindig gemacht werden.


Code allein macht nicht glücklich. Jetzt spenden!

Offline

#6 28.03.2024 18:42:27

rheo
Member

Re: [gelöst] Update-Problem

Vielen Dank, lieber Florian, für die wieder einmal sehr kompetente und schnelle Hilfe !!

Offline

Liked by:

florian

Board footer

up