WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 21.06.2018 15:54:30

jurefly
Member

Update auf 1.3.1

Da ich im Forum keinen Beitrag finden konnte hier mein Problem. Nach dem Update auf 1.3.1 kann ich nicht mehr auf das Backend meiner Seite zugreifen. Bei allen Nutzern kommt die Meldung: Username oder Passwort stimmen nicht. Das komische an der Geschichte ist, dass das Anfordern neuer Passwörter über den "Vergessen-Button" wohl funktioniert, da sich der Hasheintrag in der User-Datenbank ändert. Ein Zugriff mit dem geänderten Passwort ist aber ebenfalls nicht möglich.

Offline

#2 21.06.2018 15:56:01

florian
Administrator

Re: Update auf 1.3.1

Update-Script ausgeführt?
(Update-Anleitung siehe https://forum.wbce.org/viewtopic.php?pid=15661#p15661)

Last edited by florian (21.06.2018 15:57:48)

Offline

#3 21.06.2018 16:00:13

jurefly
Member

Re: Update auf 1.3.1

Ja - keine Fehlermeldung - Internetseite funktioniert einwandfrei.

Offline

#4 21.06.2018 16:04:17

florian
Administrator

Re: Update auf 1.3.1

Und da kommt tatsächlich die Meldung "Der Benutzername oder das Passwort ist nicht korrekt" und nicht einfach gar nichts (also kommentarloser Reload der Loginseite)?
Hast Du irgendwelche sehr speziellen Sonderzeichen, Umlaute oder Leerzeichen im Benutzernamen und/oder Passwort verwendet?

Offline

#5 21.06.2018 16:12:37

jurefly
Member

Re: Update auf 1.3.1

Sind Alles einfache Nutzernamen und Passwörter. Auch die per Kopie eingefügten Passwörter, die per Mail zugeschickt werden bringen die gleiche Meldung "Der Benutzername oder das Passwort ist nicht korrekt - und dies bei den drei Usern, von denen ich die Passwörter besitze. Ein 3-faches Vertippen sollte dabei auszuschließen sein.

Offline

#6 21.06.2018 16:16:26

florian
Administrator

Re: Update auf 1.3.1

Hm.
Kannst Du mir bitte FTP- und Backend-Zugangsdaten per PM oder an support@wbce.org zusenden, dann schaue ich mir das mal an. Wir hatten dieses Problem bislang noch nicht.

Offline

#7 21.06.2018 16:24:36

jurefly
Member

Re: Update auf 1.3.1

OK.
Inzwischen habe ich das Update über die Sicherung wieder rückgängig gemacht. Das hat aber das Anmeldeproblem nicht beseitigt.

Offline

#8 21.06.2018 16:58:50

florian
Administrator

Re: Update auf 1.3.1

Wie gesagt, bitte mal Zugangsdaten zusenden

Offline

#9 21.06.2018 18:14:00

florian
Administrator

Re: Update auf 1.3.1

Ich habs rausgefunden. Warum auch immer, es waren alle Benutzeraccounts deaktiviert - ich habe die drei mitgeteilten jetzt wieder reaktiviert, falls die restlichen auch wieder Zugriff erhalten sollen, kann dies über die Benutzerverwaltung erfolgen (siehe ggf. Hilfe)
Außerdem war beim Updaten/Zurückspielen irgendwas schief gegangen, zwischenzeitlich wurde die Seite gar nicht angezeigt. Ich habe dann nochmal das Update ausgeführt, nun läuft die Seite wieder.

Puh! *Schweißvonderstirnwisch*

Offline

Liked by:

byteworker

#10 21.06.2018 19:22:10

jurefly
Member

Re: Update auf 1.3.1

Vielen Dank für die schnelle und unkomplizierte Hilfe. Und das Du mir das Update gleich auch aufgespielt hast, finde ich einfach SUPER!!

Offline

Liked by:

florian

#11 04.07.2018 19:53:29

schrobak
Member

Re: Update auf 1.3.1

Ist das Reaktivieren ein großes Geheimnis? wink
Offenbar gibt es Konstellationen, die beim Update diesen Fehler reproduzierbar machen. Das Deaktivieren der Nutzerkonten kann ich bei 1 Seite mehrfach wiederholen, auf 2 anderen ist das Update von 1.2.0 auf 1.3.0  problemlos durchgelaufen: Das Update-Script läuft fehlerlos durch, das Frontend funktioniert, im Backend ist kein Zugang möglich, weil Username und Passwort nicht zusammenpassen. Auf Anforderung bekomme ich ein neues Passwort, das aber auch nicht funktioniert.

@florian: Kann ich das Problem selbst beheben / welche Informationen brauchst du ?
z.Zt. läuft die Problemseite weiter mit 1.2.0

lG
Andreas

Offline

#12 04.07.2018 20:14:09

florian
Administrator

Re: Update auf 1.3.1

Ein Update auf 1.3.0 ist eher mäßig sinnvoll, aktuell ist (noch) 1.3.1 (und in Kürze - diesmal wirklich -) wird es die 1.3.2 geben.
Wenn alle Accounts deaktiviert sind, wobei ich gerade keine Idee habe, woran das liegen könnte, hilft nur der Zugriff auf die Datenbank und dort in der Tabelle users bei den jew. Accounts den Wert für active auf 1 setzen.

Offline

#13 04.07.2018 20:33:52

schrobak
Member

Re: Update auf 1.3.1

Vielen Dank schon mal für den Hinweis; das werde ich dann mal versuchen.
Das Update der anderen Seiten auf 1.3.0 ist auch schon eine Weile her, inzwischen sind diese bereits auf 1.3.1 problemlos weitergedreht worden. Nur diese 1 Seite widersetzt sich.
Melde mich wieder, wenn da was geschehen ist.

Offline

#14 04.07.2018 23:03:22

colinax
Administrator

Re: Update auf 1.3.1

@jurefly und schrobak

Welche php Version verwendet ihr?

Und habt ihr Zugriff auf die DB logs?


Mein GitHub Profil: https://github.com/Colinax

Offline

#15 05.07.2018 21:48:30

schrobak
Member

Re: Update auf 1.3.1

PHP = 7.0  (7.1 ist möglich)
DB log: Sag ich mal "Nein". Im Verzeichnis "log" sind etliche Log-Dateien, deren Inhalt sich mir aber nicht auf Anhieb erschließt. Sag mit mal, was du suchst, dann finde ich evtl. was.

Offline

#16 06.07.2018 08:30:42

colinax
Administrator

Re: Update auf 1.3.1

schrobak wrote:

PHP = 7.0  (7.1 ist möglich)

Okey, dann liegt es an php mal nicht, die php Version 7.1.1 ist ziemlich stark verbugt.

schrobak wrote:

DB log: Sag ich mal "Nein". Im Verzeichnis "log" sind etliche Log-Dateien, deren Inhalt sich mir aber nicht auf Anhieb erschließt. Sag mit mal, was du suchst, dann finde ich evtl. was.

Also im log Verzeichnis von WBCE sollte eigentlich nichts drinnen sein.

Es kann natürlich sein dass das Verzeichnis des Hosters auch so heißt.

Hast du in den log Verzeichnissen (ggf im Unterverzeichnis mysql) eine Binary log Datei?


Mein GitHub Profil: https://github.com/Colinax

Offline

Board footer

Powered by FluxBB

up