WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 13.07.2019 19:32:01

chap
Member

Discours Foren / Diskussionen mit Topics!

Hallo Ihr,

ihr findet sicherlich direkt die Lösung dafür. Ich hab es nun mehrfach probiert aber ich bekomme es nicht hin.
Ich habe mir ein Discourse Forum Aufgebaut und möchte das jetzt mit allen Topics die ich habe verbinden.
Es ist einfach nur ich habe ein Problem, ich muss das mit dem Replace_Me ein Direkt URL erstellen können.
Ich hatte mir daher gedacht am besten mit Code2. Jetzt hab ich aber das Problem das ich einfach nicht auf den Punkt komme wie ich die Variable setzen kann das er immer bei jeden Topics (was in Discourse bereits als Whitelist gesetzt ist) hinterlegt.

Das ist das Original Script was ich einbinden muss:

[== HTML ==]
<div id='discourse-comments'></div>

<script type="text/javascript">
  DiscourseEmbed = { discourseUrl: 'https://www.3c6.de/',
                     discourseEmbedUrl: 'REPLACE_ME' };

  (function() {
    var d = document.createElement('script'); d.type = 'text/javascript'; d.async = true;
    d.src = DiscourseEmbed.discourseUrl + 'javascripts/embed.js';
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(d);
  })();
</script>

Das REPLACE_ME muss sich für jede Topic Seite wie folgt sein:

[== HTML ==]
<div id='discourse-comments'></div>

<script type="text/javascript">
  DiscourseEmbed = { discourseUrl: 'https://www.3c6.de/',
                     discourseEmbedUrl: 'https://www.xprog.de/topics/xprogde-im-neuen-design/' };

  (function() {
    var d = document.createElement('script'); d.type = 'text/javascript'; d.async = true;
    d.src = DiscourseEmbed.discourseUrl + 'javascripts/embed.js';
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(d);
  })();
</script>

Das heißt ich muss eine Variable finden, was zB. mit:

[== PHP ==]
<?php $url =(isset($_SERVER['HTTPS'])?'https':'http').'://' . $_SERVER['HTTP_HOST'] . $_SERVER['REQUEST_URI']; echo "$url"; ?>

ganz simple realisieren kann.

Wenn ich im Code2 jetzt die Art PHP nehme und das so mache, funktioniert das nicht. Ich bekomme dann immer Fehler und die Seite ist zerstört.
Mir ist bekannt das ich hier da wohl mit echo arbeiten muss aber ich hab kein Plan wie, so das ich den gesamten Code Schnipsel verwenden kann.


Liebe Grüße,
cHAp

Mit WBCE Realisiert: xProg.de - MailDa.de - cliffdoelling.de - wazeSN.de

Online

#2 13.07.2019 22:28:20

florian
Administrator

Re: Discours Foren / Diskussionen mit Topics!

Versuch mal folgendes:
In der /modules/topics/view_final.php nach

$setting_topic_block2 = str_replace(array_keys($event_placeholders), array_values($event_placeholders), $setting_topic_block2);		
	}

einfügen:

$topic_link = WB_URL.$topics_virtual_directory.$topic['link'].PAGE_EXTENSION;	

und in derselben Datei nach

'[ADDITIONAL_PICTURES]'	=> $additional_pictures,

einfügen:

'[LINK]'				=> $topic_link,

Damit hast Du nun den Platzhalter [LINK], der die URL zum aktuellen Topic beinhaltet, auch in der Topic-Detailansicht zur Verfügung.

Nun im Topics-Einstellungen > Thema > Fußzeile den Discourse-Code einfügen, dabei  REPLACE_ME durch  [LINK] (exakt so, in eckigen Klammern und Großbuchstaben, Hochkommara davor und danach drin lassen) ersetzen.

Code2 oder PHP brauchst Du dann nicht.

Online

#3 13.07.2019 22:51:33

chap
Member

Re: Discours Foren / Diskussionen mit Topics!

Ok, komischerweise läd er aber dann den ältesten Beitrag. Ich bin hier:  https://www.xprog.de/topics/xprogde-im-neuen-design/ und wenn ich auf Diskussion beginnen klicke kommt aber https://www.3c6.de/t/xprog-de-ein-gesch … farnox/308
hm... komisch...


Liebe Grüße,
cHAp

Mit WBCE Realisiert: xProg.de - MailDa.de - cliffdoelling.de - wazeSN.de

Online

#4 13.07.2019 23:00:39

florian
Administrator

Re: Discours Foren / Diskussionen mit Topics!

Bei Topics kann ich leider nur im Nebel stochern. Versuch mal, den Code zu ändern wie folgt:

$current_topic_link = WB_URL.$topics_virtual_directory.$topic['link'].PAGE_EXTENSION;

Die o.g. Zeile muss unbedingt NACH der } stehen (also direkt vor der Zeile, die mit $placeholders beginnt)

Und das andere zu

'[THISLINK]'				=> $current_topic_link,

und dann logischerweise mit [THISLINK] aufrufen.

Last edited by florian (13.07.2019 23:01:29)

Online

#5 13.07.2019 23:04:10

chap
Member

Re: Discours Foren / Diskussionen mit Topics!

da kommt keine auslieferung =>  discourseEmbedUrl: '' };


Liebe Grüße,
cHAp

Mit WBCE Realisiert: xProg.de - MailDa.de - cliffdoelling.de - wazeSN.de

Online

#6 13.07.2019 23:05:32

florian
Administrator

Re: Discours Foren / Diskussionen mit Topics!

Hast Du eine view.final.custom.php im Einsatz?

Online

#7 13.07.2019 23:09:36

chap
Member

Re: Discours Foren / Diskussionen mit Topics!

florian wrote:

Versuch mal folgendes:
In der /modules/topics/view_final.php nach

$setting_topic_block2 = str_replace(array_keys($event_placeholders), array_values($event_placeholders), $setting_topic_block2);		
	}

einfügen:

$topic_link = WB_URL.$topics_virtual_directory.$topic['link'].PAGE_EXTENSION;	

und in derselben Datei nach

'[ADDITIONAL_PICTURES]'	=> $additional_pictures,

einfügen:

'[LINK]'				=> $topic_link,

Damit hast Du nun den Platzhalter [LINK], der die URL zum aktuellen Topic beinhaltet, auch in der Topic-Detailansicht zur Verfügung.

Nun im Topics-Einstellungen > Thema > Fußzeile den Discourse-Code einfügen, dabei  REPLACE_ME durch  [LINK] (exakt so, in eckigen Klammern und Großbuchstaben, Hochkommara davor und danach drin lassen) ersetzen.

Code2 oder PHP brauchst Du dann nicht.

Damit ging es doch... Mein Fehler ... Hab nicht nach dem } eingefügt. smile


Liebe Grüße,
cHAp

Mit WBCE Realisiert: xProg.de - MailDa.de - cliffdoelling.de - wazeSN.de

Online

Liked by:

florian

Board footer

Powered by FluxBB

up