WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 21.08.2020 10:46:25

gottfried
Member

[Gelöst] WB 2.8.3 build 2005 nach WBCE 1.4.4

Hallo!

Thema: ************

Also - ich habe da eine wb 2.8.3 Installation Build 2005 - vermute die gibt es gar nicht offiziell, weil die schon ein system.ini.php hat aber zB
noch WB_URL in der Datenbank.

Im Grund ist mein Problem wohl einfach - im Frontend kommen keine Seiten - aber es ist zu heiß zu denken.
Hab fast 4h gebraucht um alle meine Hitzefehler zu korrigieren bis das Backend lief.

Im Frontend kommt nur eine leere Seite.
Das aber erst seit ich im config.php http auf https geändert habe.
Vorher kam die Seite aber ohne css (Farben, schrift, bg, die Ursprungsseite ist https)
- hatte ich in der config.php falsch erstellt.

Fehlermeldungen sind zwar
2020-08-21T09:27:20+00:00 [Notice] /admin/start/index.php:[111] from /admin/start/index.php:[111] WBCE_Error->scriptError "Undefined variable: wbce_latest_release"
2020-08-21T09:29:12+00:00 [Exception] There was an unknown exception: Class 'WbDatabase' not found in line (26) of /modules/libraryadmin/inc/init.inc.php
Irgendwie könnte es auch Probleme mit anytopics und libraryadmin geben, theoretisch.

aber vor der Änderung auf https  kam die Seite ja, nur leicht schräg.

????? :-) wo fang ich an?

Last edited by florian (21.08.2020 11:04:52)

Offline

#2 21.08.2020 12:13:41

florian
Administrator

Re: [Gelöst] WB 2.8.3 build 2005 nach WBCE 1.4.4

Leeres Frontend:
- Bleibt das Frontend auch leer, wenn Du testweise auf das Template WBCEZon umstellst?
- Welche Version von LibraryAdmin ist installiert?
-Wird LA überhaupt für irgendwas benötigt, oder kann das ggf. ganz deinstalliert werden?

Wegen der Notice zu wbce_latest_release:
bitte in der config.php

define('SHOW_UPDATE_INFO',false);

ergänzen, da scheint keine Verbindung zu Github zwecks Versionsüberprüfung hergestellt werden zu können.

Offline

#3 21.08.2020 13:02:11

gottfried
Member

Re: [Gelöst] WB 2.8.3 build 2005 nach WBCE 1.4.4

Hallo Florian!



Leeres Frontend:
- Bleibt das Frontend auch leer, wenn Du testweise auf das Template WBCEZon umstellst?
NEIN
- Welche Version von LibraryAdmin ist installiert?
-Wird LA überhaupt für irgendwas benötigt, oder kann das ggf. ganz deinstalliert werden?
GUTE FRAGE. sieht so aus als ob ich das nicht benötige.


Wegen der Notice zu wbce_latest_release:
bitte in der config.php

define('SHOW_UPDATE_INFO',false);

ergänzen, da scheint keine Verbindung zu Github zwecks Versionsüberprüfung hergestellt werden zu können.

Hm - ich änder das mal. WBCE telefoniert im Hintergrund mit Github?

Ich hab von dir netterweise auf die Sprünge geholfen aus dem speziellen Template der Seiten einen Aufruf rausgenommen
[[LibInclude?lib=lib_jquery&preset=colorbox]]
und jetzt gehts.

Muß irgendetwas vergessenes antiquarisches sein, weil ich ja lightbox verwende.


Also 1000 Dank vorerst!!!!

Offline

#4 21.08.2020 14:24:58

colinax
Administrator

Re: [Gelöst] WB 2.8.3 build 2005 nach WBCE 1.4.4

gottfried wrote:

Hm - ich änder das mal. WBCE telefoniert im Hintergrund mit Github?

Was verstehst du unter "telefoniert" genau?

aber zur Frage Nein, WBCE telefoniert nicht mit GitHub sondern nur mit sich selbst und schaut ob die lokal vorhandene Version die neueste ist.


gottfried wrote:

"Undefined variable: wbce_latest_release"

Kann es sein dass du den Patch für WBCE 1.4.4 nicht hochgeladen hast?

Offline

#5 21.08.2020 16:46:44

gottfried
Member

Re: [Gelöst] WB 2.8.3 build 2005 nach WBCE 1.4.4

Hallo Florian und Colinax!

Ich bin total happy, daß mittels eurer Mithilfe mein eigentliches Problem nun gelöst ist. smile  smile  smile  smile  alles andere ist für mich eher nebensächlich


Was ich mit "telefonieren" meinte ist "Github".  Diverse jquery-schnippsel "telefonieren" ja z.B auch gerne mit Google.
Das ist eigentlich nicht besonders wichtig für mich, weil ja jede DNS Abfrage mit einem DNS Server unter dem Einfluss von
z.B 1.1.1.1 Googel und 8.8.8.8 IBM steht aufgelöst wird.  Kann man eh nichts gegen machen,
daß der Weltinternetverkehr von den Illuminaten getraced wird. lol

Ja, kann gut sein, daß ich den patch nicht hochgeladen hab, obwohl ich mir die Version 1.4.4 eigentlich erst gestern runtergeladen habe.


Brauche ich in D eigentlich so einen Cookie Vorspann, auch wenn ich keine Persönlichen Daten erfasse?
Die IP wird doch eh von 1.1.1.1 oder 8.8.8.8 erfasst.

Oder frage ich da besser einen Rechtsanwalt?

:-)

Offline

#6 21.08.2020 20:00:15

florian
Administrator

Re: [Gelöst] WB 2.8.3 build 2005 nach WBCE 1.4.4

Also ich versteh nicht ganz, was das mit 1.1.1.1 und 8.8.8.8 jetzt mit WBCE zu tun hat. Die 1.4.4 baut eine Verbindung zu Github auf und schaut, ob es da einen WBCE-Release mit eine höheren Versionsnummer gibt. Mehr nicht.

In der 1.4.4 ist der Patch nicht enthalten (deshalb ist es ja ein Patch), von Haus aus sind die Änderungen erst in der 1.4.5 enthalten, die wir demnächst als (voraussichtlich...) letzten Minor Release veröffentlichen, bevor dann mit der 2.0  ein völlig neues Kapitel beginnt.

Zur Cookiefrage: wenn Du die in 1.4.4 eingeführte Möglichkeit nutzt, den Frontend-Cookie zu deaktivieren (siehe Releasenotes), und auch sonst keine anderen Cookies setzt, brauchst Du kein Cookiebanner. Wenn Du CDN nutzt, also von externen Quellen Scripte oder Schriften lädst, oder Google Maps oder Social Media-Plugins ohne Zwei-Klick-Lösung einsetzt, führt an einer entsprechenden Unterrichtung der Besucher via Cookie-Banner (und natürlich Datenschutzerklärung sowieso) kein Weg vorbei.

Last edited by florian (21.08.2020 20:01:08)

Offline

#7 22.08.2020 08:29:18

gottfried
Member

Re: [Gelöst] WB 2.8.3 build 2005 nach WBCE 1.4.4

Hallo Florian!

Also ich versteh nicht ganz, was das mit 1.1.1.1 und 8.8.8.8 jetzt mit WBCE zu tun hat.
> Nichts. Ich wollte nur sagen, daß allgemein bei jeder DNS Auflösung die IP mitgeht.
Die 1.4.4 baut eine Verbindung zu Github auf und schaut, ob es da einen WBCE-Release mit eine höheren Versionsnummer gibt. Mehr nicht.
> Ich versteh schon. Aber wo ist da z.B der Unterschied zu von Google eine Schrift zu laden?

In der 1.4.4 ist der Patch nicht enthalten (deshalb ist es ja ein Patch), von Haus aus sind die Änderungen erst in der 1.4.5 enthalten, die wir demnächst als (voraussichtlich...) letzten Minor Release veröffentlichen, bevor dann mit der 2.0  ein völlig neues Kapitel beginnt.
> Kapiert!

Zur Cookiefrage: wenn Du die in 1.4.4 eingeführte Möglichkeit nutzt, den Frontend-Cookie zu deaktivieren (siehe Releasenotes), und auch sonst keine anderen Cookies setzt, brauchst Du kein Cookiebanner.

> Absolut wichtig die Information "den Frontend-Cookie deaktivieren" - ich mach mich schlau - danke!

Wenn Du CDN nutzt, also von externen Quellen Scripte oder Schriften lädst, oder Google Maps oder Social Media-Plugins ohne Zwei-Klick-Lösung einsetzt, führt an einer entsprechenden Unterrichtung der Besucher via Cookie-Banner (und natürlich Datenschutzerklärung sowieso) kein Weg vorbei.

> Danke für die umfangreiche Information!

Offline

#8 22.08.2020 12:20:34

gottfried
Member

Re: [Gelöst] WB 2.8.3 build 2005 nach WBCE 1.4.4

Hallo!

Da war heute ein passender Artikel auf Heise zwecks DNS Auflösung. Ist ja wahrscheinlich eh hinlänglich bekannt:

https://www.heise.de/news/Privatsphaere … 64255.html

:-)

Offline

Liked by:

florian

Board footer

Powered by FluxBB

up