WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 21.09.2020 07:42:30

florian
Administrator

WBCE CMS 1.4.5 RC1 verfügbar / available

DE (english information follows)

WBCE 1.4.5 RC1* ist ab sofort als Installations-/Upgradepaket auf GitHub verfügbar.

* Release Candidate bedeutet: Die Version sollte noch nicht produktiv eingesetzt werden. Es ist für uns und die Weiterentwicklung und Fehlerbehebung aber wichtig und hilfreich, möglichst viele Testergebnisse aus unterschiedlichen Vorgängerversionen / Server-Umgebungen zu haben, wer also die Möglichkeit hat, auf einem Testsystem eine Installation / ein Update durchzuführen, ist sehr herzlich dazu eingeladen, dies zu tun und Ergebnisse / Fragen hier im Forum zu posten.

Was ist neu in 1.4.5?

Die Version 1.4.5 wird ein Sicherheits- und Wartungsrelease sein. Neue Features sind darin nicht enthalten. Es wird aber zumindest für Installationen, bei denen mehrere Personen Backend-Zugriff haben, empfohlen, das Update zeitnah einzuspielen, sobald die stabile Version verfügbar ist.

Sicherheitsrelevante Änderungen:

  • Update für Medienverwaltung

Aktualisierungen:

  • News with Images 5.0.7

  • CKEditor 4.15.0

  • Errorlogger 1.2

  • PHPMailer 6.1.7

Fehlerkorrekturen:

  • SM2_DEBUG-Switch wieder ergänzt (kein standardmäßiges Loggen von Menüaufruf-"Fehlern")

  • Darstellungsfehler in der Droplet-Übersicht bei Verwendung des Fraggy-Backend-Themes behoben

  • Beim Löschen von Seiten wird nun auch das ggf. zugehörige Verzeichnis gelöscht

  • Medienverwaltung zeigt wieder standardmäßig Thumbnails (und diese bei Mouseover etwas größer)

  • Unterstrich für Session-ID zugelassen

  • Überflüssige, nicht genutzte Verzeichnisse im Root entfernt

-

Kompatibilität/Systemvoraussetzungen
  • WBCE CMS 1.4.5 RC-1 ist freigegeben für PHP 7.1 bis PHP 7.4. Darunter oder darüber liegende PHP-Versionen werden nicht unterstützt.

-

Vielen Dank an alle Beteiligten an diesem Release, insbesondere colinax.

-

Anleitung Neuinstallation
  1. Das Installationspaket herunterladen und wie hier beschrieben verfahren

  2. Anmelden und Loslegen

Anleitung Update
  1. Datensicherung machen (Dateisystem auf dem Server) - WICHTIG

  2. Datenbanksicherung erstellen (Dump/Export, z.B. mit PhpMyAdmin oder Adminer) - WICHTIG

  3. Das Installationspaket herunterladen und lokal entpacken

  4. Wie hier beschrieben verfahren. Hinweis: wurde das /admin-Verzeichnis auf dem Server umbenannt, vor dem Upload die Umbenennung entsprechend im Installationspaket anpassen!
    *Bitte beachten, dass beim Update grundsätzlich alle vorhandenen Core-Dateien überschrieben werden. Falls also Anpassungen an den Standard-Templates WBCEZon/WBCETik vorgenommen wurden, unbedingt diese vor dem Upload aus dem Installationspaket entfernen, da sonst die auf dem Server befindlichen angepassten Versionen überschrieben werden.

  5. Updater aufrufen, Hinweis lesen und bestätigen und auf "Start Update Script" klicken

  6. Ggfs. im Zuge des Upgrades überschriebene Anpassungen an Modulen (->frontend.js/css) und Templates durch Zurückkopieren der zuvor lokal gesicherten Dateien wiederherstellen

  7. Am Backend anmelden

  8. Ggfs. nicht benötigte Module und Templates über Erweiterungen > Module bzw. Erweiterungen > Templates wieder deinstallieren

Mit dem Update-Script können alle vorherigen Versionen von WBCE (und ggf. ältere WB-Versionen bis 2.8.3 SPxx - für Migrationen von neueren Versionen bitte Kontakt zu uns aufnehmen) ohne Zwischenschritte auf WBCE CMS 1.4.5 RC-1 aktualisiert werden.

Offline

Liked by:

colinax, giz, chap

#2 21.09.2020 07:53:16

florian
Administrator

Re: WBCE CMS 1.4.5 RC1 verfügbar / available

EN

WBCE 1.4.5 RC-1  is now available as an installation / upgrade package on GitHub.

What's new in 1.4.5?

In this version, a security issue and several small bugs are fixed. This time, there will be no new features. Nevertheless it's strongly recommended to update to 1.4.5 (when the stable release is available) at least for WBCE sites with multi user environments.

Security:

  • Update for media management

Updates:

  • News with Images 5.0.7

  • CKEditor 4.15.0

  • Errorlogger 1.2

  • PHPMailer 6.1.7

Bug fixes:

  • SM2_DEBUG-Switch working again (menu call "errors" are not longer logged by default)

  • Fix for display issues in droplets overview when using the Fraggy Backend Theme

  • When pages are deleted, the corresponding subdirectory is removed as well

  • Thumbnail preview in media management by default (also the preview images are a bit larger)

  • Allow underscore for session ID

  • Unnecessary, not used directories removed from root

-

Compatibility / system requirements
  • WBCE CMS 1.4.5 is released for PHP 7.1 to PHP 7.4. PHP versions below or above are not supported.

-

Many thanks to all contributors of this version, specially to colinax.

-

New installation (as usual)
  1. Download Installer* and unzip it locally

  2. Proceed this way

  3. Log in and start working

Updating
  1. Backup your files on the server - IMPORTANT

  2. Create a database backup (dump / export, f. ex. using mit PhpMyAdmin or Adminer) - IMPORTANT

  3. Download installation package and unzip it locally

  4. Proceed this way. Please note: If you have renamed the admin directory on the server, you have to change the directory name in the upload package accordingly before copying the files onto the server
    *Please keep in mind that during the update all core files will be overwritten. So do not forget to remove the directories templates/WBCEZon or templates/WBCETik from the local installation package before uploading it, if you have applied individual changes to one of these templates on your server, otherwise these changes will be lost.

  5. Call the update script. Read the advices, check the checkbox and start the update script.

  6. If necessary, rollback unwanted changes on templates or modules by backcopying the corresponding single files from the local backup (->frontend.js/css)

  7. Log-In to the Backend

  8. If necessary, remove not used modules and templates via Add-Ons > Modules / add-Ons > Templates

The update script can be used to update all prior versions of WBCE (and possibly WB up to 2.8.3 SPxx - for migratins from newer WB versions please contact us) directly to WBCE CMS 1.4.5 RC-1.

Offline

Liked by:

stefanek

Board footer

Powered by FluxBB

up