WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 29.09.2020 07:48:38

giz
Member

[erledigt] Unvollständiges laden der EditArea

Hallo zusammen!

Eine Sache, die mich schon sehr lange stört und bei der ich auf Fehlersuche nicht wirklich weiterkomme ist folgendes:
Bereiche, bei denen Editarea geladen wird - wie zB. bei "Vorschaltseite bearbeiten", oder in den Admin-Tools die Einstellungen bei "Cookie Consent" bearbeiten, oder eben auch der "cwsoft-addon-file-editor" - laden nicht immer vollständig, oder zum Teil gar nicht.
Zur Veranschaulichung der Screenshot.
oberstes Bild: vollständiges Laden, Ansicht wie gewünscht.
linkes, unteres Bild: nur Inhalt (Text) wird geladen, der Editor selbst nicht.
rechtes, unteres Bild: nichts wird geladen.

Durch Klicken von F5 wird der komplette Inhalt manchmal geladen, manchmal auch nach mehrmaligem Ausführen nicht, oder eben nur teilweise. Besonders nervig ist das dann, wenn ein Neuladen der Seite dann noch zusätzlich eine Bestätigung anfordert. So kann man sich manchmal mit 20- oder mehr rumgeklicke hübsch die Zet vertreiben...
Kennt das noch jemand, bzw. gibt's da einen Lösungsansatz?
Weder im Errorlog-Viewer, noch in den Server Logs sind diesbezüglich Fehlermeldungen verzeichnet.
Ich hatte nur einmal, nach wiederholtem ergebnislosem Laden des AFE folgende Meldung im Errorlogviewer (wahrscheinlich, weil er nicht vollständig geladen wurde)

2020-09-21 06:30:12 	Notice 	/modules/cwsoft-addon-file-editor/code/action_handler.php L:96
from /modules/cwsoft-addon-file-editor/code/action_handler.php L:96 	WBCE_Error->scriptError "Undefined index: "
2020-09-21 06:30:12 	Notice 	/modules/cwsoft-addon-file-editor/code/action_handler.php L:96
from /modules/cwsoft-addon-file-editor/code/action_handler.php L:96 	WBCE_Error->scriptError "Trying to access array offset on value of type null"
2020-09-21 06:30:12 	Warning 	/modules/cwsoft-addon-file-editor/code/action_handler.php L:96
from /modules/cwsoft-addon-file-editor/code/action_handler.php L:96 	array_merge "array_merge(): Expected parameter 2 to be an array, null given"
2020-09-21 06:30:12 	Warning 	/modules/cwsoft-addon-file-editor/code/action_handler.php L:96
from /modules/cwsoft-addon-file-editor/code/action_handler.php L:96 	WBCE_Error->scriptError "Invalid argument supplied for foreach()" 

Wie gesagt, ich habe das schon ewig so, egal welche WBCE-Version, PHP-Version.

siehe auch hier...da wurde ja schonmal angefangen....
https://forum.wbce.org/viewtopic.php?id=3490

edit 2.10.: typo

Last edited by giz (02.10.2020 07:38:38)


WBCE 1.4.5 - Fraggy 2.5.2 - PHP 7.4.10 - All-inkl
Ein Leben ohne Hund ist möglich, aber sinnlos

Offline

#2 29.09.2020 08:26:01

colinax
Administrator

Re: [erledigt] Unvollständiges laden der EditArea

Hallo giz,

Sind dies die Angaben "WBCE 1.4.4 - Fraggy 2.5.2 - PHP 7.4.10 - All-inkl" die des Hosters auf der die Seite läuft?

Ist das AFE in der neuesten Version installiert bzw. ändert sich etwas wenn der AFE deinstalliert wird?

Hast du das CodeMirror Modul installiert?

Was auch wichtig ist bitte mache von der Browser Konsole inkl. dem gesamten Browser Fenster einen Screenshot.

Dann sehen wir was da stört dass die Ansicht nicht korrekt geladen wird.

lg

Offline

#3 29.09.2020 09:31:45

berny
Member

Re: [erledigt] Unvollständiges laden der EditArea

man sollte bei fehlerhaften Phänomenen Strg+F5 bzw Shift+ Reloade verwenden, nur dann ist sichergestellt, dass die scripte wirklich neu und nicht aus dem cache (uU fehlerhaft gespeichert) geladen werden.

Offline

#4 02.10.2020 07:31:43

giz
Member

Re: [erledigt] Unvollständiges laden der EditArea

Sorry für die späte Antwort, war auf Schulung.

Es sieht so aus, als ob ich den Schuldigen des auslösenden Verhaltens gefunden habe.
Ein Addon (WX Download Status Bar) im FF, das sich in die jeweilige Seite selbsttätig einpflegt (The addon will need permission to access all sites because it has to inject a bit of HTML into each page you visit to display the download bar.), hat immer mal wieder das vollständige Laden behindert.  roll
Danke thumb_up


WBCE 1.4.5 - Fraggy 2.5.2 - PHP 7.4.10 - All-inkl
Ein Leben ohne Hund ist möglich, aber sinnlos

Offline

#5 02.10.2020 17:41:22

colinax
Administrator

Re: [erledigt] Unvollständiges laden der EditArea

Schön zu hören dass das Problem behoben werden konnte.

Solche Addons ( IMHO oder der mittlerweile extrem veraltete und unsichere Firefox Browser ) gehören sowieso verboten.

Um solche Probleme zu vermeiden empfehle ich den neuen Microsoft Edge zu verwenden.

Lg

Edit: Ich hab das Thema als erledigt markiert

Last edited by colinax (02.10.2020 17:42:45)

Offline

Board footer

Powered by FluxBB

up