WBCE Home | WBCE Hilfe | WBCE Addon Repository | Impressum | Datenschutz

WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 27.01.2017 11:47:35

cybernet333
Member

Modul Oneforall "Verzweifelt....."

Hallo liebes Team,

ich hoffe Ihr könnt mir weiter helfen?

Ich habe den Auftrag erhalten ein kleines Immobilienportal zu errichten.
Also dachte ich mir mit "Oneforall" läßt sich das bestimmt gut umsetzen.
Gesagt getan Übersichtsseite erstellt und passt soweit.
Wäre ansich perfekt wenn da nicht das Problem mit dem Feldtyp "Modul OneForAll Link" wäre.

Ich habe einige felder angelegt was auch alles Ok ist und angezeigt wird.
Aber sobald ich im letzten Feld "Modul OneForAll Link" etwas auswähle (Link zu einer Seite) wird mir die Übersichtsseite nicht mehr korrekt angezeigt.

(Angenommen es sind 6 Anzeigen auf der Übersichtsseite, und ich setze bei Anzeige 3 den Link. Dann werden nur Anzeige 1 und 2 angezeigt und der rest fehlt?)

Ich hoffe ich konnte mich verständlich ausdrücken und Ihr könnt mir weiterhelfen.
Wäre Super dringend.

Danke schon mal im vorraus.

Offline

#2 27.01.2017 12:25:56

florian
Administrator

Re: Modul Oneforall "Verzweifelt....."

Prüfe bitte mal, was im Feld-Template steht. Eventuell ist der Link nicht geschlossen.
Oder mal PHP-Fehlerberichte einschalten und schauen, ob dann irgendwelche Meldungen angezeigt werden.

Offline

#3 27.01.2017 12:57:01

cybernet333
Member

Re: Modul Oneforall "Verzweifelt....."

Vielen Dank schon mal für die Schnelle Antwort.

Also im Feld Template steht:
<div class="mod_oneforall_oneforall_link_f">
    <div class="mod_oneforall_field_content_f">
        <a href="[CUSTOM_CONTENT]">[CUSTOM_LABEL]</a>
    </div>
</div>

sollte doch ok sein?

Wie genau kann ich mir die Fehler Anzeigen lassen bzw. Fehlerberichte einschalten?

Offline

#4 27.01.2017 12:59:34

florian
Administrator

Re: Modul Oneforall "Verzweifelt....."

Eigentlich schon, wobei es halt darauf ankommt, was OfA als [CUSTOM_CONTENT] erzeugt.
Fehlerberichte => Grundeinstellungen, erweitert, PHP-Fehlerberichte = E_EVERYTHING

Hast Du mal einen Link zur SEite, ggf. per PM oder an support@wbce.org - das ist am Ende schneller als Nebelstochern.

Offline

#5 27.01.2017 13:18:09

cybernet333
Member

Re: Modul Oneforall "Verzweifelt....."

Also jetzt kommen wir vielleicht weiter. wink

Es kommt folgende Meldung:

Fatal error: Call to a member function numRows() on null in /homepages/xx/###/htdocs/modules/oneforall/view_overview.php on line 304

der Auszug der Datei sieht ja so aus:

// For oneforall_link convert item_id to detail page link
                if ($types[$field_id] == 'oneforall_link') {
                    if (is_numeric($values[$field_id])) {
                        $query = "SELECT p.link as page_link, i.link as item_link FROM `".TABLE_PREFIX."pages` p
                                INNER JOIN `".TABLE_PREFIX."mod_".strtolower($extra[$field_id])."_items` i
                                ON p.page_id = i.page_id
                                WHERE i.item_id = ".$values[$field_id]." AND active = '1'
                                ORDER BY i.item_id
                                LIMIT 1";
                        $get_links = $database->query($query);
                        if ($get_links->numRows() > 0) {
                            $links             = $get_links->fetchRow();               
                            $values[$field_id] = WB_URL.PAGES_DIRECTORY.$links['page_link'].$links['item_link'].PAGE_EXTENSION;
                        } else {
                            $values[$field_id] = '';
                        }
                    }
                }


Die dicke rote Zeile (304) soll der Fehler sein.

Offline

#6 27.01.2017 13:22:53

florian
Administrator

Re: Modul Oneforall "Verzweifelt....."

Keine Ahnung, wie das zu fixen ist, leider.

Workaround: Normales Textfeld statt Link-Feld verwenden und da jeweils [wblink123] (123 = Page-ID der Zielseite) eintragen.

Feld-Template beibehalten

<div class="mod_oneforall_oneforall_link_f">
    <div class="mod_oneforall_field_content_f">
        <a href="[CUSTOM_CONTENT]">[CUSTOM_LABEL]</a>
    </div>
</div>

Das sollte eigentlich funktionieren.

Offline

#7 27.01.2017 13:36:59

cybernet333
Member

Re: Modul Oneforall "Verzweifelt....."

Hmmmmmm Schade das ist jetzt nicht wirklich befriedigend.  sad

Auf jeden Fall vielen Dank für die super Hilfe. Das nenn ich mal fix.
Nur so ist es leider nicht brauchbar.
Für mich ginge es, aber es sollen andere Leute die Daten pflegen/erstellen und da ist dies dann nicht Optimal.

Leider..

Offline

#8 27.01.2017 13:39:08

florian
Administrator

Re: Modul Oneforall "Verzweifelt....."

Welche OfA-Version ist das? Schon die neueste?

Offline

#9 27.01.2017 13:45:48

cybernet333
Member

Re: Modul Oneforall "Verzweifelt....."

florian wrote:

Welche OfA-Version ist das? Schon die neueste?

Version:     0.9.7

Offline

#10 27.01.2017 13:46:38

florian
Administrator

Re: Modul Oneforall "Verzweifelt....."

Versuch mal ein Update, es gibt schon die 1.0.3. VORHER DATENSICHERUNG!

Offline

#11 27.01.2017 14:03:08

cybernet333
Member

Re: Modul Oneforall "Verzweifelt....."

Leider auch mit der Version:    1.0.3 selbes Ergebnis.
Jetzt sogar im Backend fehler.  big_smile

Dann wird das wohl auf Wordpress hinauslaufen.  cry

Offline

#12 27.01.2017 14:03:50

florian
Administrator

Re: Modul Oneforall "Verzweifelt....."

Was für Fehler im Backend?

Offline

#13 27.01.2017 14:09:03

florian
Administrator

Re: Modul Oneforall "Verzweifelt....."

Dann wird das wohl auf Wordpress hinauslaufen.  cry

Ich weiß nicht, was so was soll. Motivationsfördernd ist das nicht gerade.
Wenn Du so viel Zeit hast, die Site mit Wordpress neu zu machen, ist es mir unverständlich, dass Du hier erst so einen Stress machst.

Offline

#14 27.01.2017 14:13:20

cybernet333
Member

Re: Modul Oneforall "Verzweifelt....."

Fatal error: Call to a member function numRows() on null in /homepages/43/d356082336/htdocs/modules/oneforall/modify.php on line 115

********modify.php***********
<?php
// Get group names
$query_fields = $database->query("SELECT field_id, extra, label FROM `".TABLE_PREFIX."mod_".$mod_name."_fields` WHERE type = 'group' LIMIT 1");
if ($query_fields->numRows() > 0) {
    $field    = $query_fields->fetchRow();
    $field_id = $field['field_id'];
    $label    = $field['label'];
    $a_groups = explode(',', stripslashes($field['extra']));
    array_unshift($a_groups, '&#8211;');
} else {
    $field_id = false;
}
?>

Offline

#15 27.01.2017 14:13:51

florian
Administrator

Re: Modul Oneforall "Verzweifelt....."

Falls mal wer anders dasselbe Problem hat
attachment.php?item=641&download=1

Last edited by florian (27.01.2017 14:15:12)

Offline

#16 27.01.2017 14:14:31

cybernet333
Member

Re: Modul Oneforall "Verzweifelt....."

cybernet333 wrote:

Fatal error: Call to a member function numRows() on null in /homepages/43/d356082336/htdocs/modules/oneforall/modify.php on line 115

********modify.php***********
<?php
// Get group names
$query_fields = $database->query("SELECT field_id, extra, label FROM `".TABLE_PREFIX."mod_".$mod_name."_fields` WHERE type = 'group' LIMIT 1");
if ($query_fields->numRows() > 0) {
    $field    = $query_fields->fetchRow();
    $field_id = $field['field_id'];
    $label    = $field['label'];
    $a_groups = explode(',', stripslashes($field['extra']));
    array_unshift($a_groups, '&#8211;');
} else {
    $field_id = false;
}
?>


if ($query_fields->numRows() > 0) {

Offline

#17 27.01.2017 14:17:13

cybernet333
Member

Re: Modul Oneforall "Verzweifelt....."

Jetzt kann man das Modul auch nicht mehr entfernen/deinstallieren.
Mann oh Mann dachte das wird alles ganz easy.

Offline

#18 27.01.2017 14:18:28

florian
Administrator

Re: Modul Oneforall "Verzweifelt....."

Du kannst Module nicht deinstallieren, so lange sie noch irgendwo auf einer Seite verwendet werden.

Offline

#19 27.01.2017 14:19:26

cybernet333
Member

Re: Modul Oneforall "Verzweifelt....."

florian wrote:

Dann wird das wohl auf Wordpress hinauslaufen.  cry

Ich weiß nicht, was so was soll. Motivationsfördernd ist das nicht gerade.
Wenn Du so viel Zeit hast, die Site mit Wordpress neu zu machen, ist es mir unverständlich, dass Du hier erst so einen Stress machst.

Sorry nicht falsch Verstehen.
Es gibt eine Wordpress Seite, aber genau von dieser will ich ja eigentlich weg.
Ich finde WBCE 1000mal besser und würde deshalb gerne mit diesem System Arbeiten.

Offline

#20 27.01.2017 14:22:34

florian
Administrator

Re: Modul Oneforall "Verzweifelt....."

Okay, verstehe.
Wenn Du willst, lass mir mal Backend-Zugangsdaten per PM zukommen, dann schaue ich mal direkt.
Ansonsten bitte noch etwas warten, bevor Du alles in die Tonne trittst, gib auch dem Modulhersteller die Gelegenheit, hier zu antworten.

Offline

#21 27.01.2017 14:23:15

cybernet333
Member

Re: Modul Oneforall "Verzweifelt....."

florian wrote:

Du kannst Module nicht deinstallieren, so lange sie noch irgendwo auf einer Seite verwendet werden.

Ja das weiß ich, aber es läßt sich nicht entfernen. Da kommt dann immer wieder die Meldung:
Fatal error: Call to a member function numRows() on null in /........../htdocs/modules/oneforall/delete.php on line 37

Aber ich bleibe dran.

Offline

#22 27.01.2017 14:35:49

cybernet333
Member

Re: Modul Oneforall "Verzweifelt....."

florian wrote:

Falls mal wer anders dasselbe Problem hat
https://forum.wbce.org/attachment.php?i … download=1

das wird der Fehler gewesen sein. Ich meine das war leer?

Offline

#23 27.01.2017 14:42:34

florian
Administrator

Re: Modul Oneforall "Verzweifelt....."

Ja, leider ist es nur jetzt irgendwie völlig zerschossen.
Hast Du beim Update den Haken vor "Überschreibe neuere Dateien" gesetzt?

Offline

#24 27.01.2017 14:47:12

cybernet333
Member

Re: Modul Oneforall "Verzweifelt....."

florian wrote:

Ja, leider ist es nur jetzt irgendwie völlig zerschossen.
Hast Du beim Update den Haken vor "Überschreibe neuere Dateien" gesetzt?

"nein"

Offline

#25 27.01.2017 14:50:25

florian
Administrator

Re: Modul Oneforall "Verzweifelt....."

Okay. Das dürfte der Grund für die Fehler im Backend sein.
Ändere mal auf dem Server in der info.php von OfA die Version von 1.0.3 auf 1.0.2 und rufe dann im Backend die Modulverwaltung auf. Klicke dort auf "Erweitert" oben rechts und dann auf "Module neu laden".
Nun müsste es möglich sein, OfA 1.0.3 nochmal zu installieren/aktualisieren - diesmal bitte das erwähnte Überschreibehäkchen setzen.

Last edited by florian (27.01.2017 14:50:53)

Offline

Board footer

Powered by FluxBB

up