WBCE Home | WBCE Hilfe | WBCE Addon Repository | Impressum | Datenschutz

WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 05.12.2017 09:57:37

selle
Member

Darstellungs-Assistent funktioniert nicht mehr

Hallo in die Runde,

Mein Provider hat meine HP auf PHP 7 umgestellt.

Seit dem kann ich den Darstellungs-Assistent im Frontend nicht mehr benutzen. Sobald ich diesen anklicke, lande ich auf der Startseite der Webseite. Da ich dieses Modul SEHR häufig verwende und dabei ziemlich oft die Anzahl der Spalten in der Vorschau anpassen muss, ist das ziemlich fatal.

Hat vielleicht bitte jemand eine Idee, an welcher Schraube hier gedreht werden muss?

Danke schon mal im Voraus
Stefan


"Gras wächst auch nicht schneller, wenn man daran zieht..."

Offline

#2 05.12.2017 11:13:10

colinax
Developer

Re: Darstellungs-Assistent funktioniert nicht mehr

Hi selle,

eigentlich dürfte es da keine Probleme geben, ich betreibe selber eine Seite mit RFG und php 7.

Kannst du mir sagen welche WBCE Version du hast und ob in der Browser-Konsole Fehler angezeigt werden, wenn du dich als angemeldeter User auf der Frontendseite (mit der RFG) befindest?


Die aktuellste Versionen von CKEditor gibt’s im AOR und auf meiner GitHub Seite.

Offline

#3 05.12.2017 12:16:39

selle
Member

Re: Darstellungs-Assistent funktioniert nicht mehr

Hallo colinax,

danke für die schnelle Reaktion!!!
Ich verwende die Version 1.3.0 von WBCE und wenn ich angemeldet bin, wird auf der Frontendseite (RFG) nur ein Fehler angezeigt:


JQMIGRATE: Migrate is installed, version 1.4.1
jquery-min.js:4 [Deprecation] Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check https://xhr.spec.whatwg.org/.

Der ist aber auf jeder Seite vorhanden, auch ohne RFG!

Es funktioniert auch soweit alles, nur wenn ich auf der Frontendeseite auf den Link "Darstellungs-Assistent" klicke, lande ich auf der Startseite der Homepage.
Wenn ich allerding auf Seitenendit gehe und da dann beim Abschnitt RFG den Setup-Assistent anklicke, kann ich, wie gewohnt, die hht auswählen oder eben Spalten- und Zeilen-Einstellungen vornehmen. Ist zwar umständlicher, geht aber erstmal als Notbehelf. Das wusste ich vorhin beim Post noch nicht...

Gruß
Stefan

Last edited by selle (05.12.2017 12:18:23)


"Gras wächst auch nicht schneller, wenn man daran zieht..."

Offline

#4 05.12.2017 12:45:50

colinax
Developer

Re: Darstellungs-Assistent funktioniert nicht mehr

So ich hab auf meiner Seite den Fehler reproduzieren können.

Der Fehler wird durch den neuen Output Filter in WBCE 1.3 verursacht (Ursache und Lösung sind bekannt).

Um den Fehler am einfachsten zu beheben, musst Du unter Admin-Tools -> Output Filter -> Den Filter "Frontendausgabe mit relativen URLs:" auf deaktiviert setzten dann funktioniert alles wieder wie gewohnt.

Wir arbeiten bereits an einem Release wo dieser Fehler behoben ist.


Die aktuellste Versionen von CKEditor gibt’s im AOR und auf meiner GitHub Seite.

Offline

Liked by:

selle

#5 05.12.2017 13:35:37

selle
Member

Re: Darstellungs-Assistent funktioniert nicht mehr

1.000 Dank für die Info - you made my day  smile


"Gras wächst auch nicht schneller, wenn man daran zieht..."

Offline

Liked by:

colinax

Board footer

Powered by FluxBB

up