WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 12.09.2018 10:38:09

concipio
Member

[gelöst] Text im Backend nicht mehr sichtbar

Hallo zusammen,

nachdem mein Problem "Seiten im Backend nach Update nicht sichtbar" gelöst wurde, habe ich nun ein ähnliches, aber anderes Rätsel:
auf einer anderen Seite ist nun - ohne update - der Text im Backend nicht mehr sichtbar! Die Verwaltungsebene ist da, der Seitenbaum öffnet sich, Seiten können angeklickt werden, aber der Text erscheint nicht und kann somit auch nicht bearbeitet werden (siehe Bild).

Habe mehrere Browser und PCs bemüht, Caches geleert, mehrere Backend-Templates ausprobiert, neu installiert - nichts.
Habe es mit http und https versucht, auch nichts. Habe die php-Version zurückgesetzt (falls der Hoster das automatisch aktualisiert hatte und das Template dort nicht läuft) - kein Erfolg.

Läuft auf WBCE 1.2.0 seit über einem Jahr stabil.

Was kann ich noch tun?

Danke!
Suse

Last edited by florian (12.09.2018 11:39:41)

Offline

#2 12.09.2018 10:42:03

florian
Administrator

Re: [gelöst] Text im Backend nicht mehr sichtbar

Sieht nach einem Problem mit dem CKEditor (bzw. sonstigen eingestellten Editor) aus.  Vielleicht hilft es, den mal zu deinstallieren und nochmal neu zu installieren.

Offline

#3 12.09.2018 10:48:56

ice
Member

Re: [gelöst] Text im Backend nicht mehr sichtbar

Javascript abgeschaltet?

Online

#4 12.09.2018 10:54:55

concipio
Member

Re: [gelöst] Text im Backend nicht mehr sichtbar

Leider nein.

Offline

Liked by:

ice

#5 12.09.2018 11:01:41

florian
Administrator

Re: [gelöst] Text im Backend nicht mehr sichtbar

Mal mit F12 die Browser-Entwicklertools anzeigen und zur Konsole wechseln, stehen da irgendwelche Fehlermeldungen?
Wird der Seiteninhalt angezeigt, wenn Du
- bei Grundeinstellungen für WYSIWYG-Editor "keinen" auswählst
- oder bei einer Seite in den seiteneinstellungen mal testtweise ein anderes Frontend-Template einstellst?

Offline

#6 12.09.2018 11:17:31

concipio
Member

Re: [gelöst] Text im Backend nicht mehr sichtbar

Folgendes habe ich nun probiert:
Ohne Editor habe ich eine schmale Zeile mit dem Quelltext, ist aber wenig praktisch.
Ein anderes Frontend-Template bringt keine Änderungen.
Die f12-Konsole sagt mir dies:
Synchrone XMLHttpRequests am Haupt-Thread sollte nicht mehr verwendet werden, weil es nachteilige Effekte für das Erlebnis der Endbenutzer hat. Für weitere Hilfe siehe http://xhr.spec.whatwg.org/
Das verstehe ich aber leider nicht.. cry

Offline

#7 12.09.2018 11:20:28

concipio
Member

Re: [gelöst] Text im Backend nicht mehr sichtbar

Habe noch weitere Fehler gefunden:

ckeditor.js?t=I63C:100 GET [url]https://domain.tld/modulesckeditor/wb_config/editor.styles.js?t=I63C[/url] 404 ()
append @ ckeditor.js?t=I63C:100
appendTo @ ckeditor.js?t=I63C:74
A @ ckeditor.js?t=I63C:259
load @ ckeditor.js?t=I63C:259
load @ ckeditor.js?t=I63C:263
getStylesSet @ ckeditor.js?t=I63C:511
e @ ckeditor.js?t=I63C:275
(anonymous) @ ckeditor.js?t=I63C:275
d @ ckeditor.js?t=I63C:257
e @ ckeditor.js?t=I63C:258
y @ ckeditor.js?t=I63C:258
v @ ckeditor.js?t=I63C:258
(anonymous) @ ckeditor.js?t=I63C:259
setTimeout (async)
A.CKEDITOR.env.ie.e.$.onload @ ckeditor.js?t=I63C:259
load (async)
A @ ckeditor.js?t=I63C:259
load @ ckeditor.js?t=I63C:259
load @ ckeditor.js?t=I63C:257
r @ ckeditor.js?t=I63C:275
(anonymous) @ ckeditor.js?t=I63C:275
b @ ckeditor.js?t=I63C:524
loadPart @ ckeditor.js?t=I63C:526
n @ ckeditor.js?t=I63C:275
(anonymous) @ ckeditor.js?t=I63C:274
n @ ckeditor.js?t=I63C:10
(anonymous) @ ckeditor.js?t=I63C:12
CKEDITOR.editor.CKEDITOR.editor.fire @ ckeditor.js?t=I63C:13
fireOnce @ ckeditor.js?t=I63C:12
CKEDITOR.editor.CKEDITOR.editor.fireOnce @ ckeditor.js?t=I63C:13
k @ ckeditor.js?t=I63C:272
(anonymous) @ ckeditor.js?t=I63C:272
callback @ ckeditor.js?t=I63C:260
e @ ckeditor.js?t=I63C:258
y @ ckeditor.js?t=I63C:258
v @ ckeditor.js?t=I63C:258
(anonymous) @ ckeditor.js?t=I63C:259
setTimeout (async)
A.CKEDITOR.env.ie.e.$.onload @ ckeditor.js?t=I63C:259
load (async)
A @ ckeditor.js?t=I63C:259
load @ ckeditor.js?t=I63C:259
a @ ckeditor.js?t=I63C:260
(anonymous) @ ckeditor.js?t=I63C:260
k @ ckeditor.js?t=I63C:272
g @ ckeditor.js?t=I63C:274
(anonymous) @ ckeditor.js?t=I63C:271
(anonymous) @ ckeditor.js?t=I63C:28
setTimeout (async)
setTimeout @ ckeditor.js?t=I63C:28
a @ ckeditor.js?t=I63C:270
a @ ckeditor.js?t=I63C:356
CKEDITOR.replace @ ckeditor.js?t=I63C:360
(anonymous) @ modify.php?page_id=2:218
ckeditor.js?t=I63C:263 Uncaught Error: [CKEDITOR.resourceManager.load] Resource name "wb" was not found at "[url]https://domain.tld/modulesckeditor/wb_config/editor.styles.js?t=I63C[/url]".
    at CKEDITOR.resourceManager.<anonymous> (ckeditor.js?t=I63C:263)
    at e (ckeditor.js?t=I63C:258)
    at Array.y (ckeditor.js?t=I63C:258)
    at v (ckeditor.js?t=I63C:258)
    at HTMLScriptElement.A.CKEDITOR.env.ie.e.$.onerror (ckeditor.js?t=I63C:259)
(anonymous) @ ckeditor.js?t=I63C:263
e @ ckeditor.js?t=I63C:258
y @ ckeditor.js?t=I63C:258
v @ ckeditor.js?t=I63C:258
A.CKEDITOR.env.ie.e.$.onerror @ ckeditor.js?t=I63C:259
error (async)
A @ ckeditor.js?t=I63C:259
load @ ckeditor.js?t=I63C:259
load @ ckeditor.js?t=I63C:263
getStylesSet @ ckeditor.js?t=I63C:511
e @ ckeditor.js?t=I63C:275
(anonymous) @ ckeditor.js?t=I63C:275
d @ ckeditor.js?t=I63C:257
e @ ckeditor.js?t=I63C:258
y @ ckeditor.js?t=I63C:258
v @ ckeditor.js?t=I63C:258
(anonymous) @ ckeditor.js?t=I63C:259
setTimeout (async)
A.CKEDITOR.env.ie.e.$.onload @ ckeditor.js?t=I63C:259
load (async)
A @ ckeditor.js?t=I63C:259
load @ ckeditor.js?t=I63C:259
load @ ckeditor.js?t=I63C:257
r @ ckeditor.js?t=I63C:275
(anonymous) @ ckeditor.js?t=I63C:275
b @ ckeditor.js?t=I63C:524
loadPart @ ckeditor.js?t=I63C:526
n @ ckeditor.js?t=I63C:275
(anonymous) @ ckeditor.js?t=I63C:274
n @ ckeditor.js?t=I63C:10
(anonymous) @ ckeditor.js?t=I63C:12
CKEDITOR.editor.CKEDITOR.editor.fire @ ckeditor.js?t=I63C:13
fireOnce @ ckeditor.js?t=I63C:12
CKEDITOR.editor.CKEDITOR.editor.fireOnce @ ckeditor.js?t=I63C:13
k @ ckeditor.js?t=I63C:272
(anonymous) @ ckeditor.js?t=I63C:272
callback @ ckeditor.js?t=I63C:260
e @ ckeditor.js?t=I63C:258
y @ ckeditor.js?t=I63C:258
v @ ckeditor.js?t=I63C:258
(anonymous) @ ckeditor.js?t=I63C:259
setTimeout (async)
A.CKEDITOR.env.ie.e.$.onload @ ckeditor.js?t=I63C:259
load (async)
A @ ckeditor.js?t=I63C:259
load @ ckeditor.js?t=I63C:259
a @ ckeditor.js?t=I63C:260
(anonymous) @ ckeditor.js?t=I63C:260
k @ ckeditor.js?t=I63C:272
g @ ckeditor.js?t=I63C:274
(anonymous) @ ckeditor.js?t=I63C:271
(anonymous) @ ckeditor.js?t=I63C:28
setTimeout (async)
setTimeout @ ckeditor.js?t=I63C:28
a @ ckeditor.js?t=I63C:270
a @ ckeditor.js?t=I63C:356
CKEDITOR.replace @ ckeditor.js?t=I63C:360
(anonymous) @ modify.php?page_id=2:218

Last edited by florian (12.09.2018 11:33:11)

Offline

#8 12.09.2018 11:24:51

florian
Administrator

Re: [gelöst] Text im Backend nicht mehr sichtbar

Die asynchronusblablabla-Meldung in der Konsole hat nichts zu bedeuten.

Bei dem Link oben fehlt merkwürdigerweise der / zwischen modules und ckeditor. Schaue ich in den Quelltext der SEite, ist dafür nach der Domain ein Slash zu viel (d.h. am Ende von WB_URL in der config.php steht ein Slash, der da raus muss).

Offline

#9 12.09.2018 11:31:37

concipio
Member

Re: [gelöst] Text im Backend nicht mehr sichtbar

Bingo! Das war's!
Aber wie kann sich sowas einschmuggeln und - wie findest du sowas immer raus...?!

Respekt und lieben Dank!
Suse

Offline

#10 12.09.2018 11:37:36

florian
Administrator

Re: [gelöst] Text im Backend nicht mehr sichtbar

Ausschlussprinzip...
Es kann aber eigentlich nicht sein, dass es die ganze Zeit funktioniert hat.
Ich vermute, dass der Slash am Ende der WB_URL evtl. bei der HTTPS-Umstellung irrtümlich durch Suchen&Ersetzen da reingeraten ist und der Fehler seitdem bestand, nur niemandem aufgefallen ist.

(Anmerkung: Ich habe den Link zur Seite im obigen Post entfernt)

Offline

#11 12.09.2018 11:38:41

concipio
Member

Re: [gelöst] Text im Backend nicht mehr sichtbar

Alles klar, danke!

Offline

Board footer

Powered by FluxBB

up