WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 18.01.2019 12:25:08

torsten
Member

[erledigt] Seitenbeschreibung fehlt für alle Seiten

Hallo,

zunächst einmal wünsche ich allen ein gesundes und erfolgreiches neues Jahr.
Ich habe folgende Frage:

Wie ich festgestellt habe, fehlt bei mir für jede Seite die Seitenbeschreibung in der Google-Suche (es wird eine aus dem Content generierte Ersatzbeschreibung angezeigt) und die Analysetools seorch.de und von 1u1 geben das auch als Mangel aus.

Für alle meine Seiten ist die Beschreibung und die Schlüsselwörter im backend ausgefüllt. Ebenfalls gibt es in den SEO-Tools von WBCE für jede Seite vollständige Beschreibungen.

Es war nicht immer so, dass die Seitenbeschreibung.
Über Eure Hilfe würde ich mich sehr freuen.

Beste Grüsse von Torsten

Last edited by torsten (18.01.2019 12:26:03)

Offline

#2 18.01.2019 12:46:00

florian
Administrator

Re: [erledigt] Seitenbeschreibung fehlt für alle Seiten

Thema nochmal verschoben. Ist ein Bug mit 1.4.0 DEV.

Ich habe das jetzt erstmal provisorisch gefixt, indem ich ins Template die Zeilen

<meta name="description" content="<?php page_description(); ?>" />
<meta name="keywords" content="<?php page_keywords(); ?>" />

eingefügt habe. Allerdings sollte das ja eigentlich von Simplepagehead generiert werden, der Aufruf dafür ist auch vorhanden, nur werden die Zeilen nicht geschrieben. Gemäß der /modules/simplepagehead/include.php vermute ich stark ein Problem mit OPF_AUTO_PLACEHOLDER als Verursacher. colinax, mrbaseman, könnt Ihr das mal prüfen?

Offline

#3 18.01.2019 13:54:18

colinax
Administrator

Re: [erledigt] Seitenbeschreibung fehlt für alle Seiten

Hi, ja ich werde es mir ansehen, auf meinem Seiten, die auch mit der 1.4.dev laufen inkl regex fixes, könnte ich den Fehler nicht reproduzieren.

Ich weiß aber gerade nicht auswendig ob mrbasemans zweiter regex fix bei dir bereits oben ist.

Edit: Hab den Fehler gefunden, die Beschreibung wie der Fehler erzeugt wird gibts Morgen :-)

Last edited by colinax (18.01.2019 23:29:02)

Offline

#4 20.01.2019 00:03:00

mrbaseman
Developer

Re: [erledigt] Seitenbeschreibung fehlt für alle Seiten

ich hab grad hier auch nochmal reingeschaut: Wenn ich die Insert und die I Klasse lösche, dann werden keywords und description nicht mehr verschluckt. Muss also was mit der Insert-Klasse und den dort durchgeführten Ersetzungen zu tun haben... Christian, deckt sich das mit deiner Analyse?

Offline

#5 22.01.2019 21:58:41

mrbaseman
Developer

Re: [erledigt] Seitenbeschreibung fehlt für alle Seiten

Ich ab einen Hotfix für das hier beschriebene Problem im Pull Request 337 auf Github.

Offline

#6 22.01.2019 22:05:04

colinax
Administrator

Re: [erledigt] Seitenbeschreibung fehlt für alle Seiten

Danke ich werde den fix hochladen.

Offline

Liked by:

florian

Board footer

Powered by FluxBB

up