WBCE Home | WBCE Hilfe | WBCE Addon Repository | Impressum | Datenschutz

WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 27.03.2019 16:15:32

gottfried
Member

migration von websitebaker 2.8.3 auf wbce 1.3.1

Hallo hilfreiche Geister! Ich bin neu hier!

Ich denk, ich probier nun mal WBCE aus. Mit WB war ich ja lange zufrieden, bis im Rückblick 2.8.1.
2.8.1 Installationen  machen mir auch mit Umstellung auf php 7.2 noch keine Probleme. Aber die Nachfolger.

Ich hab also auf einen clone eine WB 2.8.3  website  naiv wbce 1.3.1 draufgespielt und install/update.php aufgerufen.

Das ging gut.

im Frontend kommen nun außer der Seite zig warnings, die wohl ein update vom outputfilter und simple pagehead benötigen, dann die Seite eigentlich fast wie erhofft.

testwbce.channel-1.de

Aber das Problem ist erst mal die Meldung die kommt, wenn ich in's Backend will "Following theme file is missing: warning.html" und dann war's das. War wohl Argos Theme ?!

testwbce.channel-1.de/admin/login/index.php

was kann ich tun?

Offline

#2 27.03.2019 16:26:06

florian
Administrator

Re: migration von websitebaker 2.8.3 auf wbce 1.3.1

An sich ist die Vorgehensweise schon richtig (also in bestehende WB-Installation WBCE-Dateien kopieren und install/update.php aufrufen).
Auf der Testseite sieht es aber so aus, als seien die WBCE-Dateien unvollständig übertragen worden (daher auch die ganze Reihe Warnings) oder Altdateien wurden teilweise nicht überschrieben.

Versuch bitte mal, die Seite auf die aktuelle Version von WBCE (1.3.3) zu migrieren.
Tipp: Installationspaket zunächst lokal entpacken, dann nur den Inhalt des Ordners /wbce (also Dateien und alle darin befindlichen Unterverzeichnisse) in ein Zip-Archiv namens wbce.zip packen, dieses und die hier angefügte wbceunzip.php auf den Server kopieren und dann im Browser wbceunzip.php aufrufen. Dann /install/update.php aufrufen und schauen, ob das Update glatt durchläuft.

Offline

#3 27.03.2019 17:49:34

gottfried
Member

Re: migration von websitebaker 2.8.3 auf wbce 1.3.1

Hi!

Hab wohl das erste mal was falsch gemacht. Es hat auch ohne wbceunzip geklappt.

Die Oberfläche ist definitiv stylisher als die vom "alten"  WB.

Es funktioniert eigentlich fast alles .

nur mein "fork" der foldergallery nicht. Aber immerhin sehe ich Fehler Meldungen und schau mir das genauer an, bevor ich um Hilfe rufe.

ist echt sytylisch euer Teil!

:-)

Offline

Liked by:

florian

#4 26.04.2019 14:28:43

kinari
Member

Re: migration von websitebaker 2.8.3 auf wbce 1.3.1

Hallo Florian, habe heute versucht eine WB 2.8.3 Version auf WBCE 1.3.3 genau nach deinen Anweisungen vom 27.03.2019 upgedated. (brandl-bau.de) Zip-Archiv erstellt "wbce.zip und wbceunzip.php bei 1und1 auf Server kopiert, dann /install/update.php aufgerufen. Alle Daten wurden auch installiert, aber die Seite bringt "Fatal error:".
Ich komme auch nicht mehr ins Backend. Obwohl in der config.php
Habe dann mal über domani/install.php geschaut. WBCE CMS Installation Wizard wird angezeigt: Alles außer /config.php wird grün angezeigt. Bei config.php erscheint: "Not enpty! WBCE already installed?"

Es werden diese Error's angegeben:
Error: e1: Please fill-in the form below
Error: e2: Please enter an absolute URL
Error: e3: Please select a valid default timezone
Error: e4: Please select a valid default backend language
Error: e6: Please select a valid operating system
Error: e7: Please enter a database host name
Error: e8: Please enter a database username
Error: e9: Please enter a database password
Error: e10: Please enter a database name
Error: e13: Please enter a username for the Administrator account
Error: e14: Please enter an email for the Administrator account
Error: e16: Please enter a password for the Administrator account
Error: e17: Please make sure you re-enter the password for the Administrator account

bzw.

Notice: Undefined variable: wb_url in /homepages/43/d17349670/htdocs/install/save.php on line 70

Notice: Undefined variable: operating_system in /homepages/43/d17349670/htdocs/install/save.php on line 106

Notice: Undefined index: table_prefix in /homepages/43/d17349670/htdocs/install/save.php on line 158

Notice: Undefined index: table_prefix in /homepages/43/d17349670/htdocs/install/save.php on line 163

Notice: Undefined index: website_title in /homepages/43/d17349670/htdocs/install/save.php on line 170

Warning: Cannot modify header information - headers already sent by (output started at /homepages/43/d17349670/htdocs/install/save.php:70) in /homepages/43/d17349670/htdocs/install/save.php on line 223

Der Grund des Upgrades war wiedermal die Umstellung von php 5.6 auf php 7.2 und dem Kunden ist es heute aufgefallen, dass seine Seiten nicht mehr gehen.

Leider komme ich nicht weiter. Was habe ich nicht richtig gemacht???

Offline

#5 27.04.2019 06:15:45

florian
Administrator

Re: migration von websitebaker 2.8.3 auf wbce 1.3.1

- Besteht das Problem noch? Inzwischen wird auf der angegebenen Domain die WBCE-Standard-Wartungsseite angezeigt?
- Ist das Updatescript durchgelaufen, d.h. sind am Ende die "Kick Me"-Buttons angezeigt worden?
- Wie genau lautet der "Fatal Error"?
- Wie genau äußert sich "Komme nicht ins Backend"? Werden die Anmeldedaten nicht angenommen (Reload der Seite ohne sonstige Reaktion), oder  meinst Du etwas anderes?

Es gibt bei WBCE keine /install.php, du meinst vermutlich /install/index.php, aber die nützt Dir bei einem Update nichts. Deshalb wird logischerweise das Installationsskript mit dem Verweis auf die nicht-leere config.php gestoppt.
Allerdings ist es ein Fehler im Installationsskript, dass beim Klick auf "Check your settings" was passiert bzw. dann Fatal Errors in schwarz auf weiß ausgegeben werden, das konnte ich reproduzieren und das müssen wir im nächsten Release fixen, das hat aber nichts mit dem aktuellen Problem zu tun.

Offline

#6 27.04.2019 12:10:48

kinari
Member

Re: migration von websitebaker 2.8.3 auf wbce 1.3.1

Hi Florian,

das Problem ist nicht gelöst, habe aber herausgefunden, dass das Problem das ehemals WB Template "$template_version = 2.7" wohl verursacht. Auf meinem Rechner habe ich WBPortable 1.3 - da läuft das Template ohne Probleme. Heute habe ich WBPortable-1.3.3 installiert, welche WBCE-Version ich über die alte WB 2.8.3 installiert hatte. Auf meinem Rechner erscheinen bei der 1.3.3 Version die selben Errors.

Fatal error: Uncaught Error: Call to undefined function show_menu() in C:\Users\Downloads\WBCE_CMS\Portable\WBCEPortable-1.3.3\root\templates\brandl\index.php:61 Stack trace: #0 C:\Users\Downloads\WBCE_CMS\Portable\WBCEPortable-1.3.3\root\index.php(81): require() #1 {main} thrown in C:\Users\Downloads\WBCE_CMS\Portable\WBCEPortable-1.3.3\root\templates\brandl\index.php on line 61

index.php:61 = <?php show_menu(2,0,1)?
index.php:(81) = <br />

Thema Datenbank:
Die hatte ich zuvor gesichert beim importieren bekomme ich nur Fehlermeldungen. Damit kenne ich mich überhaupt nicht aus!!! Also mache ich über das Wochenende eine freizügige Fleißarbeit und baue die Seite mit dem älteren WB-Template mit der WBCE Version 1.3.1 neu auf. Habe zum Glück alle Seiteinhalte als .html gespeichert.

Offline

#7 27.04.2019 12:53:52

florian
Administrator

Re: migration von websitebaker 2.8.3 auf wbce 1.3.1

Das ist nicht besonders sinnvoll ehrlich gesagt. Der Fatal Error lässt sich leicht fixen. Den DB-Import brauchst du nicht, wenn die Seite ansonsten läuft. Und wenn du die Seite schon neu aufsetzen willst, dann nimm die aktuelle Version. Sonst kommst du beim nächsten PHP Update vom Regen in die Traufe.
Bin gerade unterwegs, aber wenn du mir Zugangsdaten an support@wbce.org schickst, schau ich mir das im Laufe des Tages an.

Offline

#8 28.04.2019 11:17:32

mrbaseman
Developer

Re: migration von websitebaker 2.8.3 auf wbce 1.3.1

show_menu sollte im Template durch show_menu2 ersetzt werden. Vielleicht war's das dann schon, aber Florian hat recht, an der Db braucht man in diesem Fall nicht zu fummeln

Offline

#9 29.04.2019 18:04:06

florian
Administrator

Re: migration von websitebaker 2.8.3 auf wbce 1.3.1

Zur Info: Seite läuft wieder, es waren 3 show_menu-Aufrufe zu ersetzen.

Offline

#10 30.04.2019 12:31:56

kinari
Member

Re: migration von websitebaker 2.8.3 auf wbce 1.3.1

Hi Florian, nachträglich noch mal ein dickes Dankeschön für den super schnellen Support. Habe erst mal 2 Tage verschnaufen müssen  cool

Last edited by kinari (30.04.2019 12:32:33)

Offline

Liked by:

florian

Board footer

Powered by FluxBB

up