WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 10.11.2019 12:31:05

gottfried
Member

upgrade Problem wb 2.8.4 auf wbce 1.4.0

Hallo!

Jemand hat eine wb 2.8.3 webseite bei Strato und möchte die auf wbce upgraden mit wbce 1.4.0
Die PHP Version ist seit vorgestern 7.2 und eigentlich läuft die webseite damit.
wb 2.8.3 ist ja nun aber schon bißchen alt.

kopiere ich wbce 1.4.0 entpackt drauf und starte xxx/install/update.php erscheint eine leere Seite, auch wenn ich einfach
das frontend aufrufe.

(hab in der Vergangenheit keine großen Probleme mit mehreren wbce gehabt)

Wo kann ich ansetzen? smile

Last edited by florian (11.11.2019 19:15:29)

Offline

#2 10.11.2019 16:39:21

florian
Administrator

Re: upgrade Problem wb 2.8.4 auf wbce 1.4.0

Wenn Du Zugriff auf den Strato Kunden-Login hast, schaue bitte mal dort nach, ob dort spezielle Features wie "Filter gegen Gästebuch-Spam" oder "PHP-Boost" aktiviert sind und deaktiviere diese.

Eventuell liegt es am WB-Modul expcounter, falls dieses installiert ist, bitte entfernen.

Falls das nicht hilft, schaue bitte in die Errorlogs, ob es dort Einträge gibt, die möglicherweise Aufschluss über die Ursache der Installationsprobleme geben könnten. Ggf. poste diese Einträge hier gekürzt.

Last edited by florian (11.11.2019 07:16:54)


Code allein macht nicht glücklich. Jetzt spenden!

Offline

#3 11.11.2019 18:41:00

gottfried
Member

Re: upgrade Problem wb 2.8.4 auf wbce 1.4.0

Hallo!
Der Tip mit dem errorlog auf dem Stratoserver war super.

Da steht was wie

11.11.2019 18:24:50 ...: PHP Fatal error:  Uncaught DatabaseException: Unknown MySQL server host 'DB_HOST' (0) in /.../htdocs/wb/framework/class.database.php:50: /.../htdocs/wb/index.php
11.11.2019 18:24:50 ...: Stack trace:: /.../htdocs/wb/index.php
11.11.2019 18:24:50 ...: #0 /.../htdocs/wb/framework/initialize.php(67): database->__construct(): /.../htdocs/wb/index.php
11.11.2019 18:24:50 ...: #1 /.../htdocs/wb/config.php(4): include_once('/mnt/web024/e0/...'): /.../htdocs/wb/index.php
11.11.2019 18:24:50 ...: #2 /.../htdocs/wb/index.php(19): require_once('/mnt/web024/e0/...'): /.../htdocs/wb/index.php
11.11.2019 18:24:50 ...: #3 {main}: /.../htdocs/wb/index.php
11.11.2019 18:24:50 ...:   thrown in /.../htdocs/wb/framework/class.database.php on line 50: /.../htdocs/wb/index.php
11.11.2019 18:25:22 ...: PHP Fatal error:  Uncaught DatabaseException: Unknown MySQL server host 'DB_HOST' (0) in /.../htdocs/wb/framework/class.database.php:50: /.../htdocs/wb/install/update.php
11.11.2019 18:25:22 ...: Stack trace:: /.../htdocs/wb/install/update.php
11.11.2019 18:25:22 ...: #0 /.../htdocs/wb/framework/initialize.php(67): database->__construct(): /.../htdocs/wb/install/update.php
11.11.2019 18:25:22 ...: #1 /.../htdocs/wb/config.php(4): include_once('/mnt/web024/e0/...'): /.../htdocs/wb/install/update.php
11.11.2019 18:25:22 ...: #2 /.../htdocs/wb/install/update.php(149): require_once('/mnt/web024/e0/...'): /.../htdocs/wb/install/update.php
11.11.2019 18:25:22 ...: #3 {main}: /.../htdocs/wb/install/update.php
11.11.2019 18:25:22 ...:   thrown in /.../htdocs/wb/framework/class.database.php on line 50: /.../htdocs/wb/install/update.php

Kann das mit zu tun haben, daß die wb 2.8.3 rev 2005 ein setup.ini.php verwendet und nicht config.php und ich das erst einmal anpassen muß?
:-)

Last edited by florian (11.11.2019 18:49:02)

Offline

#4 11.11.2019 19:09:50

florian
Administrator

Re: upgrade Problem wb 2.8.4 auf wbce 1.4.0

Urgh, das ist kein WB 2.8.3, das ist eine WB 2.8.4... versuch erstmal, so vorzugehen wie bei den Kollegen beschrieben bis Punkt 3, und dann WBCE drauf zu setzen.

Es sind aber sicherlich noch weitere Anpassungen erforderlich, insbesondere weil dort lib_jquery verwendet wird, die Aufrufe dafür müssen also aus dem Template raus.

Bevor Du da Stunden rein versenkst, kann es effektiver sein, die Seite leer mit WBCE neu aufzusetzen und die Inhalte von Hand zu übertragen... oder sie erst einmal noch weiter laufen zu lassen und sie komplett zu redesignen. Die Seite ist zum Zeitpunkt ihrer Entwicklung sicherlich state-of-the-art gewesen, aber ... nun ja... wenn schon größere Arbeiten im Hintergrund anstehen, sollte man eventuell die Gelegenheit nutzen, ein zeitgemäßes, und vor allem responsives Design zu entwickeln und umzusetzen.


Code allein macht nicht glücklich. Jetzt spenden!

Offline

#5 11.11.2019 19:11:07

florian
Administrator

Re: upgrade Problem wb 2.8.4 auf wbce 1.4.0

...oh, und SSL sollte natürlich dann auch aktiviert werden.


Code allein macht nicht glücklich. Jetzt spenden!

Offline

#6 11.11.2019 19:56:33

gottfried
Member

Re: upgrade Problem wb 2.8.4 auf wbce 1.4.0

Hallo Florian!

Ach ja - ich kann mich schwach erinnern, daß ich mal eine "inoffizielle" 2.8.3 heruntergeladen habe, werd mich also an die Kollegenupdateanweisung halten. Danke für die Gedankenstütze.
Hab die schon mal eine auf wb.x upgedatet. Leer aufsetzen kommt nicht so richtig in Frage, wird aber wohl trotzdem klappen, ist bis auf Textbausteine recht simpel.

Tja - SSL ist wohl das nächste Problem. Obwohl da bei einigen Installationen auch gar kein Problem war.

:-)

Offline

#7 11.11.2019 19:59:58

florian
Administrator

Re: upgrade Problem wb 2.8.4 auf wbce 1.4.0

SSL ist bei Strato vor allem ein finanzielles Problem, kostet (oft) nämlich extra.  mad
Aber zumindest gibt es in WBCE 1.4.0 bei Admintools > Outputfilter Dashboard > Erweiterte Optionen den Filter http->https, damit kann man sich den ganzen Datenbankdump-Suchen-und-Ersetzen-Aufwand ersparen.


Code allein macht nicht glücklich. Jetzt spenden!

Offline

Board footer

up