WBCE Home | WBCE Hilfe | WBCE Addon Repository | Impressum | Datenschutz

WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 02.12.2019 12:29:44

florian
Administrator

PHP 7.4

PHP 7.4 wird wieder ein Stück anspruchsvoller:
- $array{$index} ist deprecated, muss jetzt immer $array[$index] lauten
- $wert = $array[$index] verursacht nun eine Notice, wenn $array leer ist, d.h. es muss immer erst eine Abfrage if (is_array($array)) erfolgen
- Die Kurzschreibweise a ? b : c ? d : e ist deprecated, muss (a ? b : c) ? d : e oder a ? b : (c ? d : e) lauten
und dergleichen "Verbesserungen" mehr.

Jedenfalls, beim Core sind wir schon dabei, die entsprechenden Vorkommnisse zu korrigieren, aber auch etliche Module werden mit PHP 7.4 Notices und Deprecated-Meldungen anzeigen. Bis die für PHP 7.4 geeignete WBCE-Version 1.4.1 veröffentlicht wurde entsprechende Modul-Fixes zur Verfügung stehen, sollte diese PHP-Version auf produktiven Seiten noch nicht verwendet werden.

Offline

Liked by:

screamindan, thanks

Board footer

Powered by FluxBB

up