WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 12.01.2020 11:14:01

naturbursch
Member

Nach Provider-Umzug funktioniert Cookie Message und E-Maillink nicht.

Hallo zusammen,
bin Laie aber habe in den letzten Jahren mir durch Versuch und Irrtum ein gewisses Grundwissen angeeignet.
Nun musste ich eine Domain zu einem anderen Provider umziehen. Das hat soweit geklappt: ABER nun funktioniert nicht mehr die Cookie Message und auch Email können nicht per Doppelklick verwendet werden. Normale Links gehen.
Den Umzug habe ich folgendermaßen vollzogen, weil ich damit gut Erfahrungen gemacht habe.
FTP Sicherung / Datenbanksicherung mit adminer

Auf dem neuen server wbce installiert als NEUE Version
adminer installiert, dann die alte Datenbank hochgeladen und schließlich per ftp die alten DAteien wieder hochgeladen.

Die Site läuft und alles scheint zu funktionieren, lediglich eben cookie info und e-maillink nicht.

Es kann eigentlich nicht am Anbieter 1u1 liegen, weil ich dort schon einige 1u1 Seiten habe.

Es funktioniert übrigens auch nicht, wenn ich z.B. einen neuen Email Link erstelle.

Habt ihr eine Tipp?

Danke im Voraus
Naturbursch

Offline

#2 12.01.2020 14:55:11

florian
Administrator

Re: Nach Provider-Umzug funktioniert Cookie Message und E-Maillink nicht.

Ich glaube nicht, dass das mit OPF zu tun hat, klingt für mich eher nach einem JavaScript-Problem.

Bei einem Umzug ist es nicht nötig, WBCE neu zu installieren.
Man lädt auf dem alten Server die Daten runter, lädt sie auf den neuen Server hoch, macht vom Altsystem einen Datenbankdump und spielt diesen (ggf. nachdem man den Dump in Notepad++ o.ä. geöffnet und mit Suchen+Ersetzen alle Vorkommnisse der Alt-Domain durch die neue Domain ersetzt hat) im Zielsystem ein und passt zuguterletzt in der config.php im Root die Datenbankzugangsdaten und ggf. Domain an.

Hinzu kommt: Wenn vorher eine andere Version lief als neu installiert, gibt es Durcheinander. Wenn also im Zuge eines Umzugs ein Update erfolgen soll, trotzdem erst die alte Version wie beschrieben installieren und dann auf normalem Wege das Update machen.

Zum konkreten Problem: Bitte mal mit F12 Browserkonsole öffnen und schauen, ob da irgendwelche Fehler angezeigt werden und/oder mal einen Link zur Seite posten.

Last edited by florian (12.01.2020 22:41:46)

Offline

#3 13.01.2020 19:12:32

naturbursch
Member

Re: Nach Provider-Umzug funktioniert Cookie Message und E-Maillink nicht.

Hallo,
habs hinbekommen....
Habe nun wie von Florian beschrieben, nochmals per ftp alles blank hochgeladen OHNE vorher wbce zu installieren. Die Datenbank habe ich dann direkt bei ionos hochgeladen und dann wieder per ftp die aktuelle Datenbank angepasst.
Hat dann leider immer noch nicht funktioniert.
Erst als ich dann noch ein wbce update durchgeführt habe
https://help.wbce.org/pages/de/installa … f-wbce.php
hat es funktioinert mit den Email-Links.
Cookie message musste ich einmal zurücksetzen, jetzt scheint das auch zu funktionieren.


Vielen Dank!
Naturbursch

Offline

#4 13.01.2020 23:23:13

colinax
Administrator

Re: Nach Provider-Umzug funktioniert Cookie Message und E-Maillink nicht.

Hallo naturbursch,

schön dass die Seite wieder funktioniert.

Ich weis doofe Frage, der der Content der Seite ist schon komplett vorhanden oder?

Warum ich so Frage, so wie du es beschreibst, wurde beim Import nicht alles übernommen.

Welches Charset hat und hatte die Seite & welche Kollation hat und hatte die DB?

Offline

Board footer

Powered by FluxBB

up