WBCE Home | WBCE Hilfe | WBCE Addon Repository | Impressum | Datenschutz

WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 26.03.2020 18:39:47

berny
Member

[Gelöst] Itemz-Teasers + NWI

Ich habe noch ein komisches Phänomen:
Ich habe als ersten Abschnitt ein Itemz mit Teaser-grid.
Danach ein NWI 5.0.1

Wenn man also Teaser-Menüs anlegt, werden diese vor UND nach dem NWI angezeigt, also doppelt.
Interessanterweise, bei dem ersgten Teaser gehen nur die Links Weiterlesen, beim zweiten Teaser sind die Bilder mit Links auf die Hauptseite belegt.

Last edited by florian (27.03.2020 15:24:38)

Online

#2 26.03.2020 20:28:32

florian
Administrator

Re: [Gelöst] Itemz-Teasers + NWI

Kann ich so nicht reproduzieren. Link, Screenshot? welches Template?

Offline

#3 27.03.2020 07:36:08

berny
Member

Re: [Gelöst] Itemz-Teasers + NWI

Screenshot uns links folgen, muss das erst wieder aktivieren.

template Nexus responsive mit megamenü

Online

#4 27.03.2020 13:19:11

berny
Member

Re: [Gelöst] Itemz-Teasers + NWI

So, habs wieder installiert.
http://www.weisse-schaefer.at/wbce/

WBCE Version: 1.4.2
Tag: 1.4.2
PHP Version: 7.2.28

Template auch geändert, hat nix geändert.
Ich vermute da irgendwas im Outputfilter...

WYSIWYG = ist nur ein Hinweis auf die früheren News.
Die Webseite ist noch im Aufbau, deshalb fehlt natürlich etliches, also nicht als Showcase betrachten ;-)

Last edited by berny (27.03.2020 13:21:16)

Online

#5 27.03.2020 13:22:51

florian
Administrator

Re: [Gelöst] Itemz-Teasers + NWI

Ich sehe das Problem nicht...

Was ist da jetzt falsch?

attachment.php?item=2268&download=1

attachment.php?item=2267&download=1

Offline

#6 27.03.2020 13:26:51

berny
Member

Re: [Gelöst] Itemz-Teasers + NWI

Bei mir sieht das so aus:

Interessanter weise bei FF, beim IE gehts ganz normal....

Last edited by berny (27.03.2020 13:27:52)

Online

#7 27.03.2020 13:34:35

berny
Member

Re: [Gelöst] Itemz-Teasers + NWI

Im Quelltext wird das Div auch zwei mal aufgerufen:

Online

#8 27.03.2020 13:35:51

florian
Administrator

Re: [Gelöst] Itemz-Teasers + NWI

Aha. Wir kommen der Sache näher.
Erstens: Das ist nicht das Teasers-Modul, sondern Itemz mit dem Preset Teasers. Ein himmelweiter Unterschied. mad
Zweitens: Das Problem kann ich dann reproduzieren, es tritt aber nur auf, wenn man am Backend angemeldet ist.

Last edited by florian (27.03.2020 13:36:26)

Offline

#9 27.03.2020 13:55:50

berny
Member

Re: [Gelöst] Itemz-Teasers + NWI

Hätte ich auch so geschrieben  wink

im Backend angemeldet:
nur warum ruft er dann zwei mal auf, macht itemz so ja normal nicht, oder?

darum vermute ich, dass das nwi irgendetwas verursacht...

Last edited by berny (27.03.2020 13:56:26)

Online

#10 27.03.2020 13:58:28

berny
Member

Re: [Gelöst] Itemz-Teasers + NWI

Ja, reproduzierbar.
Sowohl im IE als auch im FF.

Angemeldet = Bug, Abgemeldet != Bug

Online

#11 27.03.2020 14:22:51

florian
Administrator

Re: [Gelöst] Itemz-Teasers + NWI

Ich hab's gefunden. Es ist eine gleich benannte Variable. Der Name " $output" wird sowohl in NWI als auch Itemz verwendet.
Wird $output in der /news_img/view.php und in der /news_img/templates/view.phtml in $nwi_output geändert , tritt das Problem nicht mehr auf.

Offline

#12 27.03.2020 14:37:36

berny
Member

Re: [Gelöst] Itemz-Teasers + NWI

des is a Fux, der Florian!  thumb_up  thumb_up  thumb_up

Online

#13 27.03.2020 15:15:22

boeseroeser
Guest

Re: [Gelöst] Itemz-Teasers + NWI

Reden wir hier von der view.php?
Eine Variable $output wird es wohl häufig geben, in etlichen Modulen. Und sie wohl auch immer initialisiert mit $output='';

#14 27.03.2020 15:24:20

florian
Administrator

Re: [Gelöst] Itemz-Teasers + NWI

Es ist ein Bug in NWI.

Die Variable $output wird dort nicht initial resettet mit $output='', sondern in der view.php so aufgerufen:

$output = preg_replace_callback(
        '~\[('.implode('|',$vars).')+\]~',
        function($match) use($replacements) {
            return (isset($match[1]) && isset($replacements[$match[1]]))
                ? $replacements[$match[1]]
                : '';
        },
        $settings['post_header'].$settings['post_content'].$settings['post_footer']
    );

D.h. neben der vorgeschlagenen Umbenennung der Variable würde es auch reichen, in der view.php von NWI in Zeile 29 ein $output=''; einzufügen.

Ich denke, damit ist hier dann alles gesagt und ich schließe den Thread.

Offline

Liked by:

berny

Board footer

Powered by FluxBB

up