WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 25.05.2020 22:14:22

mrbaseman
Developer

TypeError: $.include is not a function

Mit WBCE 1.4.3 und Template clean_blog habe ich das Problem, dass im Frontend in der WebConsole die Fehlermeldungen bekomme:

TypeError: $.include is not a function

und

TypeError: $.insert is not a function

eine Minigallerie wird gar nicht angezeigt, bei News with Images wird zwar bei Fotorama das erste Bild angezeigt und bei Masonry alle Bilder, aber sie erscheinen einfach als in den Text "reingeklatscht". Es erscheint keine Gallerie in dem Sinne. Ich schätze, das ist ein Folgefehler, weil vorher schon irgendwas mit jQuery schief gelaufen ist...

Hat jemand einen Tipp, was da schief läuft?

Offline

#2 25.05.2020 22:22:00

florian
Administrator

Re: TypeError: $.include is not a function

Sicher, dass das eine 1.4.3 ist? Das sollte eigentlich da drin korrigiert sein, siehe
https://forum.wbce.org/viewtopic.php?pid=30988#p30988

Offline

#3 25.05.2020 22:50:32

mrbaseman
Developer

Re: TypeError: $.include is not a function

Ja. Ich hab gerade nochmal Tag 1.4.3 ausgechecked und synchronisiert... hat leider nicht geholfen

Offline

#4 25.05.2020 23:01:10

florian
Administrator

Re: TypeError: $.include is not a function

Liegt an was anderem. Unten im Template wird nochmal jQuery geladen, das

<script src="<?php echo TEMPLATE_DIR; ?>/js/jquery.js"></script>

muss da raus.

Offline

#5 27.05.2020 18:24:56

mrbaseman
Developer

Re: TypeError: $.include is not a function

danke! das wars. Da hätt ich ja auch selbst drauf kommen können, aber irgendwie hab ich nicht nach unten im Template geschaut. Aber ja, das wird auch noch vor document.ready ausgeführt :-)

Offline

#6 26.06.2020 15:41:57

miaka83
Member

Re: TypeError: $.include is not a function

Danke für die Hilfe!

Offline

Board footer

Powered by FluxBB

up