WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 29.07.2020 11:03:18

kleo
Member

Versionsangabe bei AOR

Da die aktuelle Version von WBCE ältere Versionen von PHP nicht unterstützt, Zitat:

"WBCE CMS 1.4.4 ist freigegeben für PHP 7.1 bis PHP 7.4. Darunter oder darüber liegende PHP-Versionen werden nicht unterstützt"

wäre es vielleicht sinnvoll, auch im AOR bei den Modulen einzugeben, welche WBCE und PHP-Versionen vom Modul unterstützt werden.

Sonnst läuft die Gefahr, dass nach der Aktualisierung des Moduls deren Funktion fehlerhaft sein kann.

Offline

#2 29.07.2020 15:15:42

bernd
Developer

Re: Versionsangabe bei AOR

Den Infotext auf der AOR-Seite haste gelesen?
[ ] Ja
[ ] Nein


... nein in Europa verwenden wir beim Programmieren nicht € statt $ ...

Offline

#3 29.07.2020 15:39:23

florian
Administrator

Re: Versionsangabe bei AOR

naja, ganz unberechtigt ist die Überlegung ja nicht. Es gibt durchaus Module, die die Insert-Klasse voraussetzen und daher mit WBCE < 1.4 nicht funktionieren.
Da aber in Kürze sogar schon PHP 7.2 als veraltet angesehen werden muss (https://www.php.net/supported-versions), und Server mit PHP 5.x wohl inzwischen die absolute Ausnahme sind, halte ich die Angabe der unterstützten PHP-Versionen bei den Modulen für nicht so erforderlich.

Offline

#4 29.07.2020 16:33:46

kleo
Member

Re: Versionsangabe bei AOR

bernd wrote:

Den Infotext auf der AOR-Seite haste gelesen?
[ ] Ja
[ ] Nein

Welcher Infotext ist gemeint?

Ich habe mehrere Webseiten mit verschiedenen php-Versionen bei unterschiedlichen Hoster (die nicht ich ausgewählt habe!).

Bei einigen Hoster läuft die php-Version 7.0.x, deshalb wollte ich fragen, ob die aktuelle Modul-Versionen da auch problemlos laufen werden.

Last edited by kleo (29.07.2020 16:34:04)

Offline

#5 29.07.2020 20:48:08

colinax
Administrator

Re: Versionsangabe bei AOR

Für mein Verständnis steht alles was man benötigt im AOR, um einen Legacy Support für WBCE zu betreiben.

Bernd meint diesen hier:

Info: Alle Module sollten kompatibel zu PHP 7.4* und MySQL-strict sein.
Danke an Bernd für die Tests und 60 Modulupdates!
Note: All* modules should be compatible with PHP 7.4 and MySQL-strict.
Thanks to Bernd for the tests and 60 updated modules!

*Ausnahme/except for: Module in "Archive";  Multipage-Permissions, Bookings, Multilingual, will be updated later

Prinzipiell kann man sagen dass die Module in einem AOR generell den Angaben des CMS entsprechen werden (Ausnahmen bestätigen die Regel).

Aktuell gibt es meines Wissens nur ein Modul dass zwingend php 7.1 erfordert dass ist NWI 5 und dass steht auch in der Beschreibung, falls Module eine bestimmte CMS Version erfordern steht dass auch dabei.

Sofern dass normale Hoster sind kann man die php Version über ein Hoster-Backend oder der htaccess anpassen, sollte das nicht möglich sein, Kündigen und neuen Hoster suchen. Mittlerweile bekommt man hochmoderne Server Umgebungen die keine Wünsche offen lassen um 2 bis 4€ im Monat und sind um vieles besser als die großen deutschen Hoster.

Offline

Liked by:

florian

Board footer

Powered by FluxBB

up