WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 13.09.2020 09:44:59

screamindan
Member

Update und PHP Version unter 7.1

Moin. Nicht wirklich ein Problem, aber war kurz irritiert.

Ich hab mehrere Seiten auf WBCE 1.4.4 (Development Branch) umgestellt. Immer über die schnelle Methode mit dem Unzip auf dem Server.

Bei der letzten kam erst ne Fehlermeldung, dass die PHP Version unter 7.1 liegt. Dachte ok, also eben hochgestuft.

Dann wollte ich das Update nochmal laufen lassen, aber die beiden Dateien (zip und wbceup.php) waren nicht mehr auf dem Server.
Ist das so beabsichtigt? Hab dann nochmal beides hochgeladen und es lief ohne Probleme...

Edit: Herkunft der WBCE Version korrigiert.

Last edited by colinax (13.09.2020 11:56:04)

Offline

#2 13.09.2020 10:41:40

florian
Administrator

Re: Update und PHP Version unter 7.1

ist so beabsichtigt und steht auch so in der Beschreibung im AOR

https://addons.wbce.org/pages/addons.php?do=item&item=141 wrote:

wuz.php / wup.php und das zugehörige Zipfile werden automatisch vom Server gelöscht.

Offline

#3 13.09.2020 10:42:57

screamindan
Member

Re: Update und PHP Version unter 7.1

Das weiss ich. Aber ich hatte angenommen nur bei erfolgreichem Update.

Offline

#4 13.09.2020 10:57:15

florian
Administrator

Re: Update und PHP Version unter 7.1

Das Löschen erfolgt im Entpack-Script, nicht in der update.php oder dem Core, und das Entpack-Script "weiß" ja nicht, ob das Update geklappt hat. (Auch das Updatescript weiß das nicht, das Updatescript  wird wiederum erst bei erfolgreicher Anmeldung am CMS gelöscht. )
Du kannst im Entpack-Script das Löschen auskommentieren, sind ziemlich am Ende die Zeilen mit "unlink" am Anfang. Dann aber hinterher selbst daran denken, im Erfolgsfall die Dateien zu löschen.

Offline

Liked by:

screamindan

#5 13.09.2020 12:01:16

colinax
Administrator

Re: Update und PHP Version unter 7.1

Damit keine Missverständnisse entstehen habe ich in #1 die Herkunft der WBCE Version korrigiert.

@screamindan

Sofern du die Files am Server hochgeladen hast und irgendwas meldet dass eine höhere PHP Version benötigt wird, ist es nach der PHP Umstellung nicht mehr notwendig die Dateien nochmal hoch zuladen, da diese schon am Server sind.

Für das Installieren des WBCE Updates muss die /install/update.php aufgerufen werden, der Unzipper ist hierfür nicht notwendig, da dieser nur die zip entpackt.

Offline

#6 13.09.2020 12:12:18

screamindan
Member

Re: Update und PHP Version unter 7.1

Ah jetzt leuchtet was...  thumb_up

Offline

Board footer

Powered by FluxBB

up