WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 02.06.2021 08:55:24

bbs2
Member

Miniform Problem nach Umstellung auf WBCE 1.5

Hallo,

die Umstellung auf WBCE 1.5 lief fast problemlos. Gratulation! Lediglich mit MIniform, neueste Version, gibt es
folgendes Problem:

Eine Seite besteht aus 2 Abschnitten

Abschnitt 1: News with images
Abschnitt 2: Kontaktformular mit Miniform

die Seite mit miniform hat ein anderes template (VLWgrau) im Vergleich zum Standardtemplate (VLW), wobei bei dem seitenbezogenen template (VLWgrau) lediglich eine andere Hintergrundfarbe erscheint.

Problem:
Das miniform-Kontaktformular wird im frontend erst mit sehr großem Abstand zum Abschnitt 1 gezeigt. Der user wird das
Formular praktisch nicht benutzen, da er es nicht sieht und ein scrolldown erforderlich ist.
Bei Benutzung des Standardtemplates (VLW) tritt dieser Fehler nicht auf.

Das Miniform-Problem liegt wohl eindeutig am Templatewechsel, da die Verschiebung des Formulars bei templatewechsel nach unten auch stattfindet, wenn die Seite nicht in Abschnitte gegliedert ist.

Ich habe in die config.php die Anweisung
define('TEMPLATE_SWITCHER', true);
eingebunden, ohne Erfolg.

Viele Grüße
Heinz

Online

#2 02.06.2021 09:03:37

florian
Administrator

Re: Miniform Problem nach Umstellung auf WBCE 1.5

Den Templateswitcher-Eintrag braucht man nur, wenn das Template über eine Auswahlbox oder einen Link - so wie beispielsweise im WBCE-Templateverzeichnis - vom Besuchy gewechselt werden köännen soll. Man braucht ihn NICHT, wenn auf einem Web-Auftritt den einzelnen Seiten unterschiedliche Templates zugeordnet werden!

Zu Deinem Problem: Ich vermute da eher entweder eine Reihe an leeren Absätzen (<p>&nbsp;</p>) im betreffenden Newsbeitrag oder ein Problem mit Floats / Clear im CSS.
Bitte mal einen Link zur Seite.

Online

#3 02.06.2021 09:26:19

bbs2
Member

Re: Miniform Problem nach Umstellung auf WBCE 1.5

Hallo,

hier eine testseite mit nur einem Abschnitt miniform

https://vlw-rlp.de/pages/test2.php

hier der gleiche miniform-Inhalt als Abschnitt ohne Templatewechsel

https://vlw-rlp.de/pages/personalraete/ … lieder.php

Auf dieser Seite hat der Wechsel des templates seit Monaten mit der Version 1.4.x keine Probleme bereitet.
Die Verschiebung fand nicht statt.

Hier das Miniform-Template, das sich unter WBCE 1.5 evtl. anders verhält.

[== HTML ==]
<div class="miniform">
    <div class="{MESSAGE_CLASS}">{STATUSMESSAGE}</div>
    <div class="{FORM_CLASS}">
     <h1>Anfrage HPR-Mitglieder des VLW</h1>       
            <p>Felder mit <span><span>*</span></span> = Pflichteingaben </p>
        <br/>
        <form name="form_{SECTION_ID}" id="form_{SECTION_ID}" method="post" action="{URL}">
            <input name="miniform" type="hidden" value="{SECTION_ID}"/>
            <input name="header" type="hidden" value="Mitglieder-&Auml;nderungsmeldung"/>
            <input name="mf_timestamp" type="hidden" value="{DATE} {TIME}"/>
            {ASPFIELDS}
            <div  class="full">
                <label for="vorname"> <span>Vorname:<span>*</span></span><br></label>
               
            <input required="required" class="{VORNAME_ERROR}" type="text" id="vorname" name="mf_r_vorname" value="{VORNAME}" />
                       
            </div>
            <div  class="full">
                <label for="nachname"><span>Nachname:<span>*</span></span> <br></label>
                    <input required="required" class="{NACHNAME_ERROR}" type="text" id="nachname" name="mf_r_nachname" value="{NACHNAME}" />
                
            </div>
            <div  class="full">
                <label for="email">   <span>Ihre E-Mail für unsere Rückantwort:<span>*</span></span> <br></label>
                    <input class="{EMAIL_ERROR}" type="email" id="email" name="mf_r_email" value="{EMAIL}" />
              
            </div>
            <div  class="full">
                <label for="nachname"><span>Betreff:<span>*</span></span> <br></label>
                    <input required="required" class="{BETREFF_ERROR}" type="text" id="betreff" name="mf_r_betreff" value="{BETREFF}" />
                
            </div>
            <div  class="full">
                <label for="nachricht"><span>Nachricht:<span>*</span></span> <br></label>
                    <textarea rows="5" cols="80" class="{NACHRICHT_ERROR}" id="nachricht" name="mf_r_nachricht">{NACHRICHT}</textarea>
                           </div>
            <div class="{CAPTCHA_CLASS} full">
                <label for="captcha"><span>Spamschutz</span>
                    <div class="grouping {CAPTCHA_ERROR}">
                    {CAPTCHA}
                    </div>
                </label>
            </div>
            <div class="full">
                <button class="submit" name="Submit" type="submit">abschicken</button>
            </div>
        </form>
    </div>
</div>

Online

#4 02.06.2021 09:53:30

bernd
Developer

Re: Miniform Problem nach Umstellung auf WBCE 1.5

Beim VLW_grau fehlt in der screen.css bei #content das float: left;
devil


... nein in Europa verwenden wir beim Programmieren nicht € statt $ ...

Offline

#5 02.06.2021 10:50:39

bbs2
Member

Re: Miniform Problem nach Umstellung auf WBCE 1.5

Vielen Dank,

das war es.
Warum es monatelang unter WBCE 1.4.x funktionierte?????
Egal. Nochmals vielen Dank

Heinz

Online

#6 02.06.2021 11:08:22

bernd
Developer

Re: Miniform Problem nach Umstellung auf WBCE 1.5

Also ich seh' da keinen Zusammenhang mit der WBCE-Version ...
Ohne das float-left weiß der Browser schlicht nicht, dass das container-div links vom rechteseite-div dargestellt werden soll und stellt es richtigerweise dort hin, wo es im Dokumentenfluss steht.


... nein in Europa verwenden wir beim Programmieren nicht € statt $ ...

Offline

Liked by:

florian

Board footer

Powered by FluxBB

up