WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 23.11.2021 10:57:02

jambo
Member

WBCE V1.3.2 - Umstellung von PHP 7.3 auf 7.4

Hallo,


Ich habe folgende Installation:
WBCE V1.3.2 | PHP 7.3 --> läuft einwandfrei.

Nun soll/muss auf PHP7.4 umgestellt werden
Da die Seite selbst neu erstellt wird ist das Ziel minimaler Aufwand
(= ohne weitere Upgrade-Arbeiten sofern möglich)


Gibt es Informationen/Erfahrungen dazu, ob WBCE 1.3.2 auf PHP 7.4 läuft?
Oder ist Systemseitig mit Fehlern zu rechnen?


In der Doku wird lediglich PHP 7.2 erwähnt ohne die Mindestanforderungen zu nennen:
https://forum.wbce.org/viewtopic.php?id=2489
In der Readme der Version selbst wird lediglich PHP 5.4. als Mindestanfordderung genannt.


Herzlichen Dank für die Hilfe im Voraus.

VG Jambo

Offline

#2 23.11.2021 11:23:28

florian
Administrator

Re: WBCE V1.3.2 - Umstellung von PHP 7.3 auf 7.4

Das wird nicht funktionieren. Eine Testinstallation von 1.3.2 (von 2018!!!) mit PHP 7.4 wirft erwartungsgemäß reihenweise Fehler.
Mach ein Update direkt auf 1.5.1. So aufwändig ist das nun auch wieder nicht.

Offline

#3 23.11.2021 11:53:54

jambo
Member

Re: WBCE V1.3.2 - Umstellung von PHP 7.3 auf 7.4

Schnelle und klare Antwort.
Danke.


Bei 1.5.1 hattet Ihr geschrieben, dass da einige große Umstellungen realisiert worden sind...
Wie ich(!) verstanden habe teilweise ohne Rückwärtskompatibilität.
Daher hake ich noch mal nach:

Die Seite ist nicht von 2018 sondern noch viel älter: Prä-WBCE!!!
Ich habe da die Befürchtung, dass da in dem Fall dann doch einiges an Umarbeitung anfällt.

Wäre da nicht ein upgrade auf 1.4.0 sinnvoller bzw. einfacher?
Ist die Version auf PHP 7.4 frei gegeben?
Wären danicht weniger Probleme zu erwarten?


Die Seite soll tatsächlich lediglich für ein halbes Jahr "gerettet" werden.
Da ist im Zweifel schon ein halber Tag "viel" ... zumindestens kundenseitig :-(

Offline

#4 23.11.2021 15:09:29

florian
Administrator

Re: WBCE V1.3.2 - Umstellung von PHP 7.3 auf 7.4

Beim Update von 1.3.x auf 1.5.x müssen ggfs. auch Module aktualisiert werden.
Anpassungen am Template können auch schon bei einem Update von 1.3.x auf 1.4.x erforderlich sein.

Letztlich kommt es darauf an, wie das Template gestrickt ist und was für Module am Start sind. Es kann sein, dass ein Update in Nullkommanix durchläuft, es kann aber auch sein, dass man noch ein, zwei Stunden frickeln muss (aber sicherlich keinen halben Tag), um das Ding wieder zum Laufen zu bekommen.

Offline

#5 23.11.2021 18:07:50

jambo
Member

Re: WBCE V1.3.2 - Umstellung von PHP 7.3 auf 7.4

Das hilft doch schon mal weiter :-)
Danke für die Infos.

Und um auch dass einmal zu sagen: Die Updates sind bisher immer gut gelaufen, gerade auch bei den älteren Versionen/Seiten. Das spricht für die Arbeit und das CMS hier!

Offline

Liked by:

florian

#6 25.11.2021 09:38:23

florian
Administrator

Re: WBCE V1.3.2 - Umstellung von PHP 7.3 auf 7.4

Just for the record: Ich habe gestern eine Seite, auf der tatsächlich noch WBCE 1.1.11 (wegen PHP-Umstellung: nicht) mehr lief, auf 1.5.1 aktualisiert. Das einzige, was Probleme machte, waren die leidigen Umlaute und Sonderzeichen in Seiten- und Menütiteln und Beschreibungen, die ich dann von Hand korrigiert habe.

Offline

Board footer

up