WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 26.11.2021 10:43:11

screamindan
Member

Font Awesome und mailto-Link

Moin. Ich hab ein kleines Problem. Ich hab in Templates Font Awesome Symbole in Verbindung mit mailto-Links verbaut. Nach dem letzten WBCE Update gehen die Links zwar noch, das Symbol ist aber verschwunden; es steht da jetzt "Email". Kann das Verhalten jemand bestätigen?

<a href="#" class="icon solid fa-envelope">

Da ist das Symbol da.

<a href="mailto:email@example.com" class="icon solid fa-envelope">

Da ist es verschwunden.

Last edited by screamindan (26.11.2021 10:46:29)

Offline

#2 26.11.2021 10:53:00

screamindan
Member

Re: Font Awesome und mailto-Link

Ah ok. Outputfilter... Wird der nach Update automatisch aktiviert?

Offline

#3 26.11.2021 11:14:52

florian
Administrator

Re: Font Awesome und mailto-Link

Es gab vorher ein Problem mit dem E-Mail-Filter und FontAwesome, da hat der OPF das FA-Symbol zerschossen.
Der Filter geht allerdings davon aus, dass mailto-Links mit FA-Symbol nach diesem Muster angelegt sind:

<a href="mailto:mail@example.com"><span class="fa fa-envelope fa-fw"></span></a>

Dem Mail-Link selbst die FA-Klasse zuzuweisen ist mMn auch eher ungewöähnlich...?


Nicht ärgern. Nur wundern.

Offline

Liked by:

screamindan

#4 26.11.2021 11:25:49

screamindan
Member

Re: Font Awesome und mailto-Link

Das war im Template so angelegt, ich hab da nur rudimentäre Ahnung von... Aber so wie von Dir empfohlen funktioniert es auch mit eingeschaltetem Mailfilter...  thumb_up
Danke!

Offline

Board footer

up