WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 12.12.2021 18:59:26

losttrip
Member

Google not indexing NWI post detail pages

I'm not sure what is causing this issue, so my apologies if this is not the correct forum.

I checked Google Search console for a site I built for a client.  Under coverage I realized that all the NWI post pages are not being indexed, but are marked "Excluded".

Google Help shows this explanation:
Excluded: The page is not indexed, but we think that was your intention. (For example, you might have deliberately excluded it by a noindex directive, or it might be a duplicate of a canonical page that we've already indexed on your site.)

I am wondering if the cause of this is obvious to anyone.  Is it by design, or is there a setting I can change to allow indexing of post pages?

I would be happy to provide more info, but for now, I don't know where to start.

Thank you in advance for your time.

Offline

#2 13.12.2021 07:03:17

florian
Administrator

Re: Google not indexing NWI post detail pages

Please check if you're using simplepagehead or html5head in the template. If the title and metadata are generated the "old" way, each nwi post has unfortuately just the same <title> and <description> (no individual data, but those of the nwi page itself) and therefor Google might not index them.
Another possibility might be that they are just too short (not enough content) or that there are technical issues on the page, e.g. a missing </head>, <body> tag or sth. linke this.

Offline

#3 13.12.2021 07:26:55

losttrip
Member

Re: Google not indexing NWI post detail pages

Thank you for the reply.  My apologies, I now realize that not ALL post pages are excluded, just the majority.  I am going try switching the way the meta title is built and see if that might be the cause.

Using simplepagehead

<?php simplepagehead('/', 1, 1, 1, 0); ?>

I checked page source and each NWI post page has a unique title and description.

The titles and descriptions are not short, title ~60 characters, descriptions ~150

Google does not show any errors for these pages.

Offline

#4 13.12.2021 07:34:32

florian
Administrator

Re: Google not indexing NWI post detail pages

Hm... It's difficult to figure out the reason then. Maybe the content (not the metadata) of the not-indexed posts is too short or contains too much filler words or Google thinks that there's duplicate content somwhere else. Maybe a check with a SEO tool (like seobility) might help.

Offline

#5 13.12.2021 14:49:31

losttrip
Member

Re: Google not indexing NWI post detail pages

I was just checking to make sure it wasn't a WBCE/module setting I might have overlooked.  But, now I realize that isn't the case.
Okay, thanks.  I'll continue to look into it.

Offline

Board footer

up