WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 02.09.2022 10:15:10

bwanas
Member

Kompatibilität mit PHP Version 8.1

Hallo zusammen,
ich verwende MiniForm 0.23. Mit PHP Version 8.0 funktioniert alles prima, mit PHP Version 8.1 erscheint beim Absenden des Formulars durch einen Websitebesucher:


Websitebesucher wrote:

There was an uncatched exception
database::escapeString(): Argument #1 ($unescaped_string) must be of type string, null given, called in /is/htdocs/wpxxxxx_xxxxx/www/www.mywebsite.de/modules/miniform/functions.php on line 398
in line (257) of (/framework/class.database.php):

Wird es möglich sein, MiniForm mit PHP 8.1 zu verwenden?

Danke und viele Grüße
Birgit

Last edited by bwanas (02.09.2022 10:18:30)

Offline

#2 03.09.2022 07:13:02

florian
Administrator

Re: Kompatibilität mit PHP Version 8.1

Der Fehler wird nicht von Miniform verursacht, sondern vom WBCE-Core, denn WBCE bis einschl. 1.5.2 ist noch nicht zu PHP 8.1 kompatibel.
Die WBCE-Version 1.5.3, die dann auch für PHP 8.1 freigegeben ist, wird in Kürze veröffentlicht werden.


Code allein macht nicht glücklich. Jetzt spenden!

Offline

Board footer

up