WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 13.10.2022 17:31:11

tennstar
Member

Seite startet mit Fehlermeldung nach Update auf 1.5.3 und PHP 8.1

Hallo,
ich habe einer meiner Testseiten, um sicher zu sein, auf 1.5.3 aktualisiert und von PHP 8.06 auf 8.1 bei bplaced umgestellt.

Unter 8.06 läuft die Seite nach wie vor einwandfrei aber unter mit 8.1 erhalte ich folgende Fehlermeldung beim Start:

Fatal error: Uncaught mysqli_sql_exception: Unknown character set: 'utf8unicodeci' in /users/edelweiss/www/framework/class.database.php:68 Stack trace: #0 /users/edelweiss/www/framework/class.database.php(68): mysqli_query(Object(mysqli), 'SET NAMES utf8u...') #1 /users/edelweiss/www/framework/class.database.php(47): database->connect() #2 /users/edelweiss/www/framework/initialize.php(67): database->__construct() #3 /users/edelweiss/www/config.php(20): require('/users/edelweis...') #4 /users/edelweiss/www/index.php(20): require_once('/users/edelweis...') #5 {main} thrown in /users/edelweiss/www/framework/class.database.php on line 68

Als Temeplate ist Verti by HTML 5 up installiert.

Hier noch der das Error Log:

2022-10-13T14:32:01+00:00 [Visitor Request] http://edelweiss.bplaced.net/
2022-10-13T14:32:01+00:00 [Warning] /modules/mod_multilingual/lang.functions.php:[123] from /templates/verti-html5up/index.php:[75] language_menu "Undefined array key "DE""
2022-10-13T14:32:01+00:00 [Warning] /modules/mod_multilingual/lang.functions.php:[123] from /templates/verti-html5up/index.php:[75] language_menu "Trying to access array offset on value of type null"
2022-10-13T14:32:01+00:00 [Warning] /modules/mod_multilingual/lang.functions.php:[123] from /templates/verti-html5up/index.php:[75] language_menu "Undefined array key "EN""
2022-10-13T14:32:01+00:00 [Warning] /modules/mod_multilingual/lang.functions.php:[123] from /templates/verti-html5up/index.php:[75] language_menu "Trying to access array offset on value of type null"
2022-10-13T14:32:01+00:00 [Warning] /modules/mod_multilingual/lang.functions.php:[123] from /templates/verti-html5up/index.php:[75] language_menu "Undefined array key "IT""
2022-10-13T14:32:01+00:00 [Warning] /modules/mod_multilingual/lang.functions.php:[123] from /templates/verti-html5up/index.php:[75] language_menu "Trying to access array offset on value of type null"
2022-10-13T15:56:44+00:00 [Visitor Request] http://edelweiss.bplaced.net/
2022-10-13T15:56:44+00:00 [Warning] /modules/mod_multilingual/lang.functions.php:[123] from /templates/verti-html5up/index.php:[75] language_menu "Undefined array key "DE""
2022-10-13T15:56:44+00:00 [Warning] /modules/mod_multilingual/lang.functions.php:[123] from /templates/verti-html5up/index.php:[75] language_menu "Trying to access array offset on value of type null"
2022-10-13T15:56:44+00:00 [Warning] /modules/mod_multilingual/lang.functions.php:[123] from /templates/verti-html5up/index.php:[75] language_menu "Undefined array key "EN""
2022-10-13T15:56:44+00:00 [Warning] /modules/mod_multilingual/lang.functions.php:[123] from /templates/verti-html5up/index.php:[75] language_menu "Trying to access array offset on value of type null"
2022-10-13T15:56:44+00:00 [Warning] /modules/mod_multilingual/lang.functions.php:[123] from /templates/verti-html5up/index.php:[75] language_menu "Undefined array key "IT""
2022-10-13T15:56:44+00:00 [Warning] /modules/mod_multilingual/lang.functions.php:[123] from /templates/verti-html5up/index.php:[75] language_menu "Trying to access array offset on value of type null"

Hat vielleicht jemand eine Lösung für das Problem?

Gruß tennstar

Last edited by tennstar (13.10.2022 17:56:03)


Ich liebe Technik wenn sie funktioniert!

Offline

#2 13.10.2022 17:53:24

florian
Administrator

Re: Seite startet mit Fehlermeldung nach Update auf 1.5.3 und PHP 8.1

Klingt für mich danach, als wäre in der config.php eine ungültige Angabe.
Wenn da
define('DB_CHARSET', 'utf8_unicode_ci');
drin steht, änder das mal zu
define('DB_CHARSET', 'utf8');


Code allein macht nicht glücklich. Jetzt spenden!

Offline

#3 13.10.2022 18:24:27

tennstar
Member

Re: Seite startet mit Fehlermeldung nach Update auf 1.5.3 und PHP 8.1

Hallo Florian, das wars! thumb_up

Danke für Deine schnelle und zielgenaue Reaktion.

Gruß tennstar


Ich liebe Technik wenn sie funktioniert!

Offline

Board footer

up