WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 27.07.2023 22:52:36

bastie
Member

WBCE Portable und Win11 nicht nutzbar

Hi zusammen,

ich habe mir die letzte Version der Portable heruntergeladen. Ich bekomme den USBWebsever nicht zum Laufen. Weder der Apache startet noch MYSQL. Alles rot.

Das tritt übrigens nicht nur bei WBCE-Portable auf, der USBWebserver in allen Versionen startet unter WIN11 nicht mehr.

Bevor jemand fragt, die Voraussetzungen sind erfüllt.

Hat jemand die gleiche Erfahrung gemacht und wenn, was für eine Lösung es gibt.

Unter Win10 gab es keine Probleme. Warum immer diese Windows Upgrades, die alles nur noch ätzender machen.

Gruß

Peter


Wer Rechtschreibfehler findet, darf sie gerne herunterladen, kopieren, weiterverwenden und weiterverbreiten. Ich beanspruche in keiner Weise ein Urheberrecht. Meine Rechtschreibfehler stehen unter der MIT-Lizenz.

Offline

#2 28.07.2023 06:51:11

berny
Member

Re: WBCE Portable und Win11 nicht nutzbar

Schau mal in den Sicherheitseinstellungen nach, da gibt es etwas mit dem Schutz vor fremder Software.....

Online

#3 28.07.2023 16:55:31

webbird
Administrator

Re: WBCE Portable und Win11 nicht nutzbar

Schau auch mal ins Eventlog, da könnte es Hinweise darauf geben, woran es hapert. Unter Win10 musste man für den USBWebserver ja auch erst noch was nachinstallieren (VCRedist glaub ich), damit es lief, hast Du da die entsprechende Version installiert? Ich habe leider kein Win11 zum Testen zur Verfügung. Ich hab die penetranten Update-Hinweise abgeklemmt.  devil


Ich habe eine Amazon-Wishlist. wink Oder spende an das Projekt.
Ich kann, wenn ich will, aber wer will, dass ich muss, kann mich mal

Offline

#4 28.07.2023 18:25:50

florian
Administrator

Re: WBCE Portable und Win11 nicht nutzbar

Hier sind sonst ein paar andere lokal installierbare Server aufgeführt:
https://www.php-kurs.com/alternativen-zu-xampp.htm

WBCE Portable habe ich bei mir (Win 11) tatsächlich auch nicht mehr zum Laufen gebracht.  Wobei sich das bei mir so äußerte, dass localhost:8080 sich nicht mehr aufrufen ließ. Seltsam.


Code allein macht nicht glücklich. Jetzt spenden!

Offline

#5 29.07.2023 09:21:22

florian
Administrator

Re: WBCE Portable und Win11 nicht nutzbar

Nachtrag: Den hier habe ich gerade noch entdeckt, entpackt ist er "nur" 350 MB groß.

https://www.uniformserver.com/

Runterladen und nach C:\temp oder so entpacken (Pfad darf keine Leerzeichen enthalten).
UniServerZ\UniController.exe starten.
MySQL und Apache starten.
WBCE-Installationsdateien nach UniServerZ\www kopieren.
WBCE installieren: Datenbankname "mysql", DB-Nutzer "root", PW "root".

attachment.php?item=3462&download=1

Last edited by florian (29.07.2023 09:21:55)


Code allein macht nicht glücklich. Jetzt spenden!

Offline

Liked by:

berny, stefanek

#6 04.08.2023 23:53:39

bastie
Member

Re: WBCE Portable und Win11 nicht nutzbar

Sorry zusammen,

dass ich als Trööt-Eröffner nicht weiter reagiert habe. Wie es so schön heisst - der Teufel kackt immer auf den größten Haufen. Totalausfall der Technik inkl. Telefon. Problemlösung zog sich über Tage hin usw.,usw.

Beim neuen Rechner kommt dann noch ein Display-Schaden dazu. Reparatur dauert natürlich und kostet, weil Full-HD-Display. Jetzt hab ich einen alten Laptop reaktiviert, natürlich 32bit, aber immerhin.

Also, meine bessere Hälfte hat mir dann grünes Licht gegeben, dass ich an ihrem Homeoffice-Rechner (64bit) arbeiten darf.

Florian, danke für den Tipp mit dem UniServer, das Ding klappt prima, funktioniert allerdings nicht auf eiem 32bit-System (s.o.). ich hab es mal testweise auf verschiedenen USB-Sticks und einer externen FP installiert. Läuft ohne Probleme.

Wäre es nicht möglich, WBCE-Portable darauf auszulefern? Der USB-Werserver macht ja schon länger Zicken, besonders unter WIN10 u.11. Mit Win7 und auch Win 8.1 gabs da eine Probleme. Ist nur ein Vorschlag, ich hab jetzt nicht auf die Lizenz geschaut und weiss daher nicht, ob das geht. Aber einen Gedanken ist es immerhin wert.

Update:
Ich habe mich gewundert, wenn beim Start des UsbWebservers keine Sicherheitsabfrage seiten des Windows-Defenders mehr kam (Apache und MYSQL). In Windows-Sicherheit war die Firewall nicht aktiviert, weil ich ein externes Programm benutze. Als Antivirenprogramm nutze ich AVIRA-Prime. Der hat jetzt als Neuerung eine Firewall. Die blockiert anscheinend gnadenlos alles - auch lokale Verbindungen (bis auf den Uniform-Server, weiß der Geier warum). Nachdem ich die AVIRA-Firewall abgeschaltet habe, war die Defender-Firewall wieder aktiv. Jetzt läuft auch der USB-Webserver wieder.

@Florian: Die aktuelle Version von WBCW-Portable verwendet doch Port 80. Vielleicht hast Du ja ein ähnliches Problem mit einer externen Sicherheitssoftware?

Last edited by bastie (05.08.2023 22:50:31)


Wer Rechtschreibfehler findet, darf sie gerne herunterladen, kopieren, weiterverwenden und weiterverbreiten. Ich beanspruche in keiner Weise ein Urheberrecht. Meine Rechtschreibfehler stehen unter der MIT-Lizenz.

Offline

#7 07.08.2023 07:38:42

florian
Administrator

Re: WBCE Portable und Win11 nicht nutzbar

Danke für die Rückmeldungen und Hinweise.
Ich muss das mal prüfen, es wird so sein, dass ich irgendwo in den Tiefen der Windows-Firewall mal irgendwas zu Testzwecken umgestellt habe.
Die Lizenz von uniform server ist nicht explizit benannt, aber auf deren Website steht "Anyone is freely licensed to use, copy, study, and change the software in any way" - da könnte ich also schon darauf basierend WBCEPortable bauen.

Last edited by florian (07.08.2023 07:39:34)


Code allein macht nicht glücklich. Jetzt spenden!

Offline

#8 08.08.2023 19:06:22

florian
Administrator

Re: WBCE Portable und Win11 nicht nutzbar

Schade. Ich habe UniServer jetzt gerade nochmal auf einer anderen Windows 11-Maschine getestet, und da startet der Apache nicht (trotz installiertem VC++ 2015 in 32- und 64bit). Damit hat sich das dann als Alternative auch erledigt.


Code allein macht nicht glücklich. Jetzt spenden!

Offline

#9 11.08.2023 21:53:35

bastie
Member

Re: WBCE Portable und Win11 nicht nutzbar

florian wrote:

Schade. Ich habe UniServer jetzt gerade nochmal auf einer anderen Windows 11-Maschine getestet, und da startet der Apache nicht (trotz installiertem VC++ 2015 in 32- und 64bit). Damit hat sich das dann als Alternative auch erledigt.

Kann es sein, dass der Apache-Port von irgendeiner anderen Win-Sache besetzt ist? Ich hatte das mal mit dem UWAMP (übrigens auch interessant, nur ist da die PHP-Version nicht mehr aktuell). da konnte ich einfach den Port 80 auf 81 ändern und dann lief es. Vielleicht kann man bein Uni-Server auch den Apache-Port ändern.

Ich habe jetzt mein Gerät aus der Reparatur zurück und der UNI-Server läuft.

Aber auch interessant: bei WBCE-Portable und auch beim USB-Webserver generell startet MYSQL jetzt nicht. Vielleicht liegt es auch da am Port. Hab's noch nicht ausprobiert.


Wer Rechtschreibfehler findet, darf sie gerne herunterladen, kopieren, weiterverwenden und weiterverbreiten. Ich beanspruche in keiner Weise ein Urheberrecht. Meine Rechtschreibfehler stehen unter der MIT-Lizenz.

Offline

#10 21.08.2023 23:12:51

bastie
Member

Re: WBCE Portable und Win11 nicht nutzbar

Update:

Was das USBWebserver-Problematik angeht: per Zufall bin ich auf den Websitebaker-Portable gestossen: der verwendet den USBWebserver v10, aber nicht mit Port 80. Da hat der Apache Port 4443 und MYSQL Port 3311. Funktioniert auf mehreren Win 10 und 11 Rechnern. Allerdings sind da mehr Dateien und Ordner drin als im Original USBWebserver v10. Die scheinen sich da eine eigene Version gestrickt zu haben.

Ich weiß ja nicht ob man diese Version einfach auf WBCE-Portable umstricken darf, ich für meinen Teil habs jedenfalls getan.

Hier der Link:

https://portable.websitebaker.org/posts … P81713.php

Mich hat gestört, dass sowohl Win10 als auch Win11 beim USBWebserver rumzickt. Entweder startet der Apache nicht oder MYSQL ist nicht zum Laufen zu bekommen. Und das bei beiden aktuellen Versionen 8.6.5 und v10. Kann natürlich auch an meinen Systemen liegen, das glaube ich aber nicht. Allerdings bin ich auch kein Webserver-Experte. Ich erwarte nur, dass so ein Ding auch funktioniert.

Last edited by bastie (21.08.2023 23:20:44)


Wer Rechtschreibfehler findet, darf sie gerne herunterladen, kopieren, weiterverwenden und weiterverbreiten. Ich beanspruche in keiner Weise ein Urheberrecht. Meine Rechtschreibfehler stehen unter der MIT-Lizenz.

Offline

Liked by:

florian

#11 23.08.2023 20:11:00

florian
Administrator

Re: WBCE Portable und Win11 nicht nutzbar

Danke für den Tipp. Da sage ich doch mal ganz sportlich "Möge der Bessere gewinnen"  devil


Code allein macht nicht glücklich. Jetzt spenden!

Offline

#12 26.03.2024 12:42:27

webbird
Administrator

Re: WBCE Portable und Win11 nicht nutzbar

Ich habe jetzt den USBWebserver v10 (original von Sourceforge) auf Win11 installiert. Folgende Beobachtungen:

"Der Computer wurde durch Windows geschützt"
Bei meinem Computer handelt es sich um einen Firmenrechner mit ziemlich strengen Sicherheitseinstellungen. Ich kann bei dieser Meldung nur "Nicht ausführen" klicken. Allerdings kann ich mir die Datei per Powershell freischalten. devil

Ergebnis: Läuft. Sowohl Apache (Port 80) als auch mySQL (Port 3306) starten problemlos.

Als nächstes lade ich mal die WBCE Portable runter und teste die.

Nachtrag: Windows 11 Enterprise 22H2 mit aktivierter Windows-Firewall

Last edited by webbird (26.03.2024 12:52:03)


Ich habe eine Amazon-Wishlist. wink Oder spende an das Projekt.
Ich kann, wenn ich will, aber wer will, dass ich muss, kann mich mal

Offline

#13 26.03.2024 12:57:05

webbird
Administrator

Re: WBCE Portable und Win11 nicht nutzbar

WBCE Portable frisch von der Website runtergeladen funktioniert bei mir ebenfalls einwandfrei. Es ist also kein grundsätzliches Win11 Problem. Ich kann bei der weiteren Analyse ggfs. auch online - MS Teams oder Skype z.B. - helfen, aber schaut doch erst mal

* in die Log-Dateien vom Apache (insbesondere error.log)
* ins Eventlog des Betriebssystems (eventvwr.msc oder "Ereignisanzeige")

Weiters: cmd.exe öffnen, in das Verzeichnis <USBWebserverpfad>\apache2\bin wechseln und httpd_usbw8.exe starten. Es sollten irgendwelche Fehlerausgaben zu sehen sein.

Last edited by webbird (26.03.2024 13:00:17)


Ich habe eine Amazon-Wishlist. wink Oder spende an das Projekt.
Ich kann, wenn ich will, aber wer will, dass ich muss, kann mich mal

Offline

Board footer

up