WBCE Home | WBCE Hilfe | WBCE Addon Repository | Impressum | Datenschutz

WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 20.08.2016 15:54:41

micon
Member

Additional Pictures

- Modul Topics 0.9.0
- Zusätzliche Bilder in einem Beitrag über den Schalter für Additional Pictures hochgeladen
- im "Langtext" des Beitrages unter den Text den Platzhalter [ADDITIONAL_PICTURES] gesetzt
- Es werden aber keine Bilder angezeigt, sondern nur der Platzhalter als ganz normaler Text

Ist da noch irgendwo in Topics was einzustellen? Offensichtlich interpretiert es den Platzhalter [ADDITIONAL_PICTURES]  nicht.
Unter "Einstellungen/Bilder" gibt es zum Beispiel das Feld "[ADDITIONAL_PICTURES] Loop:". Was kommt da rein?

Last edited by micon (20.08.2016 16:21:08)

Offline

#2 20.08.2016 16:26:30

florian
Projektmanagement und Support WBCE CMS

Re: Additional Pictures

Der Platzhalter verhält sich so wie die anderen Topics-Platzhalter auch, muss also bei den Topics-Optionen an sinnfälliger Stelle in der Kopf-, Fußzeile oder dem 2. Block eingefügt werden. Siehe Screenshot anbei.
Im WYSIWYG funktioniert er nicht, wenn Du eine Galerie mitten im Text haben willst, müsstest Du das anders lösen, z.B. mit einem MiniGallery-Abschnitt auf einer nicht sichtbaren Seite und dann dem Sectionpicker-Droplet. D.h. wenn der MiniGallery-Abschnitt (nicht die Seite) die ID 42 hat, kannst Du im Langtext eines Topics [[sectionpicker?sid=42]] einfügen und hast dann die Galerie.

Offline

#3 20.08.2016 16:27:56

florian
Projektmanagement und Support WBCE CMS

Re: Additional Pictures

Im Additional Pictures-Loop sollte {THUMB} stehen.

Offline

#4 20.08.2016 16:44:11

micon
Member

Re: Additional Pictures

Danke.
So habe ich es jetzt gemacht, Eintrag bei Optionen im 2. Block. Aber im Block 2 wird jetzt neun mal (das ist die Anzahl der hochgeladenen Bilder) der Platzhalter als Text angezeigt

Last edited by micon (20.08.2016 16:46:57)

Offline

#5 20.08.2016 16:47:49

florian
Projektmanagement und Support WBCE CMS

Re: Additional Pictures

Kann es sein, dass Du "[ADDITIONAL_PICTURES]" in das Feld "[ADDITIONAL_PICTURES] Loop:" geschrieben hast?
Schau mal im Screenshot, so soll es sein.

Offline

#6 20.08.2016 16:58:34

micon
Member

Re: Additional Pictures

Ja, das war mein Fehler. Jetzt werden die Thumbs richtig angezeigt.

Jedoch: beim Klick darauf öffnet sich das große Bild als eigene Seite, nicht in einer Colorbox oder so. Daher kann ich auch nicht in der Bilderserie weiterblättern. Gibt es da vielleicht noch eine Einstellung, in welcher die zu verwendende Bildarstellung definiert wird?

Offline

#7 20.08.2016 17:01:28

florian
Projektmanagement und Support WBCE CMS

Re: Additional Pictures

Das kommt aufs Template an und ob Du WBCE einsetzt. Wie Du im Screenshot siehst, ist bei class / rel in meinem Beispiel "colorbox" hinterlegt, damit werden die Bilder - bei installiertem Colorbox-Modul- dann wie gewünscht in einer Lightbox geöffnet. Wenn Du ein anderes Lightbox-Modul verwendest (Fancybox o.ä.) müsste die class- und/oder rel-Angabe entsprechend angepasst werden.

Offline

#8 20.08.2016 17:06:28

micon
Member

Re: Additional Pictures

Ich habe WBCE mit dem Template "We Be Zeh Eh" im Einsatz.

Offline

#9 20.08.2016 17:08:42

florian
Projektmanagement und Support WBCE CMS

Re: Additional Pictures

Dann sollte das mit "colorbox" eigentlich funktionieren

Offline

#10 21.08.2016 15:39:37

grindmobil
Member

Re: Additional Pictures

Bei Topics sollten nach einem Upgrade generell die Einstellung einmal gespeichert werden - egal ob man etwas ändert oder nicht.

Offline

#11 21.08.2016 16:20:09

micon
Member

Re: Additional Pictures

Hab ich gemacht, dennoch funktioniert die Colorbox dort nicht.

Offline

#12 21.08.2016 18:10:39

florian
Projektmanagement und Support WBCE CMS

Re: Additional Pictures

Hast Du mal einen Link, ggf. per PM?

Offline

#13 10.01.2017 22:10:29

hardysign
Member

Re: Additional Pictures

Habe TOPICS 0.9.2 auf zwei verschiedenen Hostern mit dem Template WeBeZehZeh installiert. Auf der Testseite  klappt alles einwandfrei. Auf der richtigen Seite geht [ADDITIONAL_PICTURES] nicht. Es werden zwar alle Bilder schön hochgeladen und in die Medienordner Thumbs, Zoom etc. einsortiert - aber das war es auch schon. Beim Hochladen erscheint der Text:   Note: "Uploaded pictures will be displayed in alphabetic order" - Eigentlich sollte da stehen: "Thumb (edit) | Thumb | Standard | Zoom".

Findet er den Link nicht. Muss ich da was in den php-Dateien anpassen?
P.S. Ich habe auch auf dem gleichen Hoster nochmals installiert. Alles gleich und auch hier klappt alles auf Anhieb. Liegt das vielleicht an dem Hoster belwue.de?

Kann mir da jemand helfen?
Danke im voraus
HarDySign

Last edited by hardysign (12.01.2017 18:51:26)

Offline

#14 10.01.2017 23:43:07

grindbatzn
Member

Re: Additional Pictures

Eventuell hapert es an den Berechtigungen, Hast du in /media/topics-pictures auch Verzeichnisse wie "topicX" (X=topic_id) mit weiteren Verzeichnissen drin?

Offline

#15 11.01.2017 10:12:06

hardysign
Member

Re: Additional Pictures

Danke für Deine schnelle Antwort.
Nein, im Verzeichnis liegen lediglich die Ordner: original, thumbs, topic1..., zoom mit den Unterordnern: original, thumbs, zoom.
Wie gesagt: gleiche Installationsroutinen bei zwei verschiedenen Hostern.

Offline

#16 11.01.2017 10:22:40

florian
Projektmanagement und Support WBCE CMS

Re: Additional Pictures

Schau mal bitte nach, was bei Grundeinstellungen > Erweiterte Optionen anzeigen für Datei- und Verzeichnisrechte eingetragen sind. Eventuell muss hier etwas angepasst werden (normalerweise reichen 0644 / 0755, kann aber auch sein, dass bei Verzeichnissen auf 0775 hochgedreht werden muss).

Andere mögliche Fehlerursache wäre noch das alte PHP vs. FTP-Problem.

Offline

#17 11.01.2017 12:06:23

grindbatzn
Member

Re: Additional Pictures

Du hast die Bildverzeichnisse ja wahrscheinlich per FTP übertragen.
Also ist es mit ziemlicher Sicherheit ein Berechtigungsproblem.

Schau mal, ob du per medienverwaltung irgendwo einen Unterordner anlegen kannst. Wenn nein:
Ändere in /media die Berechtigung aller (und NUR) Verzeichnisse incl Unterverzeichnisse auf 755 oder 777

Offline

#18 12.01.2017 15:13:19

hardysign
Member

Re: Additional Pictures

Danke für die Hinweise. Habe alles überprüft. Media/topics-pictures hat 755 alle Verzeichnisse darunter 777. Habe überall Ordner in allen Verzeichnissen und Unterverzeichnissen von Media erstellen können. Filezilla zeigt mir auch die hochgeladenen Bilder, aber trotzdem erscheinen Sie nicht unter [ADDITIONAL_PICTURES]
Beim installieren gab es auch keine Probleme - alles grün siehe Anhang.

Last edited by hardysign (12.01.2017 18:51:55)

Offline

#19 12.01.2017 15:20:13

florian
Projektmanagement und Support WBCE CMS

Re: Additional Pictures

Kannst Du mir bitte Backend-Zugangsdaten per PM zukommen lassen, dann könnte ich mir das mal etwas genauer anschauen.

Offline

#20 12.01.2017 16:27:06

hardysign
Member

Re: Additional Pictures

Meinst Du das den Administrator mit dem Passwort? oder die FTP-Zugangsdaten??? Was heisst PM?
Habe Dich nicht verstanden.

Offline

#21 12.01.2017 16:33:31

florian
Projektmanagement und Support WBCE CMS

Re: Additional Pictures

Am besten beides, und PM = Personal Message, siehe Menüpunkt "PM"
https://forum.wbce.org/pms_inbox.php

Kannst es aber auch per Mail an support@wbce.org schicken.

Offline

#22 12.01.2017 17:35:57

florian
Projektmanagement und Support WBCE CMS

Re: Additional Pictures

So, ich konnte das Problem lokalisieren und beheben.

Die Additional_Pictures werden sowohl im Backend als auch im Frontend mit dem Befehl glob gesucht:

$files = glob($additional_picture_path."/*.{jpg,png,gif}", GLOB_BRACE);

Dieser Ausdruck funktioniert jedoch nicht auf Solaris / SunOS - Servern:
https://lodge.statamic.com/questions/58 … d-constant

In einem anderen Forum habe ich einen Fix dafür gefunden:
https://forum.opencart.com/viewtopic.ph … 37#p559236

Diesen musste ich nur geringfügig anpassen. Falls also noch wer anders das Problem hat:

Statt der o.g. Zeile den folgenden Block in der /modules/topics/inc/additional_pictures.php und /modules/topics/picupload/additional_pictures.php einfügen:

$dir = $additional_picture_path . '/';
      $extensions = array('jpg', 'jpeg', 'png', 'gif', 'bmp');

      $result = array();
      $directory = new DirectoryIterator($dir);
      foreach ($directory as $fileinfo) {
          if ($fileinfo->isFile()) {
              $extension = strtolower(pathinfo($fileinfo->getFilename(), PATHINFO_EXTENSION));
              if (in_array($extension, $extensions)) {
                  $result[] = $dir.$fileinfo->getFilename();
              }
          }
      }
      $files  = $result;

Offline

Liked by:

stefanek, hardysign

Board footer

Powered by FluxBB

up