WBCE Home | WBCE Hilfe | WBCE Addon Repository | Impressum | Datenschutz

WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 30.01.2019 18:06:45

giz
Member

Fragstan Probleme mit mobile menu auf manchen seiten

Hallo zusammen,
auf einer Testsite mit Fragstan funktioniert das mobile Menu auf manchen Seiten nicht; mit Klick auf das Hamburger-Icon wird das Menü nicht ausgefahren und in der Adressleiste hinter dem angezeigten link nur ein "#" zugefügt und das war's. Getestet sowohl mit Smartphone, als auch mit den webentwickler-tools im Fx (Bildschirmgrößen testen).
Da die Site noch nicht öffentlich ist, sende ich gerne Zugangsdaten per mail/PN, um mir zu helfen.

Danke erstmal.

WBCE 1.3.3
PHP 7.2.13

Offline

#2 30.01.2019 18:22:03

bernd
Developer

Re: Fragstan Probleme mit mobile menu auf manchen seiten

Erster Schnelltipp:
Guck mal auf den Seiten auf denen es nicht funktioniert mit den Entwicklertools in der "Konsole" nach, ob es da irgendwelche Javascript-Fehler schmeißt.

Edit:
und: kannst du eine "Regelmäßigkeit" ausmachen auf welchen Seiten es nicht funktioniert - also z.B. "WYSIWYG-Seiten gehen - auf Seiten mit Modul "xyz" klemmt es.

Last edited by bernd (30.01.2019 18:23:54)


2 x ROT13 hält besser ...

Offline

#3 30.01.2019 18:36:37

giz
Member

Re: Fragstan Probleme mit mobile menu auf manchen seiten

danke für den tipp!

ReferenceError: tsrs_CheckSection is not defined[Weitere Informationen] seite.php:262:2

    <anonym> https://domain.tld/pages/seite.php:262 i4jQuery
i
fireWith
ready
J

ReferenceError: tsrs_CheckSection is not defined

    <anonym> https://domain.tld/pages/seite.php:265 dispatch2jQuery

dispatch
handle 

das übersteigt dann aber meine eingeschränkten Fähigkeiten.... big_smile
und ich weiß nicht, wo ich da weitermachen soll/kann

zur Regelmässigkeit: bei Seiten mit Topics-, Formular-, oder Kalendermodul-Abschnitten passiert's; reine WYSIWYG-Seiten funktionieren.
Zusätzlich hängt sich dann auch die Seite auf und man kann gar nix mehr anklicken, auch der Zurück-button im Browser ist ohne Funktion.

Last edited by giz (30.01.2019 18:45:46)

Offline

#4 30.01.2019 19:16:15

bernd
Developer

Re: Fragstan Probleme mit mobile menu auf manchen seiten

Bin jetzt leider erstmal noch paar Stunden unterwegs.
Wenn niemand anderes auf das Thema einsteigt kannst du mir gerne die Zugangsdaten per PN schicken, dann guck ich heute Nacht mal drauf ...


2 x ROT13 hält besser ...

Offline

#5 30.01.2019 19:59:58

florian
Administrator

Re: Fragstan Probleme mit mobile menu auf manchen seiten

tsrs_CheckSection kling für mich eher nach dem Modul Teasers als Auslöser... kann es sein, dass auf den betr. Seiten Teasers-Abschnitte ohne Inhalt angelegt sind und/oder da über Sectionpicker-Droplet/-modul reingezogen werden?

Offline

#6 30.01.2019 20:13:14

giz
Member

Re: Fragstan Probleme mit mobile menu auf manchen seiten

zweiteres ist der Fall, ein teasers-abschnitt der startseite wird per section-picker auf den anderen seiten eingebunden.
wir nähern uns... smile

Edit: die fehlermeldung in der konsole verweist dann auf den entsprechenden abschnitt: tsrs_CheckSection(41)
und die 41 ist der teasers-abschnitt der startseite

Last edited by giz (30.01.2019 20:20:06)

Offline

#7 30.01.2019 20:32:24

florian
Administrator

Re: Fragstan Probleme mit mobile menu auf manchen seiten

Dann füg mal in der Template-index.php vor </body> ein:

<?php if (PAGE_ID!=1) { ?>
<!--(MOVE) JS HEAD BTM- -->
<script src="<?php echo WB_URL; ?>/modules/teasers/frontend.js"></script>
<!--(END)-->
<!--(MOVE) CSS HEAD BTM- -->
<link href="<?php echo WB_URL; ?>/modules/teasers/frontend.css" rel="stylesheet" >
<!--(END)-->
<? } ?>

Die Bedingung PAGE_ID!=1 muss ggf. angepast werden (1 ist die Page-ID der Startseite, auf der der Teasers-Abschnitt ist)

Offline

#8 30.01.2019 21:11:21

giz
Member

Re: Fragstan Probleme mit mobile menu auf manchen seiten

yeeehaww big_smile  big_smile

das war's! Das mobile Menü funktioniert nun, wie erhofft. Die fehlermeldungen in der Konsole sind nun weg.

**
Jetzt etwas, das nur im Fx beim Bildschirmgrößen-Testen passiert:
Es kommt immer noch vor, dass bei öfterem Anklicken des Menüs die Seite "hängen" bleibt und man nichts mehr anklicken kann.
(Hmm, schwer zu erklären. Also normales Surfen, die unterschiedlichen Menüpunkte anklicken und irgendwann geht nix mehr. Das Menü bleibt offen stehen und das einzige was passiert, ist, dass der Cursor bei Überfahren des Hamburgermenüs sich ändert (er ändert sich zum "Anklick-Cursor"); aber der Link nicht anlickbar ist, genauso wie alle anderen Links auf der seite; auch Neuladen der Seite funktioniert nicht.
Nur den Bildschirm-Testmodus deaktivieren, Seite neuladen, das hilft.....
**
Mit "echten" Smartphones, Tablet ist dieses Verhalten nicht reproduzierbar...insofern passt das für mich.
Deshalb: Super! Dankeschön für die kompetente und überaus schnelle Hilfe!
Begeistert mich immer wieder! thumb_up

Offline

Board footer

Powered by FluxBB

up