WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 11.12.2019 15:11:35

trici
Member

Multilingual Switcher geht nicht mehr mit WBCE 1.4.1

Hallo zusammen
Nach dem Update auf WBCE 1.4.1 funktioniert der Sprachwechsel nicht mehr. Irgendeine Idee woran das liegen könnte?
Danke schon mal und Gruss
trici

Offline

#2 11.12.2019 17:35:31

florian
Administrator

Re: Multilingual Switcher geht nicht mehr mit WBCE 1.4.1

Grundeinstellungen > Erweiterte Optionen anzeigen > Mehrsprachige Webseite wieder auf "Aktiviert" schalten

Offline

Liked by:

stefanek

#3 11.12.2019 19:02:14

trici
Member

Re: Multilingual Switcher geht nicht mehr mit WBCE 1.4.1

Danke, das habe ich bereits aktiviert, geht aber trotzdem nicht. Es gibt immer die Fehlermeldung "404", komischerweise auch wenn ich im Backend auf die Ansicht einer Seite klicke.

Offline

#4 11.12.2019 19:07:03

florian
Administrator

Re: Multilingual Switcher geht nicht mehr mit WBCE 1.4.1

Kannst Du mir bitte mal Backend- und FTP-Zugangsdaten per PM oder an support@wbce.org zukommen lassen, dann schaue ich mir das mal an.

Offline

#5 11.12.2019 21:13:07

florian
Administrator

Re: Multilingual Switcher geht nicht mehr mit WBCE 1.4.1

Das Problem entsteht durch die Änderung in der class.frontend.php, bei der bei mehrsprachigen Webseiten nicht mehr beim Umschalten der ?lang-Parameter angefügt wird.
D.h. dieser Parameter entfällt nun, ein  GET-Parameter (sofern vorhanden, wie z.B. bei shortURL) wird jedoch weiterhin mit & an die URL angefügt , was vom Webserver aber nicht als Parameter, sondern Dateiname interpretiert wird und folglich zum 404 führt.
Ersetzt man das & durch ?, tritt das Problem nicht mehr auf.
So weit ich sehe, hat das keine unerwünschten Nebenwirkungen, aber es wäre gut, wenn sich das nochmal wer anders anschauen könnte.

Last edited by florian (11.12.2019 21:15:56)

Offline

Board footer

Powered by FluxBB

up