WBCE Home | WBCE Hilfe | WBCE Addon Repository | Impressum | Datenschutz

WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 15.05.2017 17:37:32

jonny
Member

HTTP 500 Fehler

Hallo Leute

Ich habe ein Problem mit der Website eines Kunde bzw mit einer spezifischen OFA Seite.
https://wymann-storentechnik.ch/pages/p … ero-60.php

Bei dieser Seite erscheint bei jedem Produkt ein HTTP 500 Fehler den ich nicht lösen kann..

Was ist falsch bzw wo liegt das Problem, da alle anderen Seiten zu funktionieren scheinen?

Jonny


Wer noch etwas Dummheit will soll sich hinten anstellen..

Offline

#2 15.05.2017 18:25:28

grindmobil
Guest

Re: HTTP 500 Fehler

So was ist übel.
Deaktiviere der Reihe nach alles, ändere das template.
Wenn du eingegrenzt hast, welches Modul genau:
Gib in dessen view.php oben irgendwo an:
die('hier');
Rufe die Seite auf. Siehst du 'hier'?
Verschiebe das, bis du den Fehler 500 hast. Zurück, vor.
Dann poste die Zeile, wo der Fehler passiert.

#3 15.05.2017 18:35:07

jonny
Member

Re: HTTP 500 Fehler

Hallo

Das Modul ist OFA, die Seite https://wymann-storentechnik.ch/pages/p … rungen.php

wird noch angezeigt aber ab dort ist dann schluss..

Seltsam ist ja, das bei allen anderen Seiten, das identische Modul (wegen aufbau einheitlich) verwendet wurde und dort nichts solches passiert.

LG


Wer noch etwas Dummheit will soll sich hinten anstellen..

Offline

#4 15.05.2017 18:39:35

grindmobil
Guest

Re: HTTP 500 Fehler

Na, dann ist auf dieser Seite was anders. Deaktiviere andere Abschnitte.

#5 15.05.2017 18:44:45

jonny
Member

Re: HTTP 500 Fehler

Leider ist auf der Seite sonst nichts anders als bei den anderen sad

Abschnitte sind auch nur dieser eine ofa


Wer noch etwas Dummheit will soll sich hinten anstellen..

Offline

#6 15.05.2017 19:44:14

grindmobil
Guest

Re: HTTP 500 Fehler

Warte hier nicht auf Eingebungen der Götter, sondern mach wie oben beschrieben.

#7 15.05.2017 20:00:40

florian
Administrator

Re: HTTP 500 Fehler

@jonny Kannst Du bitte mal bei Grundeinstellunfen > erweitert die PHP-Fehlerberichte auf E_EVERYTHING setzen und schauen, ob dann irgend eine Meldung angezeigt wird?

Offline

#8 15.05.2017 20:39:26

jonny
Member

Re: HTTP 500 Fehler

Auf der Seite erscheint immernoch error 500 oder muss ich die Fehlermeldung an einem anderen Ort abrufen?


Wer noch etwas Dummheit will soll sich hinten anstellen..

Offline

#9 15.05.2017 20:48:32

florian
Administrator

Re: HTTP 500 Fehler

Hm, ne, an sich nicht. Hast Du serverseitig Zugriff auf Errorlogs? Kannst Du da mal schauen?

Offline

#10 15.05.2017 21:16:17

ronja
Member

Re: HTTP 500 Fehler

Hi,

wenn ich ein www. vor die Domain setze kommt folgende Fehlermeldung:
www.wymann-storentechnik.ch verwendet ein ungültiges Sicherheitszertifikat. Das Zertifikat gilt nur für wymann-storentechnik.ch. Fehlercode: SSL_ERROR_BAD_CERT_DOMAIN
?

Offline

#11 15.05.2017 21:20:33

florian
Administrator

Re: HTTP 500 Fehler

Ha, ich komme der Sache gerade näher. Das könnte wieder das Problem mit dem Verzeichnis für die Uploads sein, das wir vor einigen Wochen schon mal hatten. Einträge ohne Link zum Datenblatt werden nämlich angezeigt.

Offline

#12 15.05.2017 21:34:24

jonny
Member

Re: HTTP 500 Fehler

2017-05-15 21:33:16
Error
85.1.222.25
500
GET /pages/produkte/motoren-steuerungen/steuerungen/centero-60.php HTTP/1.0


390
SSL/TLS-Zugriff für Apache
2017-05-15 21:33:16
Warning
85.1.222.25

mod_fcgid: stderr: PHP Warning: require(../../../../../config.php): failed to open stream: No such file or directory in /var/www/vhosts/wymann-storentechnik.ch/httpdocs/pages/produkte/motoren-steuerungen/steuerungen/centero-60.php on line 6


Anbei die Fehlerlogs des Servers


Wer noch etwas Dummheit will soll sich hinten anstellen..

Offline

#13 15.05.2017 21:39:46

florian
Administrator

Re: HTTP 500 Fehler

Das wird immer mysteriöser... sad
Da  ist nach meiner Zählung ein ../ zu viel. Hattest Du die OfA-Seite verschoben?

Offline

#14 15.05.2017 21:42:39

jonny
Member

Re: HTTP 500 Fehler

Nein die seite wurde einmal kreiert und danach nur noch reingebaut

Deine Zählung war korrekt ein ../ Zuviel weggenommen und es klappt ohne Probleme..

Muss ich das bei jedem File nun machen?

Woran kann das liegen?

Last edited by jonny (15.05.2017 21:47:01)


Wer noch etwas Dummheit will soll sich hinten anstellen..

Offline

#15 15.05.2017 21:53:31

florian
Administrator

Re: HTTP 500 Fehler

Höchst eigenartig.
Keine Ahnung, wie das passiert ist.
Du kannst das erstmal als Workaround bei den anderen betroffenen Einträgen (das sind ja nicht alle, erstmal durchklicken; AeroTec und AstroClic funktionieren z.B.) von Hand anpassen.
Frage ist, was bei neu angelegten Einträgen passiert.

Offline

#16 15.05.2017 21:55:31

jonny
Member

Re: HTTP 500 Fehler

Die funktionierien ev. weil ich es nun am anpassen bin wie vorgeschlagen.

Werde nachher testweise mal einen neuen hinzufügen.

Was mich eher interessiert, ist weshalb nur diese Seite Betroffen ist, nicht noch andere

Tante Edit sagt: Funktioniert jetzt alles wieder laut meinem Check und auch neue Einträge problemlos erreicht.

LG

Last edited by jonny (15.05.2017 22:01:16)


Wer noch etwas Dummheit will soll sich hinten anstellen..

Offline

Board footer

Powered by FluxBB

up