WBCE Home | WBCE Hilfe | WBCE Addon Repository | Impressum | Datenschutz

WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 26.12.2018 10:33:35

eidoil32
Member

Adding support for other languages

hello,
I'm using your add-on on my wbce system, and want to ask how  i add support using other languages like hebrew,
when i write every where, only at OneForAll add-on i got only ???? (question marks)
i don't know much php or javascripts so i don't know how to deal with it.

i would happy if someone can help me with that.
other parts on wbce deal fine with hebrew..

thanks!

Offline

#2 26.12.2018 11:36:23

florian
Administrator

Re: Adding support for other languages

Does this problem appear in the backend or in the frontend of your website?
At settings > show advanced settings > charset, which charset is selected?

Offline

#3 26.12.2018 11:39:42

eidoil32
Member

Re: Adding support for other languages

thanks for your quick answer..
in settings is on UTF-8, i tried to change it to HEBREW but it doesnt help.
but as i said before, other parts on wbce system works well with hebrew, it olny the part of OneForAll (in frontend and backend)

Last edited by eidoil32 (26.12.2018 11:40:51)

Offline

#4 26.12.2018 12:19:07

florian
Administrator

Re: Adding support for other languages

I see the problem - I've tested it with some hebrew characters, but they're indeed transformed to question marks. But they're not accepted in other modules as well (when I'm trying to create a new page with a hebrew title, there appears a warning "please enter a title", and in wysiwyg the characters are completely erased). Changing the charset in the settings to hebrew, even changing the data base / table charset does not help either.
I have no idea or solution for this issue, I'm sorry.

Last edited by florian (26.12.2018 12:19:58)

Offline

#5 26.12.2018 12:20:08

eidoil32
Member

Re: Adding support for other languages

thank you anyway... !

Offline

#6 26.12.2018 18:39:13

bernd
Developer

Re: Adding support for other languages

I can reproduce this problem and think I found the reason for this behavior:
If in the database the collation is "latin1_xxxxx" then the text will be saved as  "??????" if I change it to "utf8_unicode_ci" the hebrew characters are saved correctly.

That would also explain why e.g. WYSIWYG pages works correct and some modules don't.

! It's not enough to change the collation for the affected table, the collation must also changed for the paticular fields !

@florian:
could you please check and/or confirm this observation?


2 x ROT13 hält besser ...

Online

#7 27.12.2018 08:36:23

florian
Administrator

Re: Adding support for other languages

You're right, that does the trick. thumb_up

@eidoil32: Use a database editor like PhpMyAdmin or Adminer to switch the collation of the whole database and the mod_oneforall_...-fields to utf8_unicode_ci to solve the issue.

Last edited by florian (27.12.2018 08:37:01)

Offline

Board footer

Powered by FluxBB

up