WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 04.11.2019 17:14:34

tennstar
Member

Wunderblock wird im Frontend nicht angezeigt

Hallo,
ich bin momentan mal am ausprobieren von Wunderblock und habe dieses Modul bereit auf einer Seite, allerdings mit WB am laufen.
Leider gelingt mir dies nicht mit WBCE 1.4, PHP 7.3 bei bplaced!
Ich kann das Modul installieren, bearbeiten und speichern, wenn ich mir dies dann aber im Frontend ansehen möchte ist dort ein leerer Platz.
Soviel ich mich erinnern kann hat das mit 1.3 schon funktioniert!
Was mach ich verkehrt, hat jemand eine Idee?
Vielen schon mal!
Gruß tennstar


Ich liebe Technik wenn sie funktioniert!

Offline

#2 04.11.2019 17:17:09

byteworker
Member

Re: Wunderblock wird im Frontend nicht angezeigt

Welcher Browser? hast Du eventuell Adblocker im Einsatz die die Anzeige unterdrücken?

...wenn ich mir dies dann aber im Frontend ansehen möchte ist dort ein leerer Platz...

Nur so als Idee.

Offline

#3 04.11.2019 17:26:03

tennstar
Member

Re: Wunderblock wird im Frontend nicht angezeigt

Hallo bytworker,
habe Firefox 70.01 und Edge in Benutzung, es läuft aber auch AntiRansomware im Hintergrund.
Auf der Seite unter WB, die ich schon vor einiger Zeit zum ausprobieren angelegt habe wird der Wunderblock angezeigt!

Last edited by tennstar (04.11.2019 17:26:20)


Ich liebe Technik wenn sie funktioniert!

Offline

#4 04.11.2019 17:42:01

florian
Administrator

Re: Wunderblock wird im Frontend nicht angezeigt

Bitte mal F12, Browserkonsole öffnen, prüfen ob JS-Fehler angezeigt werden. Oder Link posten.

Offline

#5 04.11.2019 17:50:02

tennstar
Member

Re: Wunderblock wird im Frontend nicht angezeigt

Hallo flotian,
hier der Link: TG Parkstein


Ich liebe Technik wenn sie funktioniert!

Offline

#6 04.11.2019 18:20:14

florian
Administrator

Re: Wunderblock wird im Frontend nicht angezeigt

Die Scripte im Head werden in der falschen Reihenfolge geladen.
Ist das eine WBCE 1.4.0 oder eine 1.4-beta?

Offline

#7 04.11.2019 18:26:37

tennstar
Member

Re: Wunderblock wird im Frontend nicht angezeigt

Ist 1.4.0 !


Ich liebe Technik wenn sie funktioniert!

Offline

#8 04.11.2019 18:51:54

florian
Administrator

Re: Wunderblock wird im Frontend nicht angezeigt

Du hast da offensichtlich einen Bug entdeckt. Wenn es eine Wegen des Aufbaus der Template-Include gibt, wird der <head> falsch zusammengestellt, übrigens nur, wenn man nicht am Backend angemeldet ist.

Abhilfe:
1) Benenne die /templates/wbce_hortal/include.php um in /templates/wbce_hortal/include1.php
(um den Automatismus zu umgehen)
2) Füge vor </head> ein:

<?php require_once('include1.php'); ?>

Dann sollte das Problem mit WuBl usw. nicht mehr auftreten.

Last edited by florian (04.11.2019 19:01:55)

Offline

#9 04.11.2019 19:00:54

florian
Administrator

Re: Wunderblock wird im Frontend nicht angezeigt

Also, es liegt an der in die include.php ausgelagerten Initialisierung der Blöcke:

foreach($block as $k=>$v){ //und haengen in einer Schleife alle an.
    if ($k == 99) {continue;}  //ausser Block 99, der ist fuer "Keine Ausgabe" reserviert.
    ob_start(); page_content($k); $contentblock[$k] = ob_get_clean();
}

// Manche Module koennen auch einen 2. Block ausgeben, der im ersten Block definiert wurde:
if(defined('MODULES_BLOCK2') AND MODULES_BLOCK2 != '') { 
    $contentblock[2] .= MODULES_BLOCK2; //der 2. Block wird einfach erweitert.
}
if(defined('TOPIC_BLOCK2') AND TOPIC_BLOCK2 != '') { 
    $contentblock[2] = TOPIC_BLOCK2; //Bei Topics sollte der 2. Block aber vollstaendig ersetzt werden.
}

Wenn das nicht in der include.php, sondern in der index.php vor dem </head> steht, tritt der Fehler nicht auf.
Das ist also die andere Möglichkeit, das Problem zu beheben, d.h. den o.g. Code aus der include.php löschen und in die index.php - umschlossen von <?php ... ?> einfügen, also so:

<?php
foreach($block as $k=>$v){ //und haengen in einer Schleife alle an.
    if ($k == 99) {continue;}  //ausser Block 99, der ist fuer "Keine Ausgabe" reserviert.
    ob_start(); page_content($k); $contentblock[$k] = ob_get_clean();
}

// Manche Module koennen auch einen 2. Block ausgeben, der im ersten Block definiert wurde:
if(defined('MODULES_BLOCK2') AND MODULES_BLOCK2 != '') { 
    $contentblock[2] .= MODULES_BLOCK2; //der 2. Block wird einfach erweitert.
}
if(defined('TOPIC_BLOCK2') AND TOPIC_BLOCK2 != '') { 
    $contentblock[2] = TOPIC_BLOCK2; //Bei Topics sollte der 2. Block aber vollstaendig ersetzt werden.
}
?>

Edit: Anleitung konkretisiert

Last edited by florian (04.11.2019 20:09:38)

Offline

#10 04.11.2019 19:09:05

tennstar
Member

Re: Wunderblock wird im Frontend nicht angezeigt

Habs erledigt, Datei umbenannt und in der templates INDEX vor head Deinen Code eingefügt, hat leider nicht viel geändert!

Last edited by tennstar (04.11.2019 19:10:15)


Ich liebe Technik wenn sie funktioniert!

Offline

#11 04.11.2019 19:11:08

florian
Administrator

Re: Wunderblock wird im Frontend nicht angezeigt

Kannst Du mir bitte mal per PM Backend-Zugangsdaten mit Adminrechten schicken, dann schaue ich mir das mal an.

Offline

#12 04.11.2019 20:02:16

tennstar
Member

Re: Wunderblock wird im Frontend nicht angezeigt

Habs probiert, jetzt wird oberhalb der Seite folgender Code angezeigt:

foreach($block as $k=>$v){ //und haengen in einer Schleife alle an. if ($k == 99) {continue;} //ausser Block 99, der ist fuer "Keine Ausgabe" reserviert. ob_start(); page_content($k); $contentblock[$k] = ob_get_clean(); } // Manche Module koennen auch einen 2. Block ausgeben, der im ersten Block definiert wurde: if(defined('MODULES_BLOCK2') AND MODULES_BLOCK2 != '') { $contentblock[2] .= MODULES_BLOCK2; //der 2. Block wird einfach erweitert. } if(defined('TOPIC_BLOCK2') AND TOPIC_BLOCK2 != '') { $contentblock[2] = TOPIC_BLOCK2; //Bei Topics sollte der 2. Block aber vollstaendig ersetzt werden. }

PM kommt sofort!


Ich liebe Technik wenn sie funktioniert!

Offline

#13 04.11.2019 20:11:23

florian
Administrator

Re: Wunderblock wird im Frontend nicht angezeigt

Ich hatte mich oben etwas missverständlich ausgedrückt. Das ist ein PHP-Codeblock, der in <?php ... ?> stehen muss. Ich habe den Post dahingehend korrigiert und das so auch auf Deiner Seite eingebaut, nun funktioniert's.

Offline

#14 04.11.2019 20:30:49

tennstar
Member

Re: Wunderblock wird im Frontend nicht angezeigt

Danke!
Jetzt werden die Objekte zwar angezeigt, Bewegung findet keine statt!
Sie müssten doch eigentlich beweglich sein und eingeblendet werden!


Ich liebe Technik wenn sie funktioniert!

Offline

#15 04.11.2019 20:34:14

florian
Administrator

Re: Wunderblock wird im Frontend nicht angezeigt

ich schaus mir an. Die Bilder werden ja auch gerade nicht geladen. Eigenartig.

Offline

#16 04.11.2019 20:49:37

florian
Administrator

Re: Wunderblock wird im Frontend nicht angezeigt

So, also in der include.php stand noch der Code, der da raus sollte, deshalb hatte das vorher noch nicht richtig funktioniert.
Bei den fehlenden Bildern: Das ist leider eine Einschränkung des bplaced-Webspace. Bestimmte Funktionen stehen da nicht zur Verfügung, und die "wide"-Versionen der Bilder konnten deshalb nicht generiert werden. Die WuBl-Bilder dürfen da also nicht über die gesamte Breite gehen. Ich habe jetzt jeweils die Aufteilung 5:1 und Text rechts bzw. links daneben (ein leerer Absatz) gewählt, damit die Bilder angezeigt werden.

Offline

#17 04.11.2019 20:54:35

tennstar
Member

Re: Wunderblock wird im Frontend nicht angezeigt

Jetzt ist es easy!
Was war notwendig und was hast Du geändert!
Heißt das für mich jetzt, wenn ich auf meinen anderen Seiten (dies ist ja nur meine Testseite) die mit 1.4.0 laufen den Wunderblock einsetzen will, dass dies dann auch wieder nicht funktioniert!
Was kann ich tun!
Nochmals vielen, vielen Dank,  thumb_up  thumb_up


Ich liebe Technik wenn sie funktioniert!

Offline

#18 04.11.2019 21:24:29

florian
Administrator

Re: Wunderblock wird im Frontend nicht angezeigt

Was kann ich tun!

1. Weniger Ausrufungszeichen verwenden ;-)
2. Wenn auf anderen Seiten auch Hortal_WBCE/Vertal_WBCE zur Verwendung kommen, die Änderungen, die ich an der index.php und der include.php vorgenommen habe, übernehmen

Die Bilderprobleme sollten auf Nicht-Gratis-Webspace eigentlich nicht vorkommen.

Offline

#19 04.11.2019 21:32:20

florian
Administrator

Re: Wunderblock wird im Frontend nicht angezeigt

Was war notwendig und was hast Du geändert

Wie gesagt, in der include.php stand noch der Code foreach($block as $k=>$v){ ... vollstaendig ersetzt werden. } - den habe ich da rausgenommen und in die index.php eingefügt, umschlossen von <?php ... ?>, damit er als PHP-Bereich interpretiert und ausgeführt wird.
Bei WuBl gibt es in dier view.php einen kleinen Fehler, da steht in Zeile 174

$picture = $uplpicdir.'/wide/'.$picturefile; 

Da $uplpicdir aber selbst schon auf / endet, muss der / vor wide raus, also

$picture = $uplpicdir.'wide/'.$picturefile;

Das hatte aber nichts mit dem Bilderproblem zu tun, sondern das kam dadurch, das getimagesize bei bplaced nicht funktioniert, weil da gd nicht aktiviert ist.

Offline

Board footer

Powered by FluxBB

up