WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 23.11.2020 14:39:32

bbs2
Member

[Gelöst] Keine cookie-Anzeige im frontend

Hallo,

auf 2 Websites habe ich cookieconsent in Gebrauch. Auf Seite eins tcb-kl.de funktioniert es,
jedoch auf Seite 2 vlw.tcb-kl.de bei gleicher Vorgehensweise nicht.
Nur hier erscheint jedoch die Fehlermeldung

2020-11-23T11:15:00+00:00 [Notice] /modules/cookieconsent/tool.php:[24] from /admin/admintools/tool.php:[88] "Undefined variable: setError"

Was ist da schief gelaufen.

Auch die Deinstallation und Neuinstallation des Moduls brachte keine Abhilfe.
Das script ist ordnungsgemäß in die wb_settings geschrieben.

Viele Grüße
Heinz

Last edited by bbs2 (23.11.2020 14:40:56)

Offline

#2 23.11.2020 14:50:43

florian
Administrator

Re: [Gelöst] Keine cookie-Anzeige im frontend

Der <head> wird falsch zusammengesetzt, der Aufruf der cookie_consent/frontend.js erfolgt vor dem Laden von jquery.
Zusätzlich wird noch "https://cdn.jsdelivr.net/npm/cookieconsent@3/build/cookieconsent.min.js geladen, ich weiß nicht wo das herkommt.

Edit:
Bitte mal prüfen, ob die hier geschilderte Problematik auch auf Deine Seite zutrifft
https://forum.wbce.org/viewtopic.php?pid=28427#p28427

Last edited by florian (23.11.2020 15:10:38)

Offline

#3 23.11.2020 18:33:40

bbs2
Member

Re: [Gelöst] Keine cookie-Anzeige im frontend

Hallo,

es funktioniert wieder.
Allerdings habe ich das Modul deinstalliert.
Bei der Deinstallation wurde jedoch der Eintrag in der Datenbank unter wb_settings
nicht gelöscht.

Ich habe den Eintrag manuell gelöscht und dann das Modul neu installiert.

Jetzt ist alles ok.

Danke
Viele Grüße
Heinz

Offline

#4 23.11.2020 19:09:14

florian
Administrator

Re: [Gelöst] Keine cookie-Anzeige im frontend

Wahrscheinlich war der Link zu cookieconsent.min.js das Problem.

Edit: Anhang entfernt

Last edited by florian (24.11.2020 09:33:40)

Offline

Liked by:

byteworker

Board footer

Powered by FluxBB

up