WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 14.09.2022 20:19:24

hpzaun
Member

Bei Modul-Update haben sich die Module "überschnitten"

Hallo,
Ich habe letzte Woche eine Reihe von Modul-Updates durchgeführt.
Dabei haben sich wohl einige Module "überschnitten". Ich weiß nicht, wie ich es anders ausdrücken soll.
Unter Umständen war meine langsame Internet-Verbindung schuld.

So wurde das Cal_Sync-Modul mit dem Hints-Modul überschrieben.
Bei der Details zum Modul  war dann bei Calendar Sync nicht  [Calendar Sync] sondern [Hints] in der eckigen Klammer zu lesen und auch dessen Versions-Nummer zu sehen.

Ich habe mir wohl auch noch backup_plus, WBCE.CKEditor und elFinder so kaputt geschrieben.

Das Problem war mir erst nach allen Updates aufgefallen. Bei Aufruf der Backend-Seite mit dem Cal_Sync-Abschnitt hatte ich dann die Hints-Anzeige (sprich einen leeren Abschnitt wie bei einem frisch hinzugefügen Hint-Abschnitt)
Der Versuch noch einmal Cal_Sync zu installieren, wurde mit "bereits installiert" abgewiesen.

Erst die Deinstallation und Neu-Installation der obigen Module hat die Fehler behoben.
Bis auf die eingetragenen Termine von Cal_Sync habe ich keine Daten verloren.

Leider habe ich nur noch die Logs als Hinweise.
Screenshots habe ich auf den Schreck nicht gemacht.
Ziel war es zunächst, die Webseite mit den Terminen wieder lauffähig zu bekommen.
Ich kann die gesamten Log-Einträge bei Bedarf hochladen.

Im Log habe ich diese Notice gefunden.
2022-09-10 20:47:25     Notice     /modules/cal_sync/modify.php L:238
from /admin/pages/modify.php L:166     "Undefined variable: MOD_HINTS"

2022-09-10 21:04:07     Warning     /admin/media/index.php L:20
from /admin/media/index.php L:20     "include(../../modules/elfinder/tool.php): failed to open stream: No such file or directory"
2022-09-10 21:04:07     Warning     /admin/media/index.php L:20
from /admin/media/index.php L:20     "include(): Failed opening '../../modules/elfinder/tool.php' for inclusion (include_path='.:/opt/php7.4.30/lib/php')"

Mit dem Thema ist keine Frage verbunden. Nur als Information, falls andere das Problem auch einmal haben.

Schönen Abend

Text-Edit und merken: Nicht übermüdet schreiben. ops

Last edited by hpzaun (15.09.2022 20:25:26)

Online

#2 14.09.2022 21:19:41

florian
Administrator

Re: Bei Modul-Update haben sich die Module "überschnitten"

Das kann eigentlich nicht sein. Bei der Installation/Update von Modulen wird immer die info.php des jeweiligen Moduls ausgelesen, und danach richten sich dann Versionsnummer und Zielverzeichnis. Keine Ahnung, was da schief gelaufen sein könnte - in meinem 15-jährigen Einsatz von WBCE (und WB) hatte ich so ein Prhänomen wirklich noch nie.

Offline

#3 15.09.2022 19:28:00

colinax
Administrator

Re: Bei Modul-Update haben sich die Module "überschnitten"

Hallo hpzaun,

wenn es leichter ist auf Englisch zu schreiben, dann bitte auch englischen Text posten, bin mir nicht sicher ob der Translator hier einiges kaputt gemacht hat.

Für mich sieht es danach aus als ob die Module per FTP Upload im Browser oder ähnliches aktualisiert wurden.

Bitte installiere dir das Programm WinSCP verbinde dich per FTP mit dem Server und lade die Neueste WBCE hoch und lass das Update Script laufen.

Edit: wenn du uns die WBCE Admin und FTP Zugangsdaten sendet, könnten wir uns das ansehen, wenn du möchtest.

Last edited by colinax (15.09.2022 19:31:58)

Offline

#4 15.09.2022 20:46:10

hpzaun
Member

Re: Bei Modul-Update haben sich die Module "überschnitten"

Hallo
Ich habe die Installation der Module normal über ERWEITERUNGEN - Modul installieren gemacht.
Einen FTP-Upload wurde nicht gemacht.
Vor der Deinstallation habe ich noch einmal versucht über - Moduldateien manuell - die Datei: "upgrade.php" der jeweiligen Module ausführen.

Die WBCE-Installation ist aktuell:
WBCE Version: 1.5.2
Tag: 1.5.2
PHP Version: 7.4.30

Nur die  MySQL-Datenbank-Version ist 5.
An die Umstellung auf Version 8 habe ich mich noch nicht getraut.
Schöne Grüße

Online

#5 15.09.2022 21:17:20

colinax
Administrator

Re: Bei Modul-Update haben sich die Module "überschnitten"

Wurde die Domain irgendwann man auf einen anderen Hoster übersiedelt bzw. wurde die Struktur des Servers verändert dass WBCE jetzt in einem Unterordner oder ähnlichem liegt?

Kannst du uns den Hoster nennen?

Offline

#6 16.09.2022 23:47:52

ruebezahl
Member

Re: Bei Modul-Update haben sich die Module "überschnitten"

Mir ist das auch einmal (1x bei hunderten Installationen) passiert, hab’s repariert und fast vergessen… itemz und Topics.
Die Ursache habe ich nicht gefunden bzw. Konnte und wollte ich das nicht reproduzieren.

Ich kenne die o.g. Module nicht, aber:
Wird eine Variable $mod_dir verwendet?
Stammen beide vom gleichen Autor bzw. werden identische Code-Fragmente verwendet (Copy/Paste)

Offline

#7 17.09.2022 14:39:39

hpzaun
Member

Re: Bei Modul-Update haben sich die Module "überschnitten"

Hallo,
der Hoster ist 1blu. Es hat kein Umzug von einem anderen Hoster stattgefunden.

Auf dem gleichen Webspace sind in anderen Ordner noch zwei weitere WBCE-Installationen.
- Eine alte zum Testen der Funktionen, bevor sich die aktuelle Seite aufgebaut habe
- eine neue mit dem Versuch eines Blogs über meine Motorrad-Reise.
Ich habe aber davon aus, dass hier nicht die Fehlerquelle liegt.

Schöne Grüße

Online

#8 17.09.2022 19:12:02

Slugger
Member

Re: Bei Modul-Update haben sich die Module "überschnitten"

Na dann will ja hoffen, das du kein Kuddelmuddel bei der Datenbankverbindung gemacht hast.?


Hoster: ALL-INKL *** Grundsätzliche WBCE Konfig ***
WBCE: 1.5.0 • BE: 2.1.0 • PHP: 8.0.6 * 1. Projekt: FE: Simple responsive • BE: Argos * 2. Projekt: FE: hortal • BE: Argos * 3. Projekt: FE: WBCEZon • BE: Argos * 4. Projekt: FE: WBCETik • BE: Argos
Status  OK

Offline

Board footer

up