WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 15.03.2023 16:21:54

chrisho
Member

[gelöst] Nach Update auf WBCE CMS 1.6.0 Colorbox und vrgr ohne Funktion

Hallo, ich habe folgendes Problem.

Nach einem Erfolgreichen update auf WBCE 1.6.0 ohne Fehlermeldung funktionier vrgr und colorbox nicht mehr.
WBCE Version: 1.6.0 • Backend Version: 2.1.0 • PHP Version: 8.0.28 ich habe beide Module deinstalliert und wieder neu installiert.

Auf anderen Seiten, die wir betreuen, gab es keine Probleme. Die Seite, um die es geht, ist https://vorortinahlen.de/pages/posts/-1165.php.
Hat vielleicht jemand einen Tipp oder eine Lösung für mich.

Gruß Christian

Last edited by florian (16.03.2023 18:57:25)

Offline

#2 15.03.2023 16:32:10

florian
Administrator

Re: [gelöst] Nach Update auf WBCE CMS 1.6.0 Colorbox und vrgr ohne Funktion

Das ist da falsch hinterlegt. Die Klasse "colorbox" funktioniert nur bei Links. Bei Bildern muss da "vrgr" stehen.
attachment.php?item=3410&download=1

Last edited by florian (15.03.2023 16:33:38)


Code allein macht nicht glücklich. Jetzt spenden!

Offline

#3 15.03.2023 16:38:39

chrisho
Member

Re: [gelöst] Nach Update auf WBCE CMS 1.6.0 Colorbox und vrgr ohne Funktion

Hallo Florian,
danke für deine schnelle Antwort.
Ich habe vrgr eingetragen. Da tut sich dann nix.

Offline

#4 15.03.2023 16:45:18

florian
Administrator

Re: [gelöst] Nach Update auf WBCE CMS 1.6.0 Colorbox und vrgr ohne Funktion

Da scheint es mit den Outputfiltern etwas zu hapern. Kannst Du mal schauen, ob das so aussieht wie hier im Screenshot
attachment.php?item=3411&download=1

und ob im Errorlog Einträge zu finden sind, die mit dem Outputfilter zu tun haben?

Last edited by florian (15.03.2023 16:45:33)


Code allein macht nicht glücklich. Jetzt spenden!

Offline

#5 15.03.2023 17:47:29

chrisho
Member

Re: [gelöst] Nach Update auf WBCE CMS 1.6.0 Colorbox und vrgr ohne Funktion

Outputfilter sind identisch. Errorlog hat keine Einträge. Siehe Screenshot.Outputfilter

Offline

#6 15.03.2023 17:54:15

florian
Administrator

Re: [gelöst] Nach Update auf WBCE CMS 1.6.0 Colorbox und vrgr ohne Funktion

Schieb die Filter bitte mal genau in die Reihenfolge wie auf meinem Screenshot zu sehen (mit dem Anfasser rechts ziehen & loslassen).
Prüfe, ob auch der Filter "Remove System PH" aktiv ist.


Code allein macht nicht glücklich. Jetzt spenden!

Offline

#7 15.03.2023 18:08:52

chrisho
Member

Re: [gelöst] Nach Update auf WBCE CMS 1.6.0 Colorbox und vrgr ohne Funktion

Habe alle Filter der Reihenfolge aktiviert der Remove System PH Filter ist aktiv. Es geht leider immer noch nicht.

Offline

#8 15.03.2023 18:25:41

stefanek
Developer

Re: [gelöst] Nach Update auf WBCE CMS 1.6.0 Colorbox und vrgr ohne Funktion

Hallo Christian,

hast Du vor dem Upgrade Colorbox auch über einen Outputfilter verwendet oder mit einem anderen Modul? Wie?

Was sagt der Browser (Error Console) wo es sich "beißt"?


“Success is the progressive realization of a worthy ideal.” ― Earl Nightingale

Offline

#9 15.03.2023 18:41:06

chrisho
Member

Re: [gelöst] Nach Update auf WBCE CMS 1.6.0 Colorbox und vrgr ohne Funktion

Hallo Stefanek,

ich hab Colorbox und vrgr ganz normal unter Erweiterungen/Module installiert. Bis zum Upgrade hat es auch super funktionier.
Das komische ist, dass die Seite https://www.zechewestfalen.de/ identisch mit der vorort Seite ist. Gleicher Server, gleiches Template
und auch identische Installationen. Da läuft alles super mit vrgr und colorbox.

Offline

Liked by:

stefanek

#10 15.03.2023 18:48:43

chrisho
Member

Re: [gelöst] Nach Update auf WBCE CMS 1.6.0 Colorbox und vrgr ohne Funktion

Danke bis hierhin erst einmal.
Leider muss ich jetzt Arbeiten, habe noch zwei Veranstaltungen, wo ich hin muss.
Morgen geht die Fehlersuche weiter.

Grüß Christian.

Offline

#11 15.03.2023 19:16:01

stefanek
Developer

Re: [gelöst] Nach Update auf WBCE CMS 1.6.0 Colorbox und vrgr ohne Funktion

chrisho wrote:

Hallo Stefanek,

ich hab Colorbox und vrgr ganz normal unter Erweiterungen/Module installiert. Bis zum Upgrade hat es auch super funktionier.

Dann würde ich sagen, schalte den Filter einfach aus hier im Dashboard, weil die beiden Skripte miteinander zu kollidieren scheinen.
attachment.php?item=3411&download=1


“Success is the progressive realization of a worthy ideal.” ― Earl Nightingale

Offline

#12 16.03.2023 14:58:23

chrisho
Member

Re: [gelöst] Nach Update auf WBCE CMS 1.6.0 Colorbox und vrgr ohne Funktion

Danke, ich habe jetzt im Dashboard colorbox ausgeschaltet und über den Link colorbox eingegeben, so läuft es erst einmal wieder.

Gruß
Christian

Offline

Liked by:

stefanek

#13 16.03.2023 15:31:00

florian
Administrator

Re: [gelöst] Nach Update auf WBCE CMS 1.6.0 Colorbox und vrgr ohne Funktion

Hm, das ist aber nicht der Sinn der Sache. Irgendwas stimmt da ja dann trotzdem nicht.


Code allein macht nicht glücklich. Jetzt spenden!

Offline

#14 16.03.2023 17:04:18

stefanek
Developer

Re: [gelöst] Nach Update auf WBCE CMS 1.6.0 Colorbox und vrgr ohne Funktion

Wie meinst Du denn?
Wenn sowohl Snippet alsauch OpFilter aktiv sind, kollidieren sie.

Was wir machen könnten ist beim Upgradescript abzufragen, ob Snippet installiert ist. Wenn ja würde geschaut ob OpFilter installiert ist und wenn ja, wie eingestellt und dann die Einstellung übernehmen.

Christian


“Success is the progressive realization of a worthy ideal.” ― Earl Nightingale

Offline

#15 16.03.2023 17:08:25

florian
Administrator

Re: [gelöst] Nach Update auf WBCE CMS 1.6.0 Colorbox und vrgr ohne Funktion

So wie ich den TO verstanden habe, funktioniert vrgr immer noch nicht (wieder). Und im Quellcode sind immer noch die System Placeholder, die eigentlich rausgefiltert werden müssten.

@chrisho: kannst Du versuchsweise mal eine Seite auf das Standardtemplate (WBCEZon) umstellen und schauen, ob die Probleme mit vrgr da auch auftreten?


Code allein macht nicht glücklich. Jetzt spenden!

Offline

#16 16.03.2023 17:08:54

chrisho
Member

Re: [gelöst] Nach Update auf WBCE CMS 1.6.0 Colorbox und vrgr ohne Funktion

Das stimmt, ich werde auch nicht aufgeben, bis der Fehler gefunden ist.
Kann es vielleicht an der Datenbank liegen? Gibt es dort einen Eintrag,
der bei mir nicht in der Datenbank vorhanden ist.

Offline

#17 16.03.2023 17:15:33

chrisho
Member

Re: [gelöst] Nach Update auf WBCE CMS 1.6.0 Colorbox und vrgr ohne Funktion

Ich habe das Standardtemplate kurz auf WBCEZon umgestellt und getestet. Hat aber auch nicht funktioniert.

Offline

#18 16.03.2023 17:17:08

florian
Administrator

Re: [gelöst] Nach Update auf WBCE CMS 1.6.0 Colorbox und vrgr ohne Funktion

Ja, schon gesehen, ich hatte zufällig gerade den Moment auf die Seite geschaut.
Kannst Du uns eventuell mal einen Backend-Zugang (Admin-Rechte) per PM schicken, dass wir mal direkt draufschauen können?


Code allein macht nicht glücklich. Jetzt spenden!

Offline

#19 16.03.2023 17:26:39

chrisho
Member

Re: [gelöst] Nach Update auf WBCE CMS 1.6.0 Colorbox und vrgr ohne Funktion

PN ist raus.

Offline

Liked by:

florian

#20 16.03.2023 18:57:11

florian
Administrator

Re: [gelöst] Nach Update auf WBCE CMS 1.6.0 Colorbox und vrgr ohne Funktion

For the record: in der Datenbank standen für einige Filter falsche Pfade (vgl. https://forum.wbce.org/viewtopic.php?pid=39198#p39198)


Code allein macht nicht glücklich. Jetzt spenden!

Offline

#21 16.03.2023 19:10:19

chrisho
Member

Re: [gelöst] Nach Update auf WBCE CMS 1.6.0 Colorbox und vrgr ohne Funktion

Vielen Dank! Echt super, ich ziehe meinen Hut! Der Fehler lag in der Datenbank. Alles läuft jetzt wieder rund.

Gruß
Christian

Offline

Liked by:

florian

Board footer

up