WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#26 24.04.2024 14:33:07

webbird
Administrator

Re: Test wbProfiles 2.0 ALPHA

florian wrote:

4. Featurewunsch:
Derzeit haben die Detaileinträge keinen eigenen <tile>, sondern fungieren unter dem selben <title> wie die Übersichtsseite. Das ist SEO-mäßig sehr ungünstig. Es wäre schön, wenn der Eintrags-Titel auch als <title> übernommen würde. (Oder ist das im Template anzupassen?)

Der komplette Header wird ja von WBCE ausgegeben. Hast Du schnell einen Link, was ich tun müßte? Die TITLE Konstante ändern geht ja nicht. Da das bei BC anders läuft, hab ich grad nicht parat, was ich tun muss.


Ich habe eine Amazon-Wishlist. wink Oder spende an das Projekt.
Ich kann, wenn ich will, aber wer will, dass ich muss, kann mich mal

Offline

#27 24.04.2024 14:37:14

webbird
Administrator

Re: Test wbProfiles 2.0 ALPHA

Entweder

<!--(REPLACE) TITLE -->
<title>Anderer Titel</title>
<!--(END)-->

oder

<!--(PH) TITLE+ --> / <!--(PH) TITLE- -->

oder?


Ich habe eine Amazon-Wishlist. wink Oder spende an das Projekt.
Ich kann, wenn ich will, aber wer will, dass ich muss, kann mich mal

Offline

#28 24.04.2024 14:43:18

florian
Administrator

Re: Test wbProfiles 2.0 ALPHA

ja, evtl. klappt es mit replace, kommt drauf an, ob wbp die wbce-hooks zu fassen kriegt. mir ist vage so, dass es da zumindest früher Probleme gab.
kann gerade nicht testen, bin unterwegs.


Nicht ärgern. Nur wundern.

Offline

#29 24.04.2024 15:02:40

Slugger
Member

Re: Test wbProfiles 2.0 ALPHA

Also ich bin immer noch in den Anfängen. So weit wie florian bin ich nicht

- Aphla3 heruntergeladen
- Versucht über die Erweiterung zu installieren.
- gleiches Problem wie vorher.
- Sehe kein Modul.

Aber ich mache zur Zeit gerade ein "DAU".

Ich muss erstmal wieder die Reste entfernen und nochmal versuchen, mir fehlt gerade die Zeit.


Hoster: ALL-INKL *** Grundsätzliche WBCE Konfig ***
WBCE: 1.5.4 • BE: 2.1.0 • PHP: 8.1.16 * 1. Projekt: FE: Simple responsive • BE: Argos * 2. Projekt: FE: hortal • BE: Argos * 3. Projekt: FE: WBCEZon • BE: Argos * 4. Projekt: FE: WBCETik • BE: Argos
Status Projekt 1-4:  OK

Offline

#30 24.04.2024 16:53:47

florian
Administrator

Re: Test wbProfiles 2.0 ALPHA

@Slugger - am besten eine frische WBCE-Installation aufsetzen und da testen.


Nicht ärgern. Nur wundern.

Offline

#31 29.04.2024 15:00:54

webbird
Administrator

Re: Test wbProfiles 2.0 ALPHA

Hoffentlich alles erledigt, bitte weitere / übersehene / immer noch existierende Fehler neu melden.


florian wrote:

1.)  Kategorien > Neue Kategorie > Absenden => leere Seite, Kategorie wird nicht angelegt
2024-04-23T13:53:59+00:00 [Exception] There was an unknown exception: SQLSTATE[42S22]: Column not found: 1054 Unknown column 'cat_position' in 'field list' in line (690) of /modules/wbProfiles/inc/wblib/wbQuery.php


(2024-04-29) Da habe ich das neue Datenbankfeld in der install.php (bzw. structure.sql) vergessen. ops Quick fix: upgrade.php ausführen oder

ALTER TABLE `<TABLE_PREFIX>mod_profiles_categories` ADD `cat_position` INT(11) UNSIGNED NULL DEFAULT '1' AFTER `cat_visible`;
florian wrote:

2.) Frontend:
Klick auf "« Zurück"-Link führt auf URL der wbp-Seite mit URL-Parameter ?do=cat&cat_id=1
=> Fehlermeldung (im FE)  Param cat_id missing or invalid
Klick auf "Eintrag" in Breadcrumb führt auf wbp-Seite mit URL-Parameter ?do=item&
=> Meldung (im FE) einfach nur "item_id"


(2024-05-06) Vielleicht hab ich schon an meinen Templates rumgeschraubt und hab die Details vergessen *hust*, aber "Zurück" gibt es bei mir nicht und auf den "Eintrag" im Breadcrumb kann man auch nicht klicken. Aber die beiden anderen Links ("Übersicht" und auf die Kategorie) hab ich geprüft und repariert.

attachment.php?item=3591&download=1

Nachtrag: Stelle gefunden, nur wird bei mir kein "backlink" generiert, warum auch immer. Sollte dann aber auch gefixt sein.


florian wrote:

II. Das Verzeichnisrechte-Problem:
1. Verzeichnis wbProfiles unter media und wbProfiles/profile_files und wbProfiles/cat_pics dort werden mit 0775 angelegt, bei den Grundeinstellungen ist aber 0755 hinterlegt (0775 fest verdrahet?). profile_files_for_sectionXX hat hingegen korrekt 0755.


(2024-04-29) Ja, 0775 ist fest verdrahtet.

EDIT: (2024-05-06) In der init.php wird jetzt eine Konstante gesetzt, die wiederum auf STRING_DIR_MODE gesetzt ist. Fallback ist 0775. Ich hoffe, ich habe jetzt alle Stellen gefunden, wo ich noch mkdir() benutzt habe.


florian wrote:

2. Verzeichnis wbProfiles /profile_files_for_sectionXX/profile_pics hat leider immer noch 1366 => dadurch lassen sich dann auch Änderungen nicht speichern  (" Unable to open base directory [/.../media/wbProfiles/profile_files_for_section_9/profile_pics]")

So sieht es bei Hoster A aus:
https://forum.wbce.org/attachment.php?i … download=1


Nachtrag: Ich habe das jetzt gerade nochmal auf einer anderen Website bei einem anderen Hoster getestet, auch hier tritt das Phänomen auf.
Bei diesem Hoster ist es sogar so, dass die Rechte sich auch per FTP nicht ändern lassen. Im FTP-Client erscheint zwar das Verzeichnis, ist aber nicht zugreifbar.
So sieht es bei Hoster B aus:
https://forum.wbce.org/attachment.php?i … download=1
https://forum.wbce.org/attachment.php?i … download=1
https://forum.wbce.org/attachment.php?i … download=1


(2024-05-06) (Hoffentlich) erledigt mit Beta1.


florian wrote:

III. Weiteres:
1. Neuen Eintrag übers Backend anlegen:
a) Geht, aber im Errorlog erscheint

2024-04-23T13:58:24+00:00 [Visitor Request] h.../admin/pages/modify.php?page_id=7&do=list
2024-04-23T13:58:24+00:00 [Warning] /modules/wbProfiles/inc/wblib/wbI18n.php:[131] from /modules/wbProfiles/inc/wbProfilesAdmin.php:[55] wbProfilesBase->__construct "Array to string conversion"
2024-04-23T13:58:36+00:00 [Visitor Request] h.../admin/pages/modify.php?page_id=7
2024-04-23T13:58:36+00:00 [Warning] /modules/wbProfiles/inc/wblib/wbI18n.php:[131] from /modules/wbProfiles/inc/wbProfilesAdmin.php:[55] wbProfilesBase->__construct "Array to string conversion"
2024-04-23T13:58:37+00:00 [Visitor Request] h.../admin/pages/modify.php?page_id=7&do=list&item_id=&edit=1
2024-04-23T13:58:37+00:00 [Warning] /modules/wbProfiles/inc/wblib/wbI18n.php:[131] from /modules/wbProfiles/inc/wbProfilesAdmin.php:[55] wbProfilesBase->__construct "Array to string conversion"

b) Dieselben Meldungen erscheinen beim Bearbeiten eines vorhanden Eintrags


Kann ich bei mir derzeit nicht reproduzieren. Welches Template-Verzeichnis verwendest Du?


florian wrote:

c) Anmerkung: Klick auf "Speichern" führt bei neuem Eintrag auf Eintrags-Übersicht zurück (analog "Save & Back"). Bei bereits bestehenden Einträgen ist das Verhalten wie erwartet (Speichern verweilt auf Eingabeformular, Save+Back führt zurück)


(Eigentlich war das so gewollt, ich verstehe aber, dass es irritierend ist.)

(2024-05-06) Erledigt mit Beta1.


florian wrote:

2. Item lock/unlock:
Funktioniert, aber auch:

2024-04-23T14:26:52+00:00 [Visitor Request] h.../admin/pages/modify.php?page_id=9&do=list&wbp_cat_id=1&item_id=1&lock=on
2024-04-23T14:26:52+00:00 [Warning] /modules/wbProfiles/inc/wblib/wbI18n.php:[131] from /modules/wbProfiles/inc/wbProfilesAdmin.php:[55] wbProfilesBase->__construct "Array to string conversion"


Tritt bei mir nicht auf, vielleicht schon durch was anderes behoben.


florian wrote:

3. Eintrag löschen im BE:
Funktioniert nicht bzw. es passiert nichts. JS-Error (Konsole)

Uncaught TypeError: modalFader is null


(2024-04-29) Gefixt mit Beta1.


florian wrote:

4. Weitere JS-Fehler auf der Konsole (bei allen Reitern)

GET
h.../modules/wbProfiles/js/datatables.min.js
[HTTP/1.1 404 Not Found 36ms]

JQMIGRATE: Migrate is installed, version 1.4.1 jquery-migrate-min.js:2:552
GET
h.../modules/wbProfiles/js/datatables.min.js
[HTTP/1.1 404 Not Found 16ms]

Uncaught ReferenceError: simpleDatatables is not defined


(2024-04-29) Gefixt mit Beta1. (Vorerst keine Nutzung von DatatablesJS im Backend.)


florian wrote:

5. Versuch, Einstellungen zu ändern:
Eingaben werden im ersten Anlauf nicht übernommen, d.h. es passiert weiter nichts bei Klick auf "Speichern", außer dass  die Einstellungen-Seite unverändert geladen wird, im Errorlog erscheint

2024-04-23T14:16:14+00:00 [Visitor Request] h.../admin/pages/modify.php?page_id=9
2024-04-23T14:16:14+00:00 [Warning] /modules/wbProfiles/inc/wblib/wbI18n.php:[131] from /modules/wbProfiles/inc/wbProfilesAdmin.php:[55] wbProfilesBase->__construct "Array to string conversion"

Wenn man dann nochmal auf "Speichern" klickt (obwohl wieder die vorherigen Werte angezeigt werden) werden die Änd. übernommen...??? Rätselhaft o_O
(Anmerkung: Ich habe zuvor die unter II.2 erwähnten Verzeichnisrechte per FTP manuell korrigiert, um Änderungen an den Einstellungen vornehmen zu können)


Doch, die werden gespeichert, nur wird das Formular nicht neu geladen. Wenn Du speicherst und danach einfach nochmal auf den Tab "Einstellungen" klickst (auf dem Du ja schon bist), siehst Du, dass es gespeichert wurde.

(2024-05-16) Gefixt mit Beta1.


florian wrote:

IV. Frontend:

1. Aufruf Detailseite erzeugt Einträge im Errorlog
2x

2024-04-23T14:04:12+00:00 [Visitor Request] h.../pages/wbp.php?do=item&item=1
2024-04-23T14:04:12+00:00 [Warning] /modules/wbProfiles/inc/wblib/wbI18n.php:[131] from /modules/wbProfiles/inc/wbProfiles.php:[41] wbProfilesBase->__construct "Array to string conversion"


tbd
Bei mir nicht, weder im BE noch im FE. Vielleicht schon gefixt. Bei Dir kam es ja oft zu dieser "Array to string conversion", wenn die einmal gefixt ist, sollten auf einen Schlag mehrere Probleme behoben sein.


florian wrote:

2. Eintrag erstellen:
Funktioniert, aber auch hier mehrmals

2024-04-23T14:38:47+00:00 [Warning] /modules/wbProfiles/inc/wblib/wbI18n.php:[131] from /modules/wbProfiles/inc/wbProfiles.php:[41] wbProfilesBase->__construct "Array to string conversion"


tbd
s.o.


florian wrote:

3. Registrierung:
Funktioniert so weit.
Zu einfaches Passwort wird abgeleht ("Ungültiges Kennwort"), allerdings wird nirgend erklärt, welche Anforderungen an das PW bestehen,


Doch, wird es, aber ist wohl zu unaufdringlich. ;D
attachment.php?item=3587&download=1

Erledigt mit Beta1.


florian wrote:

4. Featurewunsch:
Derzeit haben die Detaileinträge keinen eigenen <tile>, sondern fungieren unter dem selben <title> wie die Übersichtsseite. Das ist SEO-mäßig sehr ungünstig. Es wäre schön, wenn der Eintrags-Titel auch als <title> übernommen würde. (Oder ist das im Template anzupassen?)

(2024-05-06) Machbar durch Eintrag in item_details.tpl

<!--(REPLACE) TITLE -->
<title>{{ item_name }}</title>
<!--(END)-->



Ergänzungen von Bianka : Known Bugs

Captcha hat keinen Effekt

(2024-05-16) Gefixt mit Beta1.

Anmerkung: Es wird nur der Inhalt geprüft, nicht das Alter.


Bei Vertippern bei der Passwortwiederholung sagt es "Elemente [{{ 0 }}] und [Password] müssen gleich sein!"

Gefixt.

attachment.php?item=3599&download=1


Unten drunter sind bei Neueinträgen die Schaltflächen doppelt, wenn beim ersten Absenden ein Fehler im Formular auftrat

Gefixt.

Last edited by webbird (13.06.2024 17:42:03)


Ich habe eine Amazon-Wishlist. wink Oder spende an das Projekt.
Ich kann, wenn ich will, aber wer will, dass ich muss, kann mich mal

Offline

Liked by:

mk70

#32 30.04.2024 13:32:40

florian
Administrator

Re: Test wbProfiles 2.0 ALPHA

zur Frage des Templateverzeichnisses: das voreingestellte ("default")

Work in progress, ich schreibe hier jeweils dazu, wenn es was Neues zu dem Punkt gibt! Das heißt dieser Beitrag ändert sich mit der Zeit!

Eine Anmerkung dazu: Die Forensoftware hier versendet bei Änderungen an bestehenden Posts keine Benachrichtigungen, und das Beitragsdatum, was für die "Aktiv"-Seite relevant ist, ändert sich auch nicht . Man bekommt es daher nicht unbedingt mit, wenn sich Änderungen an obigem Post ergeben.
Wenn es der Sache dienlich ist, kann ich die Tage ein Testsystem aufsetzen auf einer Subdomain, um das Modul unter Echtbedingungen testen zu können und auch einen Bugtracker installieren.

Last edited by florian (30.04.2024 13:33:07)


Nicht ärgern. Nur wundern.

Offline

#33 06.05.2024 18:30:44

webbird
Administrator

Re: Test wbProfiles 2.0 ALPHA

florian wrote:

ja, evtl. klappt es mit replace, kommt drauf an, ob wbp die wbce-hooks zu fassen kriegt. mir ist vage so, dass es da zumindest früher Probleme gab.
kann gerade nicht testen, bin unterwegs.

Klappt bei mir mit

[== HTML ==]
<!--(REPLACE) TITLE -->
<title>{{ item_name }}</title>
<!--(END)-->

In der item_details.tpl unterbringen.

Hier gab's ein paar Updates: https://forum.wbce.org/viewtopic.php?pid=43663#p43663

Last edited by webbird (06.05.2024 18:31:13)


Ich habe eine Amazon-Wishlist. wink Oder spende an das Projekt.
Ich kann, wenn ich will, aber wer will, dass ich muss, kann mich mal

Offline

Liked by:

stefanek, florian

#34 13.05.2024 15:41:12

webbird
Administrator

Re: Test wbProfiles 2.0 ALPHA

Zur Info, ich habe ab nächste Woche Urlaub, und auch wenn ich nicht wegfahre, werde ich den Computer doch weitestgehend meiden. Ob ich diese Woche noch die Beta fertig kriege, bezweifle ich.


Ich habe eine Amazon-Wishlist. wink Oder spende an das Projekt.
Ich kann, wenn ich will, aber wer will, dass ich muss, kann mich mal

Offline

Liked by:

florian

#35 16.05.2024 18:16:50

webbird
Administrator

Re: Test wbProfiles 2.0 ALPHA

Allgemeine Info zum Registrierungsformular: Da ich gelernt habe, dass es im Sinne der Barrierefreiheit hilfreich ist, Fehler in einem Eingabeformular oberhalb des Formulars aufzulisten und dabei auf die entsprechenden Stellen zu verlinken, sieht das in wbProfiles dementsprechend aus.

attachment.php?item=3598&download=1

Die Liste ist entsprechend gefüllt, d.h. wenn man z.B. versucht, das Formular komplett leer abzuschicken, sind hier alle Pflichtfelder aufgelistet.

Last edited by webbird (16.05.2024 18:18:52)


Ich habe eine Amazon-Wishlist. wink Oder spende an das Projekt.
Ich kann, wenn ich will, aber wer will, dass ich muss, kann mich mal

Offline

Liked by:

florian

#36 13.06.2024 17:40:17

webbird
Administrator

Re: Test wbProfiles 2.0 ALPHA

So Ihr Lieben, nach Urlaub hier nun endlich die Beta1.

Edit: Hoppala, noch eine Exception gefunden. Lade gleich eine Korrektur hoch.

Last edited by webbird (13.06.2024 17:56:59)


Ich habe eine Amazon-Wishlist. wink Oder spende an das Projekt.
Ich kann, wenn ich will, aber wer will, dass ich muss, kann mich mal

Offline

#37 13.06.2024 18:42:40

webbird
Administrator

Re: Test wbProfiles 2.0 ALPHA

Neuer Versuch...


Ich habe eine Amazon-Wishlist. wink Oder spende an das Projekt.
Ich kann, wenn ich will, aber wer will, dass ich muss, kann mich mal

Offline

#38 17.06.2024 09:39:18

Slugger
Member

Re: Test wbProfiles 2.0 ALPHA

Hallo Webbird,
bin mal über das WE auf das Modul gestürzt.

BETA1
1. Installation in einem laufenden WBCE - funktionierte, bis auf den "Refresh" nach Installation im BE. Bei klicken auf eine andere Registerkarte alles da.
2. Registrieren im FE und  anlegen eines Profiles OK, Freischaltcode wurde gesendet. Nach klick darauf eine Fehlermeldung "missing cat_id" oder so. Aber der Eintrag ist vorhanden.

Kategorie "General", habe noch keine anderen angelegt.

Frage: Welche PW-Verschlüsselung wird genutzt?

Last edited by Slugger (17.06.2024 09:40:23)


Hoster: ALL-INKL *** Grundsätzliche WBCE Konfig ***
WBCE: 1.5.4 • BE: 2.1.0 • PHP: 8.1.16 * 1. Projekt: FE: Simple responsive • BE: Argos * 2. Projekt: FE: hortal • BE: Argos * 3. Projekt: FE: WBCEZon • BE: Argos * 4. Projekt: FE: WBCETik • BE: Argos
Status Projekt 1-4:  OK

Offline

#39 17.06.2024 11:48:42

webbird
Administrator

Re: Test wbProfiles 2.0 ALPHA

Danke für den Test. Was meinst Du mit "Refresh"?

PW-Verschlüsselung ist sha1.


Ich habe eine Amazon-Wishlist. wink Oder spende an das Projekt.
Ich kann, wenn ich will, aber wer will, dass ich muss, kann mich mal

Offline

#40 17.06.2024 12:22:04

webbird
Administrator

Re: Test wbProfiles 2.0 ALPHA

Slugger wrote:

2. Registrieren im FE und  anlegen eines Profiles OK, Freischaltcode wurde gesendet. Nach klick darauf eine Fehlermeldung "missing cat_id" oder so. Aber der Eintrag ist vorhanden.

Hm. Ich konnte das jetzt einmalig reproduzieren, FM: "Eintrag nicht gefunden oder Freischaltschlüssel falsch!"

Alle weiteren Versuche seither haben funktioniert.


Ich habe eine Amazon-Wishlist. wink Oder spende an das Projekt.
Ich kann, wenn ich will, aber wer will, dass ich muss, kann mich mal

Offline

#41 17.06.2024 13:42:43

Slugger
Member

Re: Test wbProfiles 2.0 ALPHA

webbird wrote:

Danke für den Test. Was meinst Du mit "Refresh"?

PW-Verschlüsselung ist sha1. thumb_up

Nach der Installation sieht man das hier nicht auf dem Bild (Die Kacheln waren nicht da, bzw. kann ich mich nicht mehr daran erinnern ob eine erfolgreiche Installation kam.

Last edited by Slugger (17.06.2024 13:43:01)


Hoster: ALL-INKL *** Grundsätzliche WBCE Konfig ***
WBCE: 1.5.4 • BE: 2.1.0 • PHP: 8.1.16 * 1. Projekt: FE: Simple responsive • BE: Argos * 2. Projekt: FE: hortal • BE: Argos * 3. Projekt: FE: WBCEZon • BE: Argos * 4. Projekt: FE: WBCETik • BE: Argos
Status Projekt 1-4:  OK

Offline

#42 17.06.2024 13:48:50

webbird
Administrator

Re: Test wbProfiles 2.0 ALPHA

Hm. Muss ich mal ausprobieren. Das kann eigentlich nur passieren, wenn bei der Modulinstallation was schief läuft und es dadurch zu einem Abbruch der Verarbeitung durch WBCE kommt. Oder auch anders: Eine Art "white page of death", nur später. Dann müßte aber auch was in den Logs zu finden sein.


Ich habe eine Amazon-Wishlist. wink Oder spende an das Projekt.
Ich kann, wenn ich will, aber wer will, dass ich muss, kann mich mal

Offline

#43 17.06.2024 14:03:15

Slugger
Member

Re: Test wbProfiles 2.0 ALPHA

Ok ich schau nach den Logs, da habe ich nicht reingeschaut -> Vergessen  devil

... so anbei Log seit gestern.

Die letzte Meldung

2024-06-17T11:49:32+00:00 [Warning] /modules/wbProfiles/inc/wbProfilesBase.php:[811] from /modules/wbProfiles/inc/wbProfilesBase.php:[823] wbProfilesBase->getDirectories "opendir(/.../media/wbProfiles/profile_files_for_section_36): Failed to open directory: Permission denied"

.

sieht bei mir auf FTP auf dem Bild aus. Die Rechte habe ich im Nachgang korrigiert.

Last edited by Slugger (17.06.2024 14:07:45)


Hoster: ALL-INKL *** Grundsätzliche WBCE Konfig ***
WBCE: 1.5.4 • BE: 2.1.0 • PHP: 8.1.16 * 1. Projekt: FE: Simple responsive • BE: Argos * 2. Projekt: FE: hortal • BE: Argos * 3. Projekt: FE: WBCEZon • BE: Argos * 4. Projekt: FE: WBCETik • BE: Argos
Status Projekt 1-4:  OK

Offline

#44 17.06.2024 14:10:12

webbird
Administrator

Re: Test wbProfiles 2.0 ALPHA

Och, menno, immer noch so ein blödes Rechteproblem... Ich hatte so gehofft ich hätte jetzt alle Stellen erwischt. cry


Ich habe eine Amazon-Wishlist. wink Oder spende an das Projekt.
Ich kann, wenn ich will, aber wer will, dass ich muss, kann mich mal

Offline

#45 17.06.2024 14:28:25

Slugger
Member

Re: Test wbProfiles 2.0 ALPHA

Ich habe noch eine txt Datei der Log seit der Installation gestern im Anhang


Hoster: ALL-INKL *** Grundsätzliche WBCE Konfig ***
WBCE: 1.5.4 • BE: 2.1.0 • PHP: 8.1.16 * 1. Projekt: FE: Simple responsive • BE: Argos * 2. Projekt: FE: hortal • BE: Argos * 3. Projekt: FE: WBCEZon • BE: Argos * 4. Projekt: FE: WBCETik • BE: Argos
Status Projekt 1-4:  OK

Offline

#46 18.06.2024 14:26:02

webbird
Administrator

Re: Test wbProfiles 2.0 ALPHA

Da mein KanBoard eine Macke hat, habe ich ein (privates) GitHub-Projekt angelegt. Wer Zugriff möchte, braucht ein GitHub-Konto. Ansonsten einfach melden.


Ich habe eine Amazon-Wishlist. wink Oder spende an das Projekt.
Ich kann, wenn ich will, aber wer will, dass ich muss, kann mich mal

Offline

#47 19.06.2024 18:07:50

florian
Administrator

Re: Test wbProfiles 2.0 ALPHA

Das von Slugger beschriebene Zugriffsrechteproblem mit dem Verzeichnis profile_files_for_section_XX kann ich leider bestätigen.

> Ändern der Einstellungen:
-  führt ohne manuell korrigierte Verzeichniszugriffsrechte zur Exception (leeres Backend, Fehlermeldung " Unable to open base directory [/.../media/wbProfiles/profile_files_for_section_1]")*
- Nach Ändern der Zugriffsrechte werden nach dem Speichern Änderungen nicht sofort angezeigt.* 
  Das ist vermutlich das, was Slugger mit Refresh meinte.
  Man kriegt auch keine Bestätigung dafür, dass die Änderungen übernommen wurden. sad

> Die Verzeichnisse /media/wbProfiles, .../profile_files werden mit 0775 angelegt (statt mit den bei den Grundeinstellungen hinterlegten 0755)*

> Der WYSIWYG-Editor verwendet nicht die editor.css
> Speichern von Einträgen (BE/FE) erzeugt Eintrag im Errorlog

2024-06-19T15:45:07+00:00 [Warning] /modules/wbProfiles/inc/wblib/wbFormBuilder.php:[1221] from /modules/wbProfiles/inc/wbProfilesBase.php:[2300] wbFormBuilder->insertBefore "Array to string conversion"

(WBCE 1.6.2, PHP 8.2.20)

> Klick auf RSS-Button im FE erzeugt Exception

2024-06-19T15:46:42+00:00 [Visitor Request] http:// ... /modules/wbProfiles/rss.php?section_id=1
2024-06-19T15:46:42+00:00 [Warning] /modules/wbProfiles/rss.php:[18] from /modules/wbProfiles/rss.php:[18] "include(/.../modules/wbProfiles/inc/wblib/class.wbValidate.php): Failed to open stream: No such file or directory"
2024-06-19T15:46:42+00:00 [Warning] /modules/wbProfiles/rss.php:[18] from /modules/wbProfiles/rss.php:[18] "include(): Failed opening '/.../modules/wbProfiles/inc/wblib/class.wbValidate.php' for inclusion (include_path='.:/vrmd/webserver/php-8.2.20/lib/php')"
2024-06-19T15:46:42+00:00 [Warning] /modules/wbProfiles/rss.php:[43] from /modules/wbProfiles/rss.php:[43] "include(/.../modules/wbProfiles/inc/class.wbProfiles.php): Failed to open stream: No such file or directory"
2024-06-19T15:46:42+00:00 [Warning] /modules/wbProfiles/rss.php:[43] from /modules/wbProfiles/rss.php:[43] "include(): Failed opening '/.../modules/wbProfiles/inc/class.wbProfiles.php' for inclusion (include_path='.:/vrmd/webserver/php-8.2.20/lib/php')"
2024-06-19T15:46:42+00:00 [Exception] There was an unknown exception: Class "wbProfiles" not found in line (44) of /modules/wbProfiles/rss.php

(mMn ist RSS aber eh so tot wie myspace und kann eigentlich weg)

> Nach dem Upload der ersten Bilder wird dann ein Verzeichnis media/wbProfiles/profile_files_for_section_1/profile_pics angelegt, auch dies leider mit den falschen (Nicht-)Zugriffsrechten (1363)*, und auch das darin befindliche Unterunterunterverzeichnis... naja. *
Ähm, die Nutzung von Bordmitteln von WBCE kämen da als Lösungsansatz wohl nicht evtl. infrage?


* Ich weiß, dass ich das schon mal reportet hatte, aber das Problem besteht halt immer noch.


Davon abgesehen: Benutzerregistrierung, Anlegen von Kategorien, Hinterlegen von Kategoriebildern, Anlegen von Einträgen via FE/BE, Datenupload, Bearbeiten von Einträgen, Anklicken von Links zu Kategorie-Übersichtsesiten funktionieren  thumb_up

Last edited by florian (19.06.2024 18:11:06)


Nicht ärgern. Nur wundern.

Offline

#48 19.06.2024 18:22:15

webbird
Administrator

Re: Test wbProfiles 2.0 ALPHA

Also was die Zugriffsrechte angeht bin ich nochmal alles durchgegangen und es gibt IMHO nur noch eine Stelle, wo ich *nicht* WBCE-Bordmittel verwende, und die ist nur für BC1. So langsam hab ich da auch keine Lust mehr. *grmpf*

Nein, man bekommt beim Speichern der Einstellungen keine Rückmeldung (nur im Fehlerfall), bei mir werden aber die aktuellen Einstellungen sofort (wieder) angezeigt.

Es ist nicht geplant, die editor.css zu laden. Das Einbinden des WYSIWYG-Editors ist in WBCE nicht so trivial, da es keine globale Schnittstelle dafür gibt. Man muss selber nach dem installierten Editor suchen, und die Funktion show...* eignet sich nicht für die Kombination mit der wblib bzw. dem wbFormBuilder. Daher wird auch ausdrücklich nur der CKE unterstützt. Ansonsten könnte man evtl. mal eine Markdown-Unterstützung einbauen, aber nicht für lau. Dann eher gar kein WYSIWYG mehr sondern nur noch eine stumpfe Textarea. Wer dann WYSIWYG braucht, muss es sich selber über das Template einbinden. Standardmäßig war ja nur so ein abgespeckter Mini-Editor (in der wblib) drin.

Es kommt jetzt noch eine Beta, dann ein oder zwei RCs und dann das Release. Warnings oder Deprecated-Meldungen im Log, die keine offensichtlichen Auswirkungen haben, müssen dann eben erst mal toleriert werden.


Ich habe eine Amazon-Wishlist. wink Oder spende an das Projekt.
Ich kann, wenn ich will, aber wer will, dass ich muss, kann mich mal

Offline

#49 19.06.2024 18:27:15

florian
Administrator

Re: Test wbProfiles 2.0 ALPHA

Danke für die Rückmeldung. Dann weiß ich Bescheid.
Den CKE bitte drin lassen.


Nicht ärgern. Nur wundern.

Offline

#50 19.06.2024 18:43:39

webbird
Administrator

Re: Test wbProfiles 2.0 ALPHA

Anbei die Beta2. Es gab wirklich viele Änderungen, hier mal einige:

Templates

Es werden jetzt drei Templates mitgeliefert: default (Grundlage für alle anderen), addresslist und datatables. Alle drei wurden komplett überarbeitet und unter anderem folgende Bugs / Unvollständigkeiten behoben:

  • [Bug] Anzeige von Bildern erfolgte nur, wenn JS Slider aktiviert ist

  • [Verbesserung] Anzeige von Bildern ohne JS Slider

  • [Bug] "Accordion" in Template "adresslist" verhielt sich merkwürdig

  • ...viele Kleinigkeiten...

Einstellungen

  • Die maximale Größe aller Uploads zu einem Beitrag kann jetzt in MB (statt bisher Bytes) eingegeben werden

  • input type="number" da wo es sinnvoll ist (statt Dropdown oder reinem Eingabefeld)

Weiteres

  • Unterstützung von Tags finalisiert (wurden in den Beiträgen noch nicht angezeigt)

  • Templates können jetzt zusätzlich eine (updatesichere) custom.css beinhalten, die bei Existenz automatisch eingebunden wird

  • Jede Menge Bugfixes

...und jede Menge mehr.

Wenn das mit den Dateisystemrechten jetzt immer noch nicht hinhaut geb ich es auf...

Last edited by webbird (19.06.2024 18:52:39)


Ich habe eine Amazon-Wishlist. wink Oder spende an das Projekt.
Ich kann, wenn ich will, aber wer will, dass ich muss, kann mich mal

Offline

Board footer

up