WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 22.11.2017 22:07:01

micon
Member

nochmal: Problem nach Update auf 1.3

Hier bin ich schon wieder, habe das jetzt erst bemerkt: Nach dem Update kann ich keine Dateien im Verzeichnis /media mehr Hochladen / Umbenenen / Löschen.
Rechte im FTP-Verzeichnis sind alle unverändert und OK.

Fehlermeldung bei Upload:

Warning: move_uploaded_file(/www/htdocs/.../wbce/media/bilder/Beleg.jpg): failed to open stream: Permission denied in /www/htdocs/.../wbce/admin/media/upload.php on line 78

Fehlermeldung bei Löschen:

Warning: unlink(/www/htdocs/.../wbce/media//bilder/Beifall.gif): Permission denied in /www/htdocs/.../wbce/admin/media/delete.php on line 102
Die ausgewählte Datei konnte nicht gelöscht werden

Last edited by florian (22.11.2017 22:20:04)

Offline

#2 22.11.2017 22:21:47

florian
Administrator

Re: nochmal: Problem nach Update auf 1.3

Offline

#3 22.11.2017 22:27:04

bernd
Developer

Re: nochmal: Problem nach Update auf 1.3

Rechte im FTP-Verzeichnis sind alle unverändert und OK.

Ganz sicher? Auch der Datei-Eigentümer?


... nein in Europa verwenden wir beim Programmieren nicht € statt $ ...

Offline

#4 22.11.2017 22:30:35

florian
Administrator

Re: nochmal: Problem nach Update auf 1.3

Offline

#5 22.11.2017 22:56:02

micon
Member

Re: nochmal: Problem nach Update auf 1.3

Verzeichnis- und Dateirechte waren tatsächlich alle OK. Habe daraufhin die Besitzrechte rekursiv auf PHP-User geändert - und sie die Daten lassen sich wieder hochladen und löschen.

Seltsam ist nur:
1. Ich bin mir sicher, dass die Besitzrechte vor dem Update auf FTP-User standen, und es hat dennoch alles funktioniert.

2. Ich habe eine andere Domain, die ebenfalls auf einem all-inkl-Server liegt, auch auf WBCE 1.3 umgestellt. Hier funktioniert alles korrekt, OHNE die Besitzrechte zu ändern. Ich habe eben nochmal nachgeschaut, dort stehen alle Verzeichnisse nach wie vor auf FTP-Server, und es funktioniert.

Wirklich SELTSAM

Offline

#6 23.11.2017 06:42:00

screamindan
Member

Re: nochmal: Problem nach Update auf 1.3

AllInkl? Guck mal ob im KAS PHP 7.0 (CGI) eingestellt ist...

Offline

Liked by:

florian

#7 23.11.2017 11:01:37

micon
Member

Re: nochmal: Problem nach Update auf 1.3

OK, habe im KAS auf PHP 7.0 umgestellt. JDamit funzt auch der PHP-User.

Offline

Board footer

Powered by FluxBB

up