WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#26 13.04.2018 13:08:08

webbird
Administrator

Re: Fraggy Backend Theme v2.6.8 verfügbar

WAH! Hoffentlich zerlegt das nicht wieder alles...


Ich habe eine Amazon-Wishlist. wink Oder spende an das Projekt.
Ich kann, wenn ich will, aber wer will, dass ich muss, kann mich mal

Offline

#27 15.04.2018 17:44:42

rjgamer
Developer

Re: Fraggy Backend Theme v2.6.8 verfügbar

Die Veränderungen sind nicht kritisch, respektive nach mir sind keine Features weggefallen die in irgend einem Projekt wie Fraggy schon verwendet hätte.

Ein Update auf Bootstrap 4.1 wird spätestens im Mai 2018 folgen.

Offline

Liked by:

colinax

#28 15.04.2018 21:26:35

colinax
Administrator

Re: Fraggy Backend Theme v2.6.8 verfügbar

rjgamer wrote:

Ein Update auf Bootstrap 4.1 wird spätestens im Mai 2018 folgen.

Finde ich gut so, dann hast mit Bootstrap 4.1.1 auch einen stable release. 4.1.0 ist ja laut den Entwicklern nur aus zeitlichen Gründen veröffenlicht worden.

Offline

#29 23.07.2018 13:30:31

rjgamer
Developer

Re: Fraggy Backend Theme v2.6.8 verfügbar

Hallo zusammen,

ich arbeite gerade an der Version 2.1.0 des Fraggy Backend Themes.

Irgendwelche Wünsche für den neuen Releases? Bis jetzt habe ich einfach mal auf Bootstrap 4.1.3 aktualisiert. Mehr aber nicht.

Oder ist jemandem evt. ein Fehler in der laufenden WBCE Beta aufgefallen?

Gruss rjgamer

Last edited by rjgamer (12.08.2018 19:24:37)

Offline

Liked by:

florian, stefanek, ice, colinax

#30 24.07.2018 10:00:25

rjgamer
Developer

Re: Fraggy Backend Theme v2.6.8 verfügbar

Keine Wünsche sind auch gut. Einfach nicht später kommen...  big_smile

Offline

Liked by:

colinax

#31 24.07.2018 10:17:31

ice
Member

Re: Fraggy Backend Theme v2.6.8 verfügbar

Ich nutze dein Backend schon eine ganze Weile, und bin damit zufrieden, deswegen keine Wünsche, alles in Ordnung.

Last edited by ice (24.07.2018 10:18:43)

Offline

Liked by:

screamindan

#32 02.08.2018 19:47:42

trici
Member

Re: Fraggy Backend Theme v2.6.8 verfügbar

Wäre schön, wenn der save-button im ckEditor funktionieren könnte. Geht bei mir jedenfalls nicht (mehr).
Dies ist praktisch wenn man viele Abschnitte hat, so muss man nicht nach jedem speichern wieder runterscrollen und den Abschnitt suchen.
Ansonsten tipptopp, vielen Dank.

Offline

#33 03.08.2018 09:55:38

colinax
Administrator

Re: Fraggy Backend Theme v2.6.8 verfügbar

trici wrote:

Wäre schön, wenn der save-button im ckEditor funktionieren könnte. Geht bei mir jedenfalls nicht (mehr).
Dies ist praktisch wenn man viele Abschnitte hat, so muss man nicht nach jedem speichern wieder runterscrollen und den Abschnitt suchen.
Ansonsten tipptopp, vielen Dank.

Hi trici,

Könntest Du uns bitte sagen welcher save Button gemeint ist?

Wenn ich dich richtig verstehe hat dein Wunsch nichts mit Fraggy zu tun sondern mit den WBCE Core(-Modulen)

Offline

#34 03.08.2018 19:53:03

trici
Member

Re: Fraggy Backend Theme v2.6.8 verfügbar

Hallo colinax
Ich hänge mal ein Scrennshot an, damit du besser siehst, welchen save-button ich meine. Mit dem Standard WBCE Flat Theme geht's, nur leider nicht mit Fraggy.

Offline

#35 04.08.2018 08:11:51

colinax
Administrator

Re: Fraggy Backend Theme v2.6.8 verfügbar

Ok der Button sollte eigentlich nichts mit Fraggy zu tun haben.

Kannst Du bitte in der (Browser-)Konsole (F12) nachschauen, ob dort Fehler angezeigt werden?

Dann wäre noch interessant welche WBCE, PHP, CKE installiert ist und wie Du den CKE updatest?

Offline

#36 04.08.2018 12:25:57

colinax
Administrator

Re: Fraggy Backend Theme v2.6.8 verfügbar

@Trici und rjgamer der Fehler ist bestätigt, wie es aussieht sind bestimmte Werte in der script(.min).js nicht mit jquery kompatible.

Last edited by colinax (07.08.2018 07:40:02)

Offline

#37 04.08.2018 12:46:48

trici
Member

Re: Fraggy Backend Theme v2.6.8 verfügbar

Ah, danke, war gerade am nachschauen.
Also bis WBCE 1.1 (PHP 5.6 und 7.1) funktionierte der Button. Ab WBCE Version 3.1 nicht mehr. In der Konsole fehlt z.B. jquery-migrate-min.js, ev. liegt es daran? Dies als ergänzende Info.

Offline

Liked by:

stefanek, colinax

#38 06.08.2018 18:12:40

rjgamer
Developer

Re: Fraggy Backend Theme v2.6.8 verfügbar

Hiho, sorry gerade beruflich viel los. Danke fürs gucken, ich werde es versuchen zu fixen und melde mich wieder.

Offline

#39 06.08.2018 20:42:21

rjgamer
Developer

Re: Fraggy Backend Theme v2.6.8 verfügbar

Hi,

also ich hab auch das Problem mit dem SaveButton, aber ich kann eure Test-Resultate nicht reproduzieren. Ich sehe keinen Fehler beim script.min.js, vielmehr eine Inkompatibilität mit dem SaveButton Plugin von CKEditor und jQuery. Siehe Screenshot.

Könnt ihr mir paar Infos mehr liefern zu euren Tests?

Gruss rjgamer

Offline

#40 06.08.2018 21:40:17

colinax
Administrator

Re: Fraggy Backend Theme v2.6.8 verfügbar

Ich habs jetzt gezielter geprüft, das Problem liegt in der ibox.js des wbsave Plugins, die nicht mit jquery 3.x kompatible ist.

Die einfachste Lösung wäre wenn Fraggy jQuery Migrate mit ausliefern würde.

Offline

Liked by:

stefanek

#41 11.08.2018 08:17:23

rjgamer
Developer

Re: Fraggy Backend Theme v2.6.8 verfügbar

Habs geschafft. Lag nicht am jQuery, sondern am Selektor im WBSave Plugin des CKEditors, der den Inhalt mittels der CSS Klasse .content gesucht und beim Fraggy nichts gefunden hatte.

Ich musste daher in der header.htt am Schluss der Datei, beim offenen Element bevor der Inhalt gerendert wird, noch die CSS Klasse "content" hinzufügen:
            <div class="container-fluid">
                <div class="content-body content">
                    <!-- END header_block -->

Jetzt gehts. Wird im 2.1.0 vom Fraggy dann gefixt sein.

Last edited by rjgamer (12.08.2018 19:15:03)

Offline

Liked by:

stefanek, florian

#42 11.08.2018 09:22:48

rjgamer
Developer

Re: Fraggy Backend Theme v2.6.8 verfügbar

Sonst noch Wünsche oder Fehler die erst in der WBCE 1.3.2 aufgetreten sind?

Gruss rjgamer

Offline

#43 12.08.2018 19:24:50

rjgamer
Developer

Re: Fraggy Backend Theme v2.6.8 verfügbar

Korrektur, Fraggy wird auf Bootstrap 4.1.3 aktualisiert.

Offline

#44 13.08.2018 15:20:08

rjgamer
Developer

Re: Fraggy Backend Theme v2.6.8 verfügbar

Hallo zusammen,

die Version 2.1.0 von Fraggy Backend Theme wurde veröffentlicht. Für den "einfachen" Benutzer verändert sich aber nicht viel: Bootstrap wurde auf die neuste Version aktualisiert, ein Bug im Zusammenspiel mit dem CKEditor wurde behoben und das Caching der Custom Logos und Favicons wurde implementiert.

Der neue Release kann direkt via der Fraggy-eigenen Update-Funktion installiert werden (unten Rechts beim Dashboard im Adminbereich). Ich würde mich über Feedbacks freuen, ob das Ganze bei euch funktioniert hat. cool

Gruss rjgamer

---------------------

Du kannst den neusten Release (exkl. Source Code) des Fraggy Backend Themes vom offiziellen GitHub Repository herunterladen. Für alle Webdesigner und Entwickler gibt es natürlich auch einen Source Code Release.

Changelog (nur die Differenz zur Vorgängerversion und in Englisch)

  • Updated to Bootstrap 4.1.3

  • Custom logo and favicon will be cached now (client-side)

  • Added missing CSS class for the WBSave plugin of the CKEditor

Bitte die Anleitung in der README für das eigene Logo und Favicon lesen! Neu können die Bilder auch direkt im Medien-Ordner oder sogar in das Hauptverzeichnis der WBCE-Installation hochgeladen werden. Mit diesem Lösungsansatz und der Fraggy-eigenen API wird das erneute Hinzufügen nach einer Aktualisierung hinfällig. thumb_up

Gemäss README wird für Fraggy Backend Theme zwingend die Version 1.3 von WBCE oder neuer vorausgesetzt. Ältere Versionen von WBCE werden nicht mehr unterstützt.

Die Entfernung des "Designed by"-Vermerks sowie den Links zu neoflow.ch und wbce.org ist lizenzrechtlich verboten!

---------------------

Ich bin Spenden via PayPal nicht abgeneigt (gerade wenn Fraggy auch in kommerziellen Projekten verwendet wird)  tongue

Offline

Liked by:

cwsoft, bernd, ice, jps77

#45 14.08.2018 15:33:34

ice
Member

Re: Fraggy Backend Theme v2.6.8 verfügbar

Auto-Update hat wunderbar funktioniert! Danke!

Last edited by ice (14.08.2018 15:33:46)

Offline

Liked by:

rjgamer

#46 14.08.2018 15:49:10

giz
Member

Re: Fraggy Backend Theme v2.6.8 verfügbar

Auto-Update ohne Probleme durchgelaufen.
Danke thumb_up


WBCE 1.5.4 - Fraggy 2.6.8 - PHP 8.0.26 - All-inkl
Ein Leben ohne Hund ist möglich, aber sinnlos

Offline

Liked by:

rjgamer

#47 16.08.2018 06:49:04

rjgamer
Developer

Re: Fraggy Backend Theme v2.6.8 verfügbar

Hallo zusammen,

kleiner Bugfix-Release in der Version 2.1.1 veröffentlicht. Obwohl Fraggy schon einen cURL-Check implementiert hatte, wurde vor dem Check schon eine cURL-spezifische Variable verwendet, was dann zu einem API-seitigen Fehler des Auto-Updaters führen konnte - sofern cURL als PHP Extension beim Webserver deaktiviert war. Danke colinax für den Hinweis! thumb_up

Der Release kann wie üblich über den Auto-Updater installiert werden - sofern man natürlich cURL als PHP Extension aktiviert hat. Ansonsten wird aber ab der Version 2.1.1 nun eine hübsche, in rot gefärbte Meldung im Panel des Auto-Updaters erscheinen. wink

Gruss rjgamer

---------------------

Du kannst den neusten Release (exkl. Source Code) des Fraggy Backend Themes vom offiziellen GitHub Repository herunterladen. Für alle Webdesigner und Entwickler gibt es natürlich auch einen Source Code Release.

Changelog (nur die Differenz zur Vorgängerversion und in Englisch)

  • Fixed cURL check for auto updater

Gemäss README wird für Fraggy Backend Theme zwingend die Version 1.3 von WBCE oder neuer vorausgesetzt. Ältere Versionen von WBCE werden nicht mehr unterstützt.

Die Entfernung des "Designed by"-Vermerks sowie den Links zu neoflow.ch und wbce.org ist lizenzrechtlich verboten!

---------------------

Ich bin Spenden via PayPal nicht abgeneigt (gerade wenn Fraggy auch in kommerziellen Projekten und bei Kunden verwendet wird).

Last edited by rjgamer (22.03.2019 15:34:25)

Offline

Liked by:

better-work

#48 06.02.2019 13:23:00

ice
Member

Re: Fraggy Backend Theme v2.6.8 verfügbar

Hallo, hier ein kleiner Hinweis:

Mit dem aktuellen Fraggy Backend Theme wird in den Allgemeinen Einstellungen von mpform der Abschnitt "E-Mail-Einstellungen (Bestätigungsmail an Formularabsender)" nicht angzeigt. Es wird nur diese Überschrift angezeigt, aber die ganzen Einstellungen darunter werden abgeschnitten.

Mit dem WBCE Flat Theme wird alles richtig angezeigt.

Last edited by ice (06.02.2019 13:23:11)

Offline

#49 08.02.2019 10:15:19

mrbaseman
Developer

Re: Fraggy Backend Theme v2.6.8 verfügbar

Ich kann es reproduzieren. Der Abschnit wird aber nicht abgeschnitten sondern die Überschrift erscheint bei Fraggy unterhalb der Tabelle.

Innerhalb des mpForm Moduls kann man sie aber wieder nach oben schieben, indem man das backend.css anpasst ( > CSS-Einstellungen > Backend.css ):
die folgende Zeile suchen:

.settings_table caption           { color: #fff !important; font-size: 16px; font-weight: bold; line-height: 160%; background-color: #515d76; background-image: url("images/box_bg.png"); background-repeat: repeat-x; text-align: left; margin-top: 8px; padding-top: 4px; padding-left: 10px; height: 35px; border: 1px #515d76 }

und ändern in (den ersten Eintrag in den geschweiften Klammern mit hinzufügen):

.settings_table caption           { caption-side: top; color: #fff !important; font-size: 16px; font-weight: bold; line-height: 160%; background-color: #515d76; background-image: url("images/box_bg.png"); background-repeat: repeat-x; text-align: left; margin-top: 8px; padding-top: 4px; padding-left: 10px; height: 35px; border: 1px #515d76 }

Die Anpassung kommt in die nächste Version mit rein, aber die CSS-Dateien werden beim Update nicht automatisch überschrieben, damit die Anpassungen durch den Benutzer nicht jedesmal verloren gehen. Nur bei Neuinstallationen werden die Dateien angelegt, ansonsten wird nur die Vorlage als backend.default.css abgelegt und der Benutzer muss die Anpassungen ggf. manuell einpflegen (oder natürlich die Vorlage einfach über backend.css drüber kopieren, wenn er selbst keine Änderungen vorgenommen hat)

Offline

Liked by:

ice

#50 08.02.2019 10:18:18

mrbaseman
Developer

Re: Fraggy Backend Theme v2.6.8 verfügbar

ah und da seh ich gerade, ich hab selbst eine alte Version der css Datei. In neueren Versionen ist das schöner formatiert:

.settings_table caption { 
    caption-side: top;   /* diese Zeile neu  einfügen */
    color: #fff !important; 
    font-size: 16px; 
    font-weight: bold; 
    line-height: 160%; 
    background-color: #515d76; 
    background-image: url("images/box_bg.png"); 
    background-repeat: repeat-x; 
    text-align: left; 
    margin-top: 8px; 
    padding-top: 4px; 
    padding-left: 10px; 
    height: 35px; 
    border: 1px #515d76 
}

Offline

Liked by:

ice

Board footer

up