WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 08.02.2017 13:07:47

kleo
Member

MiniSlider

Es gibt ein gutes und einfaches MiniSlider Modul von dev4me.com.

Leider funktionert es bei mir mit dem frisch installierten WBCE nicht.

Weiß jemand, wie man es zum Laufen bringt?

Offline

#2 08.02.2017 13:13:35

florian
Administrator

Re: MiniSlider

Hallo und willkommen,

den Fehler kann ich hier nicht reproduzieren. Wie äußert sich das Problem genau?

Eventuell fehlen im verwendeten Frontend-Template vor dem </head> die Zeilen

<?php
	register_frontend_modfiles('css');
	register_frontend_modfiles('js');
 ?>

Offline

#3 08.02.2017 13:23:14

kleo
Member

Re: MiniSlider

Bei der Installation des Modules keine Probleme.
Bei den Einstellungen des Modules keine Probleme.
Bei dem Upload der Bilder keine Probleme.

Beim Aufrufen der entsprechenden Seite siht man nur eine dünne schwarze Linie. Mehr nichts.

Ich habe es bei der Standarstemplate getestet sowie bei der Sypiags.
sypiags hat die Code:

   if(function_exists('register_frontend_modfiles')) {
    register_frontend_modfiles('css');
	register_frontend_modfiles('jquery');
    register_frontend_modfiles('js');
}

Offline

#4 08.02.2017 13:31:59

kleo
Member

Re: MiniSlider

Danke für so eine schnelle Antwort!!!

Es funktioniert jetzt auch bei mir! Ich habe nichts geändert.
Es lag wahrscheinlich an der Serverseite.

Aber trotzdem VIELEN DANK ! ! ! !

Offline

Liked by:

florian

#5 09.03.2017 20:27:17

kleo
Member

Re: MiniSlider

Das Modul gefählt mir sehr.
Ich habe aber einige Kleinigkeiten entdeckt, die mich stören.

Und zwar:
- bei der Ausgabe von den Capitons werden die Umlauten nicht unterstützt. Bei der Eingabe im Backend sieht es normal aus, bei der Ausgabe im Frontend werden die  Umlauten nicht dargestellt. Soll bei irgendeiner Datei der Zeichensatz geändert werden? Wenn Ja, bei welcher?

- es wäre nicht schlecht, wenn die alternativ Texte von Bilder irgendwo eingegeben werden könnten. Momentan kann man lediglich nur die Titel von Bildern als Capitons eingeben. Kann man es irgendwie erweitern?

Offline

#6 09.03.2017 22:05:41

florian
Administrator

Re: MiniSlider

Das Umlautproblem kannst Du umgehen, indem Du die Umlaute maskierst:
ä = &auml;
ö = &ouml;
ß = &szlig;
usw.
Bildbeschreibungen abgesehen von Bildtiteln sieht MiniSlider nicht vor. Wenn Du so etwas benötigst, schau Dir mal das Modul Itemz an, da gibt es Presets, die dem recht nahe kommen.

Offline

#7 15.03.2017 12:38:15

kleo
Member

Re: MiniSlider

Danke für den Vorschlag. Es funktionert gut.

Es wäre aber sinnvolll das Modul für die Mehrsprachigkeit wirklich fit zu machen.
Das Modul ist einfach und gefällt mir sehr. Ich würde es versuchen diesen Fehler zu lösen.
Ich vermute, es liegt an dem verwendeten Zeichensatz bei irgendeiner Datei. Oder soll ich nach anderen Ursachen schauen?

Offline

#8 15.03.2017 20:01:40

florian
Administrator

Re: MiniSlider

Ich kann das Problem mit den Umlauten hier gerade nicht reproduzieren, was ist denn bei Dir für ein Zeichensatz (=> Grundeinstellungen) hinterlegt?

Offline

#9 15.03.2017 21:20:12

kleo
Member

Re: MiniSlider

Ich habe jetzt es bei zwei Webseiten überprüft:
bei einer geht es tatsächlich (!), bei der anderen aber nicht...

Die Webseiten werden bei verschiedenen Hoster gehostet.
Bei beiden: die Sprache ist Deutsch, der Zeichensatz ist utf8.

Ich werde jetzt die Modulversionen vergleichen und ggb. die einzelnen Moduldateien von beiden Webseiten, nicht dass ich da etwas versehnetlich geändert habe...

Hm...

Offline

#10 15.03.2017 21:21:14

kleo
Member

Re: MiniSlider

Jedenfalls: Danke für die Antwort!!!

Offline

#11 16.03.2017 20:05:27

kleo
Member

Re: MiniSlider

Ich habe alles überprüft.

Ich verwende bei 4 Webseiten die gleiche Version des Minisliders.
Allerdings bei 3 verschiedenen Hoster.

Die Ergebnisse:
1. Bei one.com funktioniert alles anstandslos, nicht nur Umlaute, sondern griechischen und auch kyrilischen Buchstaben werden korrekt dargestellt

2. Bei 1and1.com werden Umlauten dargestellt, aber keinen griechischen und kyrilischen Buchstaben

3. Bei strato.de weder Umlauten noch griechischen oder kyrilischen Buchstaben

Bei allen 4 Webseiten steht Deutsch als Haupsprache und utf8 als Zeichensatz.

Beim Speichern von capitons bei Minislider-Settings gehen bei strato und 1&1 die griechischen und kyrilischen Buchstaben verloren, an deren Stelle erscheinen beim nächsten Aufruf im backend Fragezeichen. Die Umlauten werden im backend zwar korrekt abgespeichert, erscheinen im frontend aber nicht korrekt.

Die wysiwyg-sectionen stellen bei allen Hoster alle Buchstaben aber ganz korrekt dar!!!

Eine Idee, wo der Hund begraben ist???

Last edited by kleo (16.03.2017 20:07:36)

Offline

#12 17.03.2017 06:22:13

kleo
Member

Re: MiniSlider

Ich bin einen Schritt nächer gekommen.

Bei one.com haben die Felder des Moduls Minislider die Collation utf8_general_ci
Bei strato.de aber latin_german1_ci !!!!

Obwohl die beiden DB sowohl bei  one.com als auch bei strato.de die Collation utf8 haben!

Das heißt: das bei der Installation des Moduls der im WBCE Adminbereich eingestellte Zeichensatz NICHT IMMER übernommen wird! Oder?

Woran liegt es?

Offline

#13 17.03.2017 13:06:59

evaki
Guest

Re: MiniSlider

WB/WBCE stellt sich auf Vorgaben des Servers ein, und die (mysql, php, http) sollten dann auch aufeinander abgestimmt sein. Was passiert, wenn MySQL und ein Client miteinander Daten austauschen?


MySQL Information wb/wbce-Admin-Modul
Es kann beispielsweise durchaus so aussehen:

 character_set_client = latin1    
    character_set_connection = latin1    
    character_set_database = latin1    
    character_set_filesystem = binary    
    character_set_results = latin1    
    character_set_server = latin1    
    character_set_system = utf8    
    collation_connection = latin1_swedish_ci    
    collation_database = latin1_swedish_ci    
    collation_server = latin1_swedish_ci     

Die Umlautproblematik (2007)
Setting WB to UTF8 (2012)
WB/WBCE und utf8mb4_unicode_ci

Last edited by evaki (17.03.2017 15:55:29)

Board footer

up