WBCE Home | WBCE Hilfe | WBCE Addon Repository | Impressum | Datenschutz

WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#26 25.09.2017 16:53:04

webbird
Developer

Re: LeafletMaps Darstellungsfehler

thanks wrote:

• Aufgefallen ist mir noch ein kosmetisches Problemchen: Speichere ich unter Einstellungen die Konfiguration, erscheint kurz links oben eine OK-Häkchen in weiß auf weißen Grund, sichtbar eigentlich nur, weil der dort befindliche schwarze Text überlagert wird. Absicht oder übersehen?

Also von mir ist der nicht. angel Meine "Debug-Ausgaben" sind nicht so subtil. devil


Some people just need a high-five. In the face. With a chair.

Offline

Liked by:

thanks

#27 25.09.2017 16:57:28

webbird
Developer

Re: LeafletMaps Darstellungsfehler

florian wrote:

Ich weiß nicht, ob es ein Bug oder Feature ist, aber wenn mehrfach ein Marker derselben Farbe verwendet wird, hat er im Frontend immer den Glyph, der für den zuerst angelegten Marker dieser Fabe angegeben wurde, unabhängig davon, was ihm in Backend zugewiesen wird.

Bug!

In meiner DB war mir aufgefallen, dass die Glyph-Spalte in der falschen Tabelle war. Ich hab da nicht weiter drauf geachtet, in Entwicklungsumgebungen kann das ja schon mal passieren. (Wenn man 3 CMS parallel auf hat landen die Sachen auch schon mal in der falschen Datenbank, da ist die falsche Tabelle ja nun wirklich eine Kleinigkeit...) Aber Deiner Beobachtung nach scheint der Fehler dann ja doch im Release gelandet zu sein. Die Spalte "glyph" gehört in die Tabelle "*_markers" und sonst nirgendwohin. Wenn Du sie noch woanders hast, bitte mal löschen und nochmal testen.

Edit: Daran scheint es nicht zu liegen, ich schau mal nach.

Edit 2: Liegt am JavaScript, tatsächlich habe ich pro Icon nur einen Glyph vorgesehen.

Edit 3: Also doch ein Feature. devil

Last edited by webbird (25.09.2017 17:08:40)


Some people just need a high-five. In the face. With a chair.

Offline

#28 25.09.2017 17:08:18

webbird
Developer

Re: LeafletMaps Darstellungsfehler

Versuch's mal hiermit.


Some people just need a high-five. In the face. With a chair.

Offline

#29 25.09.2017 17:18:08

florian
Projektmanagement und Support WBCE CMS

Re: LeafletMaps Darstellungsfehler

Jep, damit tritt der Bug nicht mehr auf.  thumb_up

Offline

#30 25.09.2017 18:11:01

webbird
Developer

Re: LeafletMaps Darstellungsfehler

Gut, nächste Version gibt es dann, wenn ich das Modul mit BC 1 und 2 getestet habe. Bis dahin könnt Ihr ja das JS aus dem Thread nehmen und manuell austauschen.


Some people just need a high-five. In the face. With a chair.

Offline

#31 01.11.2017 19:54:10

miotop
Member

Re: LeafletMaps Darstellungsfehler

Hallo, ich habe festgestellt, dass LeafletMaps ab iPhone6 und neuer die Flags in der Karte nicht anzeigt.
Beispiel: simdrive.ch
Hat noch jemand dieses Problem?
//miotop

Offline

#32 01.11.2017 20:16:37

florian
Projektmanagement und Support WBCE CMS

Re: LeafletMaps Darstellungsfehler

Hallo und willkommen,

ich habe leider (?) kein iphone, kann dir aber - schwacher Trost - immerhin sagen, dass das Problem mit Android 6 auf dem smartphone nicht auftritt.

Offline

#33 02.11.2017 10:45:00

webbird
Developer

Re: LeafletMaps Darstellungsfehler

Ich hab leider nur ein uraltes IPhone 4S. Ich weiß nicht, inwieweit die Emulatoren wirklich zuverlässig sind. Von anderer Stelle weiß ich aber, dass iOS Geräte allgemein Probleme haben, die andere nicht haben. Wir haben z.B. eine Anmeldeseite für einen Newsletter, die überall bedienbar ist, nur nicht unter iOS. Da ist nur die Hälfte des Formulars zu sehen. (Trotz Responsive Design.)
Ich recherchiere mal, ob das ein bekannter Fehler mit LeafletJS bzw. dem Glyph-Plugin ist. Oder, andersrum: Wenn Du mit dem IPhone auf die Seite von LeafletJS gehst, besteht das Problem dann auch? -> http://leafletjs.com/


Some people just need a high-five. In the face. With a chair.

Offline

#34 02.11.2017 17:13:06

thanks
Member

Re: LeafletMaps Darstellungsfehler

Ich habe ein nicht ganz so uraltes iPhone 5, dort ist die Darstellung in Ordnung.

Last edited by thanks (02.11.2017 17:13:27)

Offline

#35 02.11.2017 19:43:59

webbird
Developer

Re: LeafletMaps Darstellungsfehler

Na immerhin. big_smile Wäre aber interessanter ob die Darstellung im Modul auch in Ordnung ist. *smile* Vermutlich liegt es ja an meinem JavaScript Code.

Last edited by webbird (02.11.2017 19:44:56)


Some people just need a high-five. In the face. With a chair.

Offline

Board footer

Powered by FluxBB

up