WBCE Home | WBCE Hilfe | WBCE Addon Repository | Impressum | Datenschutz

WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#26 25.09.2017 17:53:04

webbird
Developer

Re: LeafletMaps Darstellungsfehler

thanks wrote:

• Aufgefallen ist mir noch ein kosmetisches Problemchen: Speichere ich unter Einstellungen die Konfiguration, erscheint kurz links oben eine OK-Häkchen in weiß auf weißen Grund, sichtbar eigentlich nur, weil der dort befindliche schwarze Text überlagert wird. Absicht oder übersehen?

Also von mir ist der nicht. angel Meine "Debug-Ausgaben" sind nicht so subtil. devil


Some people just need a high-five. In the face. With a chair.

Offline

Liked by:

thanks

#27 25.09.2017 17:57:28

webbird
Developer

Re: LeafletMaps Darstellungsfehler

florian wrote:

Ich weiß nicht, ob es ein Bug oder Feature ist, aber wenn mehrfach ein Marker derselben Farbe verwendet wird, hat er im Frontend immer den Glyph, der für den zuerst angelegten Marker dieser Fabe angegeben wurde, unabhängig davon, was ihm in Backend zugewiesen wird.

Bug!

In meiner DB war mir aufgefallen, dass die Glyph-Spalte in der falschen Tabelle war. Ich hab da nicht weiter drauf geachtet, in Entwicklungsumgebungen kann das ja schon mal passieren. (Wenn man 3 CMS parallel auf hat landen die Sachen auch schon mal in der falschen Datenbank, da ist die falsche Tabelle ja nun wirklich eine Kleinigkeit...) Aber Deiner Beobachtung nach scheint der Fehler dann ja doch im Release gelandet zu sein. Die Spalte "glyph" gehört in die Tabelle "*_markers" und sonst nirgendwohin. Wenn Du sie noch woanders hast, bitte mal löschen und nochmal testen.

Edit: Daran scheint es nicht zu liegen, ich schau mal nach.

Edit 2: Liegt am JavaScript, tatsächlich habe ich pro Icon nur einen Glyph vorgesehen.

Edit 3: Also doch ein Feature. devil

Last edited by webbird (25.09.2017 18:08:40)


Some people just need a high-five. In the face. With a chair.

Offline

#28 25.09.2017 18:08:18

webbird
Developer

Re: LeafletMaps Darstellungsfehler

Versuch's mal hiermit.


Some people just need a high-five. In the face. With a chair.

Offline

#29 25.09.2017 18:18:08

florian
Projektmanagement und Support WBCE CMS

Re: LeafletMaps Darstellungsfehler

Jep, damit tritt der Bug nicht mehr auf.  thumb_up

Offline

#30 25.09.2017 19:11:01

webbird
Developer

Re: LeafletMaps Darstellungsfehler

Gut, nächste Version gibt es dann, wenn ich das Modul mit BC 1 und 2 getestet habe. Bis dahin könnt Ihr ja das JS aus dem Thread nehmen und manuell austauschen.


Some people just need a high-five. In the face. With a chair.

Offline

Board footer

Powered by FluxBB

up