WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 11.11.2020 14:54:50

antons
Member

[solved] CKEditor not working

I have done fresh installation right now.

Unfortunately the CKEditor not working. No signs at all.

Default installation.

Help, please!
Ubuntu server 18.04
WBCE Version: 1.4.5
PHP Version: 7.2.24

Last edited by florian (11.11.2020 18:00:31)

Offline

#2 11.11.2020 15:16:26

florian
Administrator

Re: [solved] CKEditor not working

Which language do you use in the WBCE backend?
Which browser?

Please press F12 to open the browser's developer tools and choose "console", are there any JS errors (red text) displayed?

Offline

#3 11.11.2020 15:21:17

antons
Member

Re: [solved] CKEditor not working

I tried different backend languages: russian, english, latvian

Offline

#4 11.11.2020 15:24:45

florian
Administrator

Re: [solved] CKEditor not working

Please check the error console of the browser as described and have also a look at Admintools > Error Log Viewer, if there are any entries.
Try also to uninstall / reinstall CKE. (Download here)

Offline

#5 11.11.2020 15:33:01

antons
Member

Re: [solved] CKEditor not working

Errors:
Failed to load resource: the server responded with a status of 404 (Not Found)

Uncaught ReferenceError CKEDITOR is not defined at modify.php?pageid=1:115

Offline

#6 11.11.2020 15:36:56

antons
Member

Re: [solved] CKEditor not working

Offline

#7 11.11.2020 15:41:28

florian
Administrator

Re: [solved] CKEditor not working

Check your config.php. If there's a slash at the end of WB_URL, remove it.

Offline

#8 11.11.2020 17:04:45

antons
Member

Re: [solved] CKEditor not working

Thank You for response. No extra slash. The WBCM is installed into sub directory.

define('WB_URL', 'http://mail.balvurcb.lv/test');

Offline

#9 11.11.2020 17:16:09

florian
Administrator

Re: [solved] CKEditor not working

Are you sure? I can see here a double slash, and that only happens if there's an unwanted trailing slash in the config.php.

Offline

#10 11.11.2020 17:24:06

antons
Member

Re: [solved] CKEditor not working

Sorry, it was for one moment. As experiment I add slash at the end, test it, and remove it. Now it is no slash.
define('DB_CHARSET', 'utf8');
define('TABLE_PREFIX', 'wbce1_');

define('WB_URL', 'http://mail.balvurcb.lv/test'); // no leading/trailing slash or backslash.
define('ADMIN_DIRECTORY', 'admin'); // no leading/trailing slash or backslash. A simple directory name only.


require_once(dirname(__FILE__).'/framework/initialize.php');
// end of file -------------

Last edited by antons (11.11.2020 17:24:59)

Offline

#11 11.11.2020 17:32:28

florian
Administrator

Re: [solved] CKEditor not working

Uninistalling / Re-installing CKE as mentioned in #4 above did not help either?

Offline

#12 11.11.2020 17:32:50

antons
Member

Re: [solved] CKEditor not working

I have another message in debug console (Firefox)
Cannot download (script) with source http://mail.balvurcb.lv/home/test/modul … .js?t=K87C

There is an extra word "home" in the path.

Offline

#13 11.11.2020 17:33:40

antons
Member

Re: [solved] CKEditor not working

florian wrote:

Uninistalling / Re-installing CKE as mentioned in #4 above did not help either?

No results

Offline

#14 11.11.2020 17:37:10

florian
Administrator

Re: [solved] CKEditor not working

is there a .htaccess in the root, or any other way of URL/path rewriting?

NB: WBCE has no problems being installed in a subdir and/or on a subdomain, might be an issue with the server's configuration.

I would never use a mailserver for website testing anyway. If you need webspace for testing WBCE, have a look at bplaced, there you can get some webspace with PHP and a database for free.

Offline

#15 11.11.2020 17:43:03

antons
Member

Re: [solved] CKEditor not working

OK Thanks for response. Seems to be server. I appreciate Your help. There is no .htaccess

No rewrite rules.

May be... I use symlinks to web directory. Files actually placed in users directory, then symlink to /var/www/html

Last edited by antons (11.11.2020 17:46:54)

Offline

#16 11.11.2020 17:53:42

antons
Member

Re: [solved] CKEditor not working

Yes, If I install into /var/www/html/sub-folder directly, all works.

Thank You!

Offline

Liked by:

florian

Board footer

Powered by FluxBB

up