WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 28.03.2024 09:32:50

florian
Administrator

Test wbProfiles 2.0 ALPHA

1. Die Installation aus dem Zip funktioniert nicht, auch wenn die wav-Dateien von securimage, die den Installer so aufblähen, rausgenommen werden.
Es wird nur das Verzeichnis /modules/wblib, aber nicht /modules/wbProfiles erzeugt.

2. Lösche ich im Installer die /inc/wblib/info.php, scheint die Installation zu klappen.
Allerdings muss dann noch Erweiterungen > erweitert > Module neu laden aufgerufen werden, damit wbP auch in der Liste der installierten Module erscheint.

3. Nach Anlegen eines neuen Eintrags erscheint

SQLSTATE[42000]: Syntax error or access violation: 1055 Expression #1 of SELECT list is not in GROUP BY clause and contains nonaggregated column 'db12345.t1.item_id' which is not functionally dependent on columns in GROUP BY clause; this is incompatible with sql_mode=only_full_group_by

Der Eintrag wird angelegt, erscheint aber nur unter "Neue Einträge", nicht jedoch bei "Einträge" (dort weiterhin der o.g. Fehlerhinweis).

4. Änderungen der Einstellungen: Speichern bricht ab mit

Unable to open base directory [/homepages/.../media/wbProfiles/profile_files_for_section_51]

Errorlog:

2024-03-28T07:29:49+00:00 [Warning] /modules/wbProfiles/inc/wbProfilesBase.php:[749] from /modules/wbProfiles/inc/wbProfilesBase.php:[761] wbProfilesBase->getDirectories "opendir(/.../media/wbProfiles/profile_files_for_section_51): Failed to open directory: Permission denied"

Das Verzeichnis ist da, hat aber (Nicht-)Zugriffsrechte, die ich so auch noch nicht gesehen habe. (1363), siehe Screenshot im Anhang.

Last edited by florian (28.03.2024 09:33:05)


Code allein macht nicht glücklich. Jetzt spenden!

Offline

#2 28.03.2024 17:24:23

webbird
Administrator

Re: Test wbProfiles 2.0 ALPHA

Danke erst mal für den Test. thumb_up

Zu 1.: Wegen der Größe müßte das eigentlich schon am Upload scheitern. big_smile Wenn Du das per FTP machst, wie im Beitrag zu v2 beschrieben, sollte es eigentlich keine Probleme geben. Zumindest hat es bei mir geklappt. Aber ich teste das nochmal, ich will eh noch das ZIP so weit strippen wie es geht. Wenn WBCE wegen der info.php durcheinander kommt, benenne ich die halt um. wink

Zu 2.: Sicherlich ein Folgefehler.

Zu 3.: Versuche ich mal zu reproduzieren. Ich entwickle auf USBWebserverV10.

Zu 4.: Strange, ich erzeuge das Verzeichnis mit mkdir(...vz..., 0770), "eigentlich schon immer". Ich hab derzeit aber auch keine Linux-Umgebung zum Test zur Hand.

Bitte noch Versionsinformationen zu PHP und mySQL plus ggfs. weitere Besonderheiten.


Ich habe eine Amazon-Wishlist. wink Oder spende an das Projekt.
Ich kann, wenn ich will, aber wer will, dass ich muss, kann mich mal

Offline

#3 28.03.2024 17:26:17

webbird
Administrator

Re: Test wbProfiles 2.0 ALPHA

sql_mode in USBWebserver: sql_mode=NO_ENGINE_SUBSTITUTION,STRICT_TRANS_TABLES


Ich habe eine Amazon-Wishlist. wink Oder spende an das Projekt.
Ich kann, wenn ich will, aber wer will, dass ich muss, kann mich mal

Offline

#4 28.03.2024 17:32:36

florian
Administrator

Re: Test wbProfiles 2.0 ALPHA

(Das ist auf einem anderen Server als für die S.-I.)

Da läuft:
PHP 8.2.17
upload_max_filesize

MySQL 8.0
ONLY_FULL_GROUP_BY, STRICT_TRANS_TABLES, NO_ZERO_IN_DATE, NO_ZERO_DATE, ERROR_FOR_DIVISION_BY_ZERO, NO_ENGINE_SUBSTITUTION

Last edited by florian (28.03.2024 17:32:58)


Code allein macht nicht glücklich. Jetzt spenden!

Offline

#5 28.03.2024 17:39:23

webbird
Administrator

Re: Test wbProfiles 2.0 ALPHA

Zu 3.: Änder mal in der wbProfilesBase.php folgenden Abschnitt (liegt so um Zeile 1835 herum):

[== PHP ==]
            // ----- apply filter -----
            if ($cat_id && !$filter) {
                #if ($this->_current_settings['allow_duplicates'] != 'yes') {
                #    $group_by  = 't1.item_name';
                #} else {
                #    $group_by  = 't1.item_id';
                #}
                $where[]  = 't1.cat_id == ?';
                $params[] = $cat_id;
            }

Last edited by webbird (28.03.2024 17:39:57)


Ich habe eine Amazon-Wishlist. wink Oder spende an das Projekt.
Ich kann, wenn ich will, aber wer will, dass ich muss, kann mich mal

Offline

#6 28.03.2024 17:50:11

florian
Administrator

Re: Test wbProfiles 2.0 ALPHA

thumb_up damit geht's

Last edited by florian (28.03.2024 17:50:26)


Code allein macht nicht glücklich. Jetzt spenden!

Offline

#7 28.03.2024 18:13:39

webbird
Administrator

Re: Test wbProfiles 2.0 ALPHA

Ich weiß noch nicht, welche Folgen das möglicherweise hat, aber das müßten weitere Tests zeigen.

Ich verabschiede mich jetzt erst mal in die Osterfeiertage. kiss


Ich habe eine Amazon-Wishlist. wink Oder spende an das Projekt.
Ich kann, wenn ich will, aber wer will, dass ich muss, kann mich mal

Offline

#8 28.03.2024 18:15:13

florian
Administrator

Re: Test wbProfiles 2.0 ALPHA

DANKE!

Und Frohe Ostern!


Code allein macht nicht glücklich. Jetzt spenden!

Offline

#9 05.04.2024 14:06:20

webbird
Administrator

Re: Test wbProfiles 2.0 ALPHA

zu 1.: securimage aus dem ZIP entfernt.
zu 2.: info.php im wblib-Unterverzeichnis umbenannt
zu 3.: Sollte behoben sein
zu 4.: Seltsame Zugriffsrechte kann ich leider nicht prüfen / nachvollziehen, hab hier nur Windows

Neues Zip hier. https://forum.wbce.org/viewtopic.php?pid=43538#p43538


Ich habe eine Amazon-Wishlist. wink Oder spende an das Projekt.
Ich kann, wenn ich will, aber wer will, dass ich muss, kann mich mal

Offline

#10 Yesterday 16:50:10

Slugger
Member

Re: Test wbProfiles 2.0 ALPHA

Hallo webbird,

heute auch mal die Alpha probiert:

Nach Installation folgende Meldung:

[== PHP ==]
2024-04-13T14:37:13+00:00 [Visitor Request] https://xxx/admin/modules/install.php
2024-04-13T14:37:13+00:00 [Warning] /modules/wbProfiles/install.php:[95] from /admin/modules/install.php:[229] "mkdir(): No such file or directory"

wbProfiles im FTP vorhanden, jedoch nicht im WBCE als Modul zu sehen.

Konfiguration meine Plattform:
PHP VERSION 8.1.27

System:
Linux dd11510 5.4.0-174-generic #193-Ubuntu SMP Thu Mar 7 14:29:28 UTC 2024 x86_64

Server-Typ: MariaDB
Server-Version: 10.5.23-MariaDB

Bin noch mit WBCE 1.5.4 unterwegs

Bei Wiederholung der Installation, sagt das System, Modul bereits installiert.

Last edited by Slugger (Yesterday 16:53:52)


Hoster: ALL-INKL *** Grundsätzliche WBCE Konfig ***
WBCE: 1.5.4 • BE: 2.1.0 • PHP: 8.1.16 * 1. Projekt: FE: Simple responsive • BE: Argos * 2. Projekt: FE: hortal • BE: Argos * 3. Projekt: FE: WBCEZon • BE: Argos * 4. Projekt: FE: WBCETik • BE: Argos
Status Projekt 1-4:  OK

Offline

Board footer

up