WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 17.10.2021 17:42:48

chap
Member

[gelöst] 3 Topics Droplets funktionieren nach Update von 1.4.3 auf 1.5.1 nicht mehr

Hallo,

vorab: Mir ist bekannt das Topics nicht mehr Supportet wird. Leider bietet aber kein anderes Plugin hier das was ich benötige alles.

Ich habe nun endlich nach einigen Wochen es mal auch geschafft die Webseite www.xprog.de von 1.4.3 auf die aktuelle 1.5.1 zu Updaten.
Dabei ist nun das Problem, dass  aktuell was ich sehen kann, drei Droplets nicht mehr funktionieren. Sie liefern die Beiträge leider Links im Menü nicht mehr aus und im Breaking News auch nicht. Zu sehen auf meiner Webseite: www.xprog.de.

Im Anhang sind die drei Droplets angehängt.
Vielleicht kann sich das einer Ansehen und mir sagen, was ich machen muss, oder direkt die Lösung geben!

Herzlichen Dank!

Last edited by florian (18.10.2021 06:05:54)


Liebe Grüße,
cHAp

Offline

#2 17.10.2021 17:57:26

bernd
Developer

Re: [gelöst] 3 Topics Droplets funktionieren nach Update von 1.4.3 auf 1.5.1 nicht mehr

Release-Notes lesen wir eindeutig überbewertet!

Die Release-Notes zu 1.5.1 sagen eindeutig man möge bitte auch die https://forum.wbce.org/viewtopic.php?id=4339 beachten.
Und dort steht:

(Feature mit Breaking Change) PHP 8-Kompatibilität hergestellt (Module, die noch MYSQL_ASSOC verwenden, funktionieren nicht mehr!)

Das wäre das erste nach dem ich - bei Droplets für solch ein altes, nicht mehr unterstütztes Modul - schauen würde...

Und bevor du fragst: alle Vorkommen von MYSQL_ASSOC müssen durch MYSQLI_ASSOC ersetzt werden.


... nein in Europa verwenden wir beim Programmieren nicht € statt $ ...

Online

#3 17.10.2021 18:00:40

chap
Member

Re: [gelöst] 3 Topics Droplets funktionieren nach Update von 1.4.3 auf 1.5.1 nicht mehr

Ja stimmt, ich hab mir das Grad nochmal genauer angeschaut. Ich werde das mal ergänzen. Stimmt, das war erst auch auf ein anderen Script außerhalb von WBCE im gespräch. Ich sollte wieder mehr Schlafen und nicht Ständig arbeiten! :-D Danke Dir für den Hinweis! :-D Läuft wieder. smile


Liebe Grüße,
cHAp

Offline

#4 17.10.2021 18:10:41

chap
Member

Re: [gelöst] 3 Topics Droplets funktionieren nach Update von 1.4.3 auf 1.5.1 nicht mehr

Falls wer noch Topics einsetzen sollte. Im Plugins/Topics sind paar PHP Dateien die entsprechend korrigiert werden müssten wegen den MYSQL_ASSOC auf MYSQLI_ASSOC.

Danke Bernd für den Hinweis nochmal. smile


Liebe Grüße,
cHAp

Offline

Liked by:

screamindan

#5 17.10.2021 18:46:04

bernd
Developer

Re: [gelöst] 3 Topics Droplets funktionieren nach Update von 1.4.3 auf 1.5.1 nicht mehr

Nur zum bessern Verständnis dieses MYSQL / MYSQLI Geraffels:

Die MYSQL-Extension (also die ohne I) war bereits seit PHP5.5 (Mitte 2013) "deprecated" und wurde mit Erscheinen von PHP7.0 (Ende 2015) entfernt und durch die MYSQLI-Extension ersetzt.

WBCE hatte seither einen "Würgaround" der die in freier Wildbahn noch zahlreich vorhandenen MYSQL_XXX abfing und klammheimlich nach MYSQLI_XXX umbog, damit nicht gleich alles zusammen bricht.
Nach nunmehr knapp 6 Jahren fanden wir es an der Zeit - nach umfangreichen Bereinigungen des Cores und nahezu aller Module - diesen alten Zopf endlich abzuschneiden und den "Würgaround" zu entfernen.


... nein in Europa verwenden wir beim Programmieren nicht € statt $ ...

Online

Liked by:

screamindan

#6 17.10.2021 19:04:41

chap
Member

Re: [gelöst] 3 Topics Droplets funktionieren nach Update von 1.4.3 auf 1.5.1 nicht mehr

Das glaub ich gerne und ist auch richtig so. Ich hätte das nur gleich aber merken sollen aber na ja. smile Ich hab das im Modulordner von Topics nun auch alles entsprechend geändert. smile Ansonsten wird ja groß keine Module verwendet big_smile


Liebe Grüße,
cHAp

Offline

#7 18.10.2021 12:40:21

screamindan
Member

Re: [gelöst] 3 Topics Droplets funktionieren nach Update von 1.4.3 auf 1.5.1 nicht mehr

chap wrote:

Falls wer noch Topics einsetzen sollte. Im Plugins/Topics sind paar PHP Dateien die entsprechend korrigiert werden müssten wegen den MYSQL_ASSOC auf MYSQLI_ASSOC.

Danke Bernd für den Hinweis nochmal. smile

Moin. Ich verwende auch noch das Topics. Kannst Du bitte mal schreiben, welche Dateien genau geändert werden müssen?

Offline

#8 18.10.2021 13:08:52

chap
Member

Re: [gelöst] 3 Topics Droplets funktionieren nach Update von 1.4.3 auf 1.5.1 nicht mehr

Moin,

Also...

/topics/droplets/topics_rss_statistic.php
/topics/modify_topic.php
/topics/rss.php
/topics/search.php

Dort hab ich Änderungen noch vornehmen müssen. Ich Empfehle aber schau dir alle Dateien in Topics an. Da wir Zeit zu Zeit das Topics weiter entwickelt haben, kann es sein das sich das MYSQL_ASSOC bei Änderungen bei uns schon in MYSQLI_ASSOC geändert hatte.


Liebe Grüße,
cHAp

Offline

Liked by:

screamindan

#9 18.10.2021 16:54:55

bernd
Developer

Re: [gelöst] 3 Topics Droplets funktionieren nach Update von 1.4.3 auf 1.5.1 nicht mehr

Unter Linux gibt es ja dankenswerterweise mit "grep" einen mächtigen Kommandozeilen-Befehl für solche Fälle  lol

grep -RiIl '(MYSQL_ASSOC)'

Durchsucht ein Verzeichnis rekursiv nach dem String "(MYSQL_ASSOC)" und listet die Dateien der Fundstellen auf.
Kombiniert man das mit bischen weiterer Kommandozeilen "Magie"

grep -RiIl '(MYSQL_ASSOC)' | xargs sed -i 's/(MYSQL_ASSOC)/(MYSQLI_ASSOC)/g'

werden sämtliche Vorkommen automatisch ersetzt, ohne das man eine Datei manuell anfassen müßte.

Unter Windows müßte es evtl. was ähnliches geben ...


... nein in Europa verwenden wir beim Programmieren nicht € statt $ ...

Online

Liked by:

chap

#10 18.10.2021 17:34:41

chap
Member

Re: [gelöst] 3 Topics Droplets funktionieren nach Update von 1.4.3 auf 1.5.1 nicht mehr

Top. smile finde ich gut. Da bin ich leider nicht mehr so komform. big_smile


Liebe Grüße,
cHAp

Offline

#11 18.10.2021 19:21:05

florian
Administrator

Re: [gelöst] 3 Topics Droplets funktionieren nach Update von 1.4.3 auf 1.5.1 nicht mehr

Just for the record:
Der Herr Maisriml hat da gefixte Versionen seiner Module (also auch Topics) für bestehende Installationen (siehe Hinweise auf der Seite) bereitgestellt:
https://wbce.at/de/module.php

Last edited by florian (18.10.2021 19:21:18)

Offline

Liked by:

screamindan

#12 18.10.2021 20:08:04

chap
Member

Re: [gelöst] 3 Topics Droplets funktionieren nach Update von 1.4.3 auf 1.5.1 nicht mehr

Ja das hab ich gesehen aber die Droplets sind ja nicht direkt von ihm die ich verwende. Aber das hat sich ja geklärt smile


Liebe Grüße,
cHAp

Offline

Board footer

up