WBCE Home | WBCE Hilfe | WBCE Addon Repository | Impressum | Datenschutz

WBCE CMS Forum

WBCE CMS – Way Better Content Editing.

You are not logged in.

#1 05.06.2017 16:59:10

berny
Member

Backup

Wenn man beim Backup die Dateien sichern will, wird zuerst das Zip File erzeugt, dann aber vermutlich versucht, ein sql auszuführen, was zur Fehlermeldung
Konnte Datei .../modules/backup/backup-sql.php nicht finden
führt.

WBCE 1.1.11

Name: 	Backup
Version: 	2.8.0.6

Bug oder was anderes ?
Reproduzierbar auch in der höheren Version?

Online

#2 06.06.2017 10:21:39

florian
Projektmanagement und Support WBCE CMS

Re: Backup

Konnte ich hier nicht reproduzieren.
Ist denn eine backup-sql.php unter /modules/backup vorhanden? Wenn nicht, einfach aus dem WBCE-Installationspaket dort hin kopieren.

Online

#3 06.06.2017 17:23:40

berny
Member

Re: Backup

Warum wird diese überhaupt aufgerufen, wenn nur Datein gesichert werden?

Muss mir das nochmal genau angucken...

Online

#4 06.06.2017 17:29:30

florian
Projektmanagement und Support WBCE CMS

Re: Backup

Der Name ist irreführend, auch die Dateisicherung läuft über die backup-sql. Ist wohl in grauer Vorzeit da mal nachträglich angeflanscht worden oder so.

Online

#5 08.06.2017 10:55:23

berny
Member

Re: Backup

Ich vermute, dass es beim download-Befehl irgendwie hackt.
Weil, das zip ist da, und dann findet der Browser die Datei nicht mehr.
Es ist jetzt nicht so schlimm, weil ich die Daten manuell herunterladen kann, aber trotzdem komisch...

Wie kann ich das prüfen?

Online

#6 02.02.2018 17:07:16

creatore
Member

Re: Backup

Das Modul (V 2.8.0.7) erstellt beim Datenbackup ZIP auf dem Server. Leider ist diese ZIP defekt.
Kann noch jemand diesen Fehler reproduzieren?

Offline

#7 02.02.2018 17:35:19

florian
Projektmanagement und Support WBCE CMS

Re: Backup

Ein altbekanntes, leider noch nicht gelöstes Problem

https://forum.wbce.org/viewtopic.php?id=405

Online

#8 02.02.2018 19:36:58

creatore
Member

Re: Backup

Danke für den Link. War mir so nicht bekannt.

Offline

#9 02.02.2018 21:27:00

bernd
Developer

Re: Backup

Verständnisfrage:
zumindest in der Version aus dem AOR ist doch

set_time_limit(120);

drin.
2 Minuten ist ja schon 'ne schöne Hausnummer, sollte doch eigentlich reichen? Ok, bei einem gut gefüllten /media kanns schon eng werden.

@Creatore:
wenn du die Möglichkeit hast, zum ausprobieren vielleicht diesen Wert in der backup.sql.php einfach mal erhöhen.


2 x ROT13 hält besser ...

Offline

#10 03.02.2018 08:16:55

florian
Projektmanagement und Support WBCE CMS

Re: Backup

Ich vermute den Timeout als Ursache des Problems, sicher bin ich nicht.
Bei Shared-Hosting-Anbietern lässt sich meist der Timeout nicht wirklich erhöhen, bzw. höhere Werte als der anbieterseitig vorgegebene, der  oft nur bei 30 Sekunden liegt, werden schlichtweg ignoriert.

Online

#11 05.02.2018 20:54:11

creatore
Member

Re: Backup

@bernd
Danke für den Hinweis. Die betreffende Seite liegt auf einem Shared-Hosting.
Ich überlege gerade, ob ich das mal mit der Portable Version oder aufm XAMPP ausprobiere.

Die Vermutung von Florian leuchtet mir ein, insbesondere, da ein ganz sportlicher Medienordner vorhanden ist.

Offline

Board footer

Powered by FluxBB

up